summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2006-09-27 10:08:11 +0000
committerDenis Dupeyron <calchan@gentoo.org>2006-09-27 10:08:11 +0000
commit363f69bd29cd4218b04d74a2350e3bdc6460401a (patch)
tree02a409d0b2149a48b47431428c977a6143fdfc60 /sci-electronics
parentAdd missing dependency over imagemagick for the LaTeX plugin. Thanks to Erdro... (diff)
downloadgentoo-2-363f69bd29cd4218b04d74a2350e3bdc6460401a.tar.gz
gentoo-2-363f69bd29cd4218b04d74a2350e3bdc6460401a.tar.bz2
gentoo-2-363f69bd29cd4218b04d74a2350e3bdc6460401a.zip
Version bump.
(Portage version: 2.1.2_pre1-r2)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/gnucap/ChangeLog10
-rw-r--r--sci-electronics/gnucap/files/digest-gnucap-0.353
-rw-r--r--sci-electronics/gnucap/gnucap-0.35.ebuild41
3 files changed, 53 insertions, 1 deletions
diff --git a/sci-electronics/gnucap/ChangeLog b/sci-electronics/gnucap/ChangeLog
index b05b57b24f74..4ec66c46db15 100644
--- a/sci-electronics/gnucap/ChangeLog
+++ b/sci-electronics/gnucap/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-electronics/gnucap
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gnucap/ChangeLog,v 1.24 2006/09/23 12:38:26 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gnucap/ChangeLog,v 1.25 2006/09/27 10:08:11 calchan Exp $
+
+*gnucap-0.35 (27 Sep 2006)
+
+ 27 Sep 2006; Denis Dupeyron <calchan@gentoo.org> +gnucap-0.35.ebuild:
+ Version bump. Until we sort out the mess created by the development
+ releases, you will probably want to mask them by adding the following line
+ to your package.mask :
+ =sci-electronics/gnucap-2006*
23 Sep 2006; Denis Dupeyron <calchan@gentoo.org> gnucap-20060830.ebuild:
The readline library is in the base profile. So there is no need to
diff --git a/sci-electronics/gnucap/files/digest-gnucap-0.35 b/sci-electronics/gnucap/files/digest-gnucap-0.35
new file mode 100644
index 000000000000..e8ef9d023072
--- /dev/null
+++ b/sci-electronics/gnucap/files/digest-gnucap-0.35
@@ -0,0 +1,3 @@
+MD5 16fc7cacac987ea556753d030f2595b9 gnucap-0.35.tar.gz 1008736
+RMD160 96a3f62ef9e082bb5bf113af86f1372d2896791e gnucap-0.35.tar.gz 1008736
+SHA256 820bd9e32be5b1a4422744c19b371616ace70f48f00768b8afe373f9ded1516b gnucap-0.35.tar.gz 1008736
diff --git a/sci-electronics/gnucap/gnucap-0.35.ebuild b/sci-electronics/gnucap/gnucap-0.35.ebuild
new file mode 100644
index 000000000000..c3dbad0990d4
--- /dev/null
+++ b/sci-electronics/gnucap/gnucap-0.35.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gnucap/gnucap-0.35.ebuild,v 1.1 2006/09/27 10:08:11 calchan Exp $
+
+DESCRIPTION="GNUCap is the GNU Circuit Analysis Package"
+SRC_URI="http://www.gnucap.org/dist/${P}.tar.gz"
+HOMEPAGE="http://www.gnucap.org/"
+
+IUSE="doc examples"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="doc? ( app-text/tetex )"
+
+src_unpack() {
+ unpack ${A} || die "Failed to unpack!"
+ cd ${S}
+
+ # No need to install COPYING and INSTALL
+ sed -i \
+ -e 's: COPYING INSTALL::' \
+ -e 's:COPYING history INSTALL:history:' \
+ doc/Makefile.in || die "sed failed"
+
+ if ! use doc ; then
+ sed -i \
+ -e 's:SUBDIRS = doc examples man:SUBDIRS = doc examples:' \
+ Makefile.in || die "sed failed"
+ fi
+
+ if ! use examples ; then
+ sed -i \
+ -e 's:SUBDIRS = doc examples:SUBDIRS = doc:' \
+ Makefile.in || die "sed failed"
+ fi
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "Installation failed"
+}