summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-06-10 06:49:52 +0000
committerMichael Weber <xmw@gentoo.org>2013-06-10 06:49:52 +0000
commitc7094e03bb7920a7d3da928db5891a0853dccf92 (patch)
tree9f83a715d1cc30517ed24bde266664551bf8d55b /sci-electronics
parentVersion bumps (diff)
downloadgentoo-2-c7094e03bb7920a7d3da928db5891a0853dccf92.tar.gz
gentoo-2-c7094e03bb7920a7d3da928db5891a0853dccf92.tar.bz2
gentoo-2-c7094e03bb7920a7d3da928db5891a0853dccf92.zip
Version bump
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/linsmith/ChangeLog7
-rw-r--r--sci-electronics/linsmith/linsmith-0.99.25.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/sci-electronics/linsmith/ChangeLog b/sci-electronics/linsmith/ChangeLog
index fb74b2f66299..cbf75cc9d2f5 100644
--- a/sci-electronics/linsmith/ChangeLog
+++ b/sci-electronics/linsmith/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/linsmith
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/linsmith/ChangeLog,v 1.15 2013/02/08 21:41:25 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/linsmith/ChangeLog,v 1.16 2013/06/10 06:49:52 xmw Exp $
+
+*linsmith-0.99.25 (10 Jun 2013)
+
+ 10 Jun 2013; Michael Weber <xmw@gentoo.org> +linsmith-0.99.25.ebuild:
+ Version bump
08 Feb 2013; Agostino Sarubbo <ago@gentoo.org> linsmith-0.99.24.ebuild:
Stable for x86, wrt bug #456032
diff --git a/sci-electronics/linsmith/linsmith-0.99.25.ebuild b/sci-electronics/linsmith/linsmith-0.99.25.ebuild
new file mode 100644
index 000000000000..36d53886f348
--- /dev/null
+++ b/sci-electronics/linsmith/linsmith-0.99.25.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/linsmith/linsmith-0.99.25.ebuild,v 1.1 2013/06/10 06:49:52 xmw Exp $
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="Smith charting program, mainly designed for educational use."
+HOMEPAGE="http://www.jcoppens.com/soft/linsmith/index.en.php"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+ x11-libs/gtk+:2
+ dev-libs/libxml2:2
+ dev-libs/glib:2
+ dev-libs/atk
+ gnome-base/libgnome
+ gnome-base/libgnomecanvas
+ gnome-base/libgnomeui"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # This patch is to prevent make install copying
+ # the examples in /usr/share/linsmith
+ # Now they are cp to the correct location.
+ epatch \
+ "${FILESDIR}"/${PN}-datafiles.patch
+
+ # fix QA warnings about wrong categories in .desktop file
+ sed -i -e "s/Application;Engineering;/Education;Science;Electronics;/" \
+ -e "s/Encoding=/#Encoding=/" \
+ ${PN}.desktop || die
+
+ # fix QA warnings about 'maintainer mode'
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto "/usr/share/${PN}"
+ doins datafiles/conv0809
+
+ dodoc AUTHORS ChangeLog NEWS NOTES README THANKS TODO
+ doman doc/${PN}.1
+
+ domenu ${PN}.desktop
+ doicon ${PN}_icon.xpm
+
+ if use doc; then
+ insinto "/usr/share/doc/${PF}"
+ doins doc/manual.pdf
+ fi
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ doins datafiles/*.circ datafiles/*.load || die
+ fi
+}