summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2009-11-02 01:52:04 +0000
committerSteve Arnold <nerdboy@gentoo.org>2009-11-02 01:52:04 +0000
commit7e40af16ce060818c1fcfe54d34f7ebf7e33349e (patch)
tree10b5740c857ef877998b3aaa400af0d2be710253 /sci-geosciences/mapnik
parentremoval of mythdvd since its been on the removal list for over a year and half (diff)
downloadgentoo-2-7e40af16ce060818c1fcfe54d34f7ebf7e33349e.tar.gz
gentoo-2-7e40af16ce060818c1fcfe54d34f7ebf7e33349e.tar.bz2
gentoo-2-7e40af16ce060818c1fcfe54d34f7ebf7e33349e.zip
Updated to latest upstream release and shed some patches (closes bug
291376). (Portage version: 2.2_rc47/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences/mapnik')
-rw-r--r--sci-geosciences/mapnik/ChangeLog8
-rw-r--r--sci-geosciences/mapnik/mapnik-0.6.1.ebuild94
2 files changed, 101 insertions, 1 deletions
diff --git a/sci-geosciences/mapnik/ChangeLog b/sci-geosciences/mapnik/ChangeLog
index a2d3927b686b..8b62db910115 100644
--- a/sci-geosciences/mapnik/ChangeLog
+++ b/sci-geosciences/mapnik/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-geosciences/mapnik
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapnik/ChangeLog,v 1.11 2009/08/22 23:18:09 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapnik/ChangeLog,v 1.12 2009/11/02 01:52:04 nerdboy Exp $
+
+*mapnik-0.6.1 (02 Nov 2009)
+
+ 02 Nov 2009; Steve Arnold <nerdboy@gentoo.org> +mapnik-0.6.1.ebuild:
+ Updated to latest upstream release and shed some patches. Seems to work
+ fine both with and without use=python. Closes bug #291376.
22 Aug 2009; Steve Arnold <nerdboy@gentoo.org> mapnik-0.5.1.ebuild,
mapnik-0.6.0.ebuild:
diff --git a/sci-geosciences/mapnik/mapnik-0.6.1.ebuild b/sci-geosciences/mapnik/mapnik-0.6.1.ebuild
new file mode 100644
index 000000000000..99cf43c0e964
--- /dev/null
+++ b/sci-geosciences/mapnik/mapnik-0.6.1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapnik/mapnik-0.6.1.ebuild,v 1.1 2009/11/02 01:52:04 nerdboy Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A Free Toolkit for developing mapping applications."
+HOMEPAGE="http://www.mapnik.org/"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="cairo curl debug doc +gdal postgres python sqlite"
+
+RDEPEND="dev-libs/boost
+ dev-libs/libxml2
+ dev-libs/icu
+ media-libs/libpng
+ media-libs/jpeg
+ media-libs/tiff
+ media-libs/freetype:2
+ sci-libs/proj
+ x11-libs/agg
+ media-fonts/dejavu
+ python? ( >=dev-libs/boost-1.35.0-r5[python] )
+ cairo? ( x11-libs/cairo
+ dev-cpp/cairomm )
+ postgres? (
+ >=virtual/postgresql-base-8.0
+ >=dev-db/postgis-1.1.2
+ )
+ gdal? ( sci-libs/gdal )
+ sqlite? ( dev-db/sqlite:3 )
+ curl? ( net-misc/curl )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/scons-1.0.0"
+
+src_prepare() {
+ sed -i -e "s|/usr/local|/usr|g" \
+ -e "s|Action(env\[config\]|Action('%s --help' % env\[config\]|" \
+ SConstruct || die
+
+ sed -i -e "s:mapniklibpath + '/fonts':'/usr/share/fonts/dejavu/':g" \
+ bindings/python/SConscript || die "sed 1 failed"
+}
+
+src_configure() {
+ MAKEOPTS="INTERNAL_LIBAGG=no"
+
+ MAKEOPTS="${MAKEOPTS} INPUT_PLUGINS="
+ use postgres && MAKEOPTS="${MAKEOPTS}postgis,"
+ use gdal && MAKEOPTS="${MAKEOPTS}gdal,ogr,"
+ use sqlite && MAKEOPTS="${MAKEOPTS}sqlite,"
+ use curl && MAKEOPTS="${MAKEOPTS}osm,"
+ MAKEOPTS="${MAKEOPTS}shape,raster"
+
+ use cairo || MAKEOPTS="${MAKEOPTS} CAIRO=false"
+ use python || MAKEOPTS="${MAKEOPTS} BINDINGS=none"
+ use debug && MAKEOPTS="${MAKEOPTS} DEBUG=yes"
+
+ use postgres && use sqlite && MAKEOPTS="${MAKEOPTS} PGSQL2SQLITE=yes"
+
+ scons CXX="$(tc-getCXX)" ${MAKEOPTS} DESTDIR="${D}" configure \
+ || die "scons configure failed"
+}
+
+src_compile() {
+ scons || die "scons make failed"
+}
+
+src_install() {
+ scons install || die "scons install failed"
+
+ if use python ; then
+ fperms o-w /usr/lib/python*/site-packages/mapnik/paths.py
+ dobin utils/stats/mapdef_stats.py
+ insinto /usr/share/doc/${P}/examples
+ doins utils/ogcserver/*
+ fi
+
+ dodoc AUTHORS CHANGELOG README
+ use doc && dohtml -r docs/api_docs/python/*
+}
+
+pkg_postinst() {
+ elog ""
+ elog "See the home page or the OpenStreetMap wiki for more info, and"
+ elog "the installed examples for the default mapnik ogcserver config."
+ elog ""
+}