summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-05-02 19:01:42 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-05-02 19:01:42 +0000
commitffe8c44115d80c7e7de901067a01b69d448e7892 (patch)
tree8fad80cf2bd795619073c3f3b5603598c43898ab /sci-geosciences/mapserver
parent[bump] dev-perl/GD-2.460.0 (diff)
downloadgentoo-2-ffe8c44115d80c7e7de901067a01b69d448e7892.tar.gz
gentoo-2-ffe8c44115d80c7e7de901067a01b69d448e7892.tar.bz2
gentoo-2-ffe8c44115d80c7e7de901067a01b69d448e7892.zip
Try to support php too. Sadly it fails with gcc-4.6
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences/mapserver')
-rw-r--r--sci-geosciences/mapserver/ChangeLog6
-rw-r--r--sci-geosciences/mapserver/mapserver-6.0.0_rc1.ebuild20
2 files changed, 19 insertions, 7 deletions
diff --git a/sci-geosciences/mapserver/ChangeLog b/sci-geosciences/mapserver/ChangeLog
index 143d089c833c..6835491e4853 100644
--- a/sci-geosciences/mapserver/ChangeLog
+++ b/sci-geosciences/mapserver/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-geosciences/mapserver
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapserver/ChangeLog,v 1.31 2011/05/02 18:40:38 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapserver/ChangeLog,v 1.32 2011/05/02 19:01:42 scarabeus Exp $
+
+ 02 May 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ mapserver-6.0.0_rc1.ebuild:
+ Try to support php too. Sadly it fails with gcc-4.6
02 May 2011; Tomáš Chvátal <scarabeus@gentoo.org>
mapserver-6.0.0_rc1.ebuild:
diff --git a/sci-geosciences/mapserver/mapserver-6.0.0_rc1.ebuild b/sci-geosciences/mapserver/mapserver-6.0.0_rc1.ebuild
index c4925ed57f78..d88ca32ea772 100644
--- a/sci-geosciences/mapserver/mapserver-6.0.0_rc1.ebuild
+++ b/sci-geosciences/mapserver/mapserver-6.0.0_rc1.ebuild
@@ -1,11 +1,16 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapserver/mapserver-6.0.0_rc1.ebuild,v 1.4 2011/05/02 18:40:38 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapserver/mapserver-6.0.0_rc1.ebuild,v 1.5 2011/05/02 19:01:42 scarabeus Exp $
EAPI=3
MY_P="${PN}-${PV/_/-}"
+PHP_EXT_NAME="php_mapscript"
+PHP_EXT_S="${WORKDIR}/${MY_P}/mapscript/php/"
+PHP_EXT_SKIP_PHPIZE="no"
+USE_PHP="php5-3"
+
PYTHON_DEPEND="python? *"
SUPPORT_PYTHON_ABIS="1"
PYTHON_MODNAME="mapscript.py"
@@ -15,7 +20,7 @@ PYTHON_MODNAME="mapscript.py"
WEBAPP_MANUAL_SLOT=yes
-inherit eutils autotools depend.apache webapp distutils perl-module # ruby-ng
+inherit eutils autotools depend.apache webapp distutils perl-module php-ext-source-r2 # ruby-ng
DESCRIPTION="OpenSource development environment for constructing spatially enabled Internet-web applications."
HOMEPAGE="http://mapserver.org"
@@ -25,7 +30,7 @@ LICENSE="MIT"
KEYWORDS="~amd64 ~x86"
# I must check for mygis use flag availability
-IUSE="bidi cairo gdal geos gif mysql opengl perl postgis proj python threads tiff xml xslt" # ruby php tcl
+IUSE="bidi cairo gdal geos gif mysql opengl perl php postgis proj python threads tiff xml xslt" # ruby php tcl
RDEPEND="
dev-libs/expat
@@ -87,7 +92,8 @@ pkg_setup() {
}
src_unpack() {
- default
+ # unpack A and then copy the php thingies into workdir/php-slot
+ php-ext-source-r2_src_unpack
}
src_prepare() {
@@ -109,7 +115,7 @@ src_configure() {
fi
# some scripts require configure time options so place it here
- #use php && myopts+=" --with-php=$(${PHPCONFIG} --include-dir)"
+ use php && myopts+=" --with-php=${EPREFIX}/usr/lib64/php5.3/include/php/"
# sde is ESRI package that you have to buy first
# oraclespatial needs oracle server for testing/usage
@@ -148,10 +154,11 @@ src_configure() {
}
src_compile() {
- default
+ emake -j1 || die
use python && _enter_build_dir "${S}/mapscript/python" "distutils_src_compile"
use perl && _enter_build_dir "${S}/mapscript/perl" "perl-module_src_prep"
use perl && _enter_build_dir "${S}/mapscript/perl" "perl-module_src_compile"
+ use php && php-ext-source-r2_src_compile
#use ruby && _enter_build_dir "${S}/mapscript/ruby" "ruby-ng_src_compile"
}
@@ -173,6 +180,7 @@ src_install() {
use python && _enter_build_dir "${S}/mapscript/python" "distutils_src_install"
use perl && _enter_build_dir "${S}/mapscript/perl" "perl-module_src_install"
use perl && _enter_build_dir "${S}/mapscript/perl" "fixlocalpod"
+ use php && php-ext-source-r2_src_install
#use ruby && _enter_build_dir "${S}/mapscript/ruby" "ruby-ng_src_install"
webapp_src_preinst