summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-08-25 17:00:54 +0000
committerMike Gilbert <floppym@gentoo.org>2013-08-25 17:00:54 +0000
commit2bd6c76320f2bfbc479cc7f52bd84bef98966b28 (patch)
tree552f38f7ac93fbfa2a21a33d2bcc9fb6edacddd0 /sci-geosciences
parentVersion bump, bug #480916. (diff)
downloadgentoo-2-2bd6c76320f2bfbc479cc7f52bd84bef98966b28.tar.gz
gentoo-2-2bd6c76320f2bfbc479cc7f52bd84bef98966b28.tar.bz2
gentoo-2-2bd6c76320f2bfbc479cc7f52bd84bef98966b28.zip
Fix the live ebuild and convert to distutils-r1.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gpsd/ChangeLog5
-rw-r--r--sci-geosciences/gpsd/gpsd-9999.ebuild49
2 files changed, 19 insertions, 35 deletions
diff --git a/sci-geosciences/gpsd/ChangeLog b/sci-geosciences/gpsd/ChangeLog
index 96f90bbe633a..4f98e0dfff54 100644
--- a/sci-geosciences/gpsd/ChangeLog
+++ b/sci-geosciences/gpsd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-geosciences/gpsd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.108 2013/08/24 12:34:41 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.109 2013/08/25 17:00:54 floppym Exp $
+
+ 25 Aug 2013; Mike Gilbert <floppym@gentoo.org> gpsd-9999.ebuild:
+ Fix the live ebuild and convert to distutils-r1.
24 Aug 2013; Agostino Sarubbo <ago@gentoo.org> gpsd-3.9.ebuild:
Stable for ppc64, wrt bug #468262
diff --git a/sci-geosciences/gpsd/gpsd-9999.ebuild b/sci-geosciences/gpsd/gpsd-9999.ebuild
index 0bfebe0e453f..a4cc18f68dc3 100644
--- a/sci-geosciences/gpsd/gpsd-9999.ebuild
+++ b/sci-geosciences/gpsd/gpsd-9999.ebuild
@@ -1,15 +1,14 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-9999.ebuild,v 1.12 2013/03/30 20:37:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-9999.ebuild,v 1.13 2013/08/25 17:00:54 floppym Exp $
-EAPI="4"
+EAPI="5"
-PYTHON_DEPEND="python? 2:2.6"
-RESTRICT_PYTHON_ABIS="3.*"
-SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python{2_6,2_7} )
SCONS_MIN_VERSION="1.2.1"
-inherit eutils udev user multilib distutils scons-utils toolchain-funcs
+inherit eutils udev user multilib distutils-r1 scons-utils toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.savannah.nongnu.org/gpsd.git"
@@ -34,9 +33,10 @@ GPSD_PROTOCOLS=(
IUSE_GPSD_PROTOCOLS=${GPSD_PROTOCOLS[@]/#/gpsd_protocols_}
IUSE="${IUSE_GPSD_PROTOCOLS} bluetooth cxx debug dbus ipv6 latency_timing ncurses ntp python qt4 +shm +sockets test udev usb X"
REQUIRED_USE="X? ( python )
- gpsd_protocols_nmea2000? ( gpsd_protocols_aivdm )"
+ gpsd_protocols_nmea2000? ( gpsd_protocols_aivdm )
+ python? ( ${PYTHON_REQUIRED_USE} )"
-RDEPEND="X? ( dev-python/pygtk:2 )
+RDEPEND="X? ( dev-python/pygtk:2[${PYTHON_USEDEP}] )
ncurses? ( sys-libs/ncurses )
bluetooth? ( net-wireless/bluez )
usb? ( virtual/libusb:1 )
@@ -45,7 +45,8 @@ RDEPEND="X? ( dev-python/pygtk:2 )
dev-libs/dbus-glib
)
ntp? ( || ( net-misc/ntp net-misc/chrony ) )
- qt4? ( dev-qt/qtgui:4 )"
+ qt4? ( dev-qt/qtgui:4 )
+ python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}
virtual/pkgconfig
test? ( sys-devel/bc )"
@@ -57,13 +58,7 @@ if [[ ${PV} == "9999" ]] ; then
=app-text/docbook-xml-dtd-4.1*"
fi
-pkg_setup() {
- use python && python_pkg_setup
-}
-
-src_unpack() {
- default
-
+src_prepare() {
# Make sure our list matches the source.
local src_protocols=$(echo $(
sed -n '/GPS protocols/,/Time service/{s:#.*::;s:[(",]::g;p}' "${S}"/SConstruct | awk '{print $1}' | LC_ALL=C sort
@@ -73,16 +68,13 @@ src_unpack() {
eerror "Ebuild protocols: ${GPSD_PROTOCOLS[*]}"
die "please sync ebuild & source"
fi
-}
-src_prepare() {
epatch "${FILESDIR}"/${PN}-3.8-ldflags.patch
epatch "${FILESDIR}"/${PN}-3.8-libgps.patch
epatch "${FILESDIR}"/${PN}-3.8-udev.patch
epatch "${FILESDIR}"/${PN}-3.4-no-man-gen.patch
epatch "${FILESDIR}"/${PN}-3.7-rpath.patch
epatch "${FILESDIR}"/${PN}-3.7-gps_regress.patch #441760
- epatch "${FILESDIR}"/${PN}-3.8-no-export-t.patch #463850
# Avoid useless -L paths to the install dir
sed -i \
@@ -106,7 +98,7 @@ src_prepare() {
-e "s|@GPS_CLIENT_SOURCES@|${client}|" \
-e "s|@SCRIPTS@|$(pyvar python_progs)|" \
"${FILESDIR}"/${PN}-3.3-setup.py > setup.py || die
- distutils_src_prepare
+ distutils-r1_src_prepare
fi
}
@@ -148,7 +140,7 @@ src_compile() {
export SHLINKFLAGS=${LDFLAGS} LINKFLAGS=${LDFLAGS}
escons
- use python && distutils_src_compile
+ use python && distutils-r1_src_compile
}
src_install() {
@@ -158,13 +150,10 @@ src_install() {
newinitd "${FILESDIR}"/gpsd.init-2 gpsd
if use python ; then
- distutils_src_install
+ distutils-r1_src_install
# Delete all X related packages if user doesn't want them
if ! use X ; then
- local p
- for p in $(grep -Il 'import .*pygtk' *) ; do
- find "${D}"/usr/bin -name "${p}*" -delete
- done
+ rm "${ED%/}"/usr/bin/xgps* || die
fi
fi
}
@@ -174,11 +163,3 @@ pkg_preinst() {
# as it doesn't seem to be needed during compile/install ...
enewuser gpsd -1 -1 -1 "uucp"
}
-
-pkg_postinst() {
- use python && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use python && distutils_pkg_postrm
-}