summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2009-08-19 02:59:58 +0000
committerSteve Arnold <nerdboy@gentoo.org>2009-08-19 02:59:58 +0000
commit5589a90c1c0ffd1213a9e75d17fe6d7046650b46 (patch)
treed837af1030c71360e10bb6089c259af0485d230d /sci-geosciences
parentamd64 stable, all tests passed. bug 281699 (diff)
downloadgentoo-2-5589a90c1c0ffd1213a9e75d17fe6d7046650b46.tar.gz
gentoo-2-5589a90c1c0ffd1213a9e75d17fe6d7046650b46.tar.bz2
gentoo-2-5589a90c1c0ffd1213a9e75d17fe6d7046650b46.zip
Updated postgres deps to explicitly exclude libpq.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/mapnik/ChangeLog9
-rw-r--r--sci-geosciences/mapnik/mapnik-0.5.1.ebuild12
-rw-r--r--sci-geosciences/mapnik/mapnik-0.6.0.ebuild12
3 files changed, 26 insertions, 7 deletions
diff --git a/sci-geosciences/mapnik/ChangeLog b/sci-geosciences/mapnik/ChangeLog
index 8a563a64668a..f872ff357f7b 100644
--- a/sci-geosciences/mapnik/ChangeLog
+++ b/sci-geosciences/mapnik/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-geosciences/mapnik
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapnik/ChangeLog,v 1.9 2009/06/17 07:05:44 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapnik/ChangeLog,v 1.10 2009/08/19 02:59:58 nerdboy Exp $
+
+ 19 Aug 2009; Steve Arnold <nerdboy@gentoo.org> mapnik-0.5.1.ebuild,
+ mapnik-0.6.0.ebuild:
+ Updated postgres deps to explicitly exclude libpq (which will not work).
+ The virtual is currently not an option, and none of the new postgresql
+ packages have been stablized yet, so this is the only way mapnik (and a
+ few other packages) can go stable.
17 Jun 2009; Alfredo Tupone <tupone@gentoo.org> mapnik-0.6.0.ebuild:
Selecting boost version that has python IUSE. Bug #274358 by Arjen Robbemond
diff --git a/sci-geosciences/mapnik/mapnik-0.5.1.ebuild b/sci-geosciences/mapnik/mapnik-0.5.1.ebuild
index 6f23f22fa476..48190aeb1e66 100644
--- a/sci-geosciences/mapnik/mapnik-0.5.1.ebuild
+++ b/sci-geosciences/mapnik/mapnik-0.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapnik/mapnik-0.5.1.ebuild,v 1.7 2009/01/04 19:48:41 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapnik/mapnik-0.5.1.ebuild,v 1.8 2009/08/19 02:59:58 nerdboy Exp $
inherit eutils toolchain-funcs
@@ -22,8 +22,14 @@ RDEPEND=">=dev-libs/boost-1.33.0
>=sci-libs/proj-4.4.9
sci-libs/gdal
xml? ( dev-libs/libxml2 )
- postgres? ( >=dev-db/postgresql-base-8.3
- >=dev-db/postgis-1.1.2 )
+ postgres? ( || (
+ >=dev-db/postgresql-8.0
+ >=dev-db/postgresql-base-8.0
+ >=dev-db/postgresql-server-8.0
+ )
+ !dev-db/libpq
+ >=dev-db/postgis-1.1.2
+ )
python? ( >=dev-lang/python-2.4 )
bidi? ( dev-libs/fribidi )"
diff --git a/sci-geosciences/mapnik/mapnik-0.6.0.ebuild b/sci-geosciences/mapnik/mapnik-0.6.0.ebuild
index a6ad02fe7eae..57c8c3812d8f 100644
--- a/sci-geosciences/mapnik/mapnik-0.6.0.ebuild
+++ b/sci-geosciences/mapnik/mapnik-0.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapnik/mapnik-0.6.0.ebuild,v 1.3 2009/06/17 07:05:44 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapnik/mapnik-0.6.0.ebuild,v 1.4 2009/08/19 02:59:58 nerdboy Exp $
EAPI=2
inherit eutils toolchain-funcs
@@ -26,8 +26,14 @@ RDEPEND="dev-libs/boost
python? ( >=dev-libs/boost-1.35.0-r5[python] )
cairo? ( x11-libs/cairo
dev-cpp/cairomm )
- postgres? ( >=dev-db/postgresql-base-8.3
- >=dev-db/postgis-1.1.2 )
+ postgres? ( || (
+ >=dev-db/postgresql-base-8.0
+ >=dev-db/postgresql-server-8.0
+ >=dev-db/postgresql-8.0
+ )
+ !dev-db/libpq
+ >=dev-db/postgis-1.1.2
+ )
gdal? ( sci-libs/gdal )
sqlite? ( dev-db/sqlite:3 )
curl? ( net-misc/curl )"