summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-05-23 14:20:01 +0000
committerMike Frysinger <vapier@gentoo.org>2012-05-23 14:20:01 +0000
commit6273f02c17b1c093a0d4fea160608cdd32b3aeb3 (patch)
tree5b58dcefc75be3fdac0bbe33e9e16cac882c3c77 /sci-geosciences
parentRestrict tests for now, acked by yngwin bug #395153. (diff)
downloadgentoo-2-6273f02c17b1c093a0d4fea160608cdd32b3aeb3.tar.gz
gentoo-2-6273f02c17b1c093a0d4fea160608cdd32b3aeb3.tar.bz2
gentoo-2-6273f02c17b1c093a0d4fea160608cdd32b3aeb3.zip
Version bump.
(Portage version: 2.2.0_alpha102/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gpsd/ChangeLog8
-rw-r--r--sci-geosciences/gpsd/files/gpsd-3.6-debug.patch221
-rw-r--r--sci-geosciences/gpsd/files/gpsd-3.6-rpath.patch13
-rw-r--r--sci-geosciences/gpsd/gpsd-3.6.ebuild163
4 files changed, 404 insertions, 1 deletions
diff --git a/sci-geosciences/gpsd/ChangeLog b/sci-geosciences/gpsd/ChangeLog
index f460f0c0b9b5..c4a8cb6bb299 100644
--- a/sci-geosciences/gpsd/ChangeLog
+++ b/sci-geosciences/gpsd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-geosciences/gpsd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.85 2012/05/21 22:37:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.86 2012/05/23 14:20:01 vapier Exp $
+
+*gpsd-3.6 (23 May 2012)
+
+ 23 May 2012; Mike Frysinger <vapier@gentoo.org> +files/gpsd-3.6-debug.patch,
+ +files/gpsd-3.6-rpath.patch, +gpsd-3.6.ebuild:
+ Version bump.
*gpsd-3.5 (21 May 2012)
diff --git a/sci-geosciences/gpsd/files/gpsd-3.6-debug.patch b/sci-geosciences/gpsd/files/gpsd-3.6-debug.patch
new file mode 100644
index 000000000000..ecaf717b7391
--- /dev/null
+++ b/sci-geosciences/gpsd/files/gpsd-3.6-debug.patch
@@ -0,0 +1,221 @@
+From 07ecfcc72d977cfd364f0337032d5be7a0ff64e0 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Wed, 23 May 2012 10:09:26 -0400
+Subject: [PATCH] nmea2000: fix build failures when debugging is disabled
+
+When debugging is disabled, there is no libgps_debuglevel, so building
+this driver fails with:
+driver_nmea2000.c: In function 'print_data':
+driver_nmea2000.c:50:10: error: 'libgps_debuglevel' undeclared (first use in this function)
+
+Add some ifdef to this driver to fix that, and change the return type
+of print_data to void since it always returns 0 and no one ever checks
+the return value.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ driver_nmea2000.c | 45 +++++++++++++++++++++++----------------------
+ 1 files changed, 23 insertions(+), 22 deletions(-)
+
+diff --git a/driver_nmea2000.c b/driver_nmea2000.c
+index 1db6686..b3d2734 100644
+--- a/driver_nmea2000.c
++++ b/driver_nmea2000.c
+@@ -44,8 +44,9 @@ typedef struct PGN
+ FILE *logFile = NULL;
+ #endif /* of if LOG_FILE */
+
+-static int print_data(unsigned char *buffer, int len, PGN *pgn)
++static void print_data(unsigned char *buffer, int len, PGN *pgn)
+ {
++#ifdef LIBGPS_DEBUG
+ /*@-bufferoverflowhigh@*/
+ if ((libgps_debuglevel >= LOG_IO) != 0) {
+ int l1, l2, ptr;
+@@ -67,7 +68,7 @@ static int print_data(unsigned char *buffer, int len, PGN *pgn)
+ gpsd_report(LOG_IO,"%s\n", bu);
+ }
+ /*@+bufferoverflowhigh@*/
+- return(0);
++#endif
+ }
+
+ static gps_mask_t get_mode(struct gps_device_t *session)
+@@ -84,7 +85,7 @@ static gps_mask_t get_mode(struct gps_device_t *session)
+
+ static gps_mask_t hnd_059392(unsigned char *bu, int len, PGN *pgn, struct gps_device_t *session)
+ {
+- (void)print_data(bu, len, pgn);
++ print_data(bu, len, pgn);
+ gpsd_report(LOG_DATA, "pgn %6d(%3d):\n", pgn->pgn, session->driver.nmea2000.unit);
+ return(0);
+ }
+@@ -92,7 +93,7 @@ static gps_mask_t hnd_059392(unsigned char *bu, int len, PGN *pgn, struct gps_de
+
+ static gps_mask_t hnd_060928(unsigned char *bu, int len, PGN *pgn, struct gps_device_t *session)
+ {
+- (void)print_data(bu, len, pgn);
++ print_data(bu, len, pgn);
+ gpsd_report(LOG_DATA, "pgn %6d(%3d):\n", pgn->pgn, session->driver.nmea2000.unit);
+ return(0);
+ }
+@@ -100,7 +101,7 @@ static gps_mask_t hnd_060928(unsigned char *bu, int len, PGN *pgn, struct gps_de
+
+ static gps_mask_t hnd_126208(unsigned char *bu, int len, PGN *pgn, struct gps_device_t *session)
+ {
+- (void)print_data(bu, len, pgn);
++ print_data(bu, len, pgn);
+ gpsd_report(LOG_DATA, "pgn %6d(%3d):\n", pgn->pgn, session->driver.nmea2000.unit);
+ return(0);
+ }
+@@ -108,7 +109,7 @@ static gps_mask_t hnd_126208(unsigned char *bu, int len, PGN *pgn, struct gps_de
+
+ static gps_mask_t hnd_126464(unsigned char *bu, int len, PGN *pgn, struct gps_device_t *session)
+ {
+- (void)print_data(bu, len, pgn);
++ print_data(bu, len, pgn);
+ gpsd_report(LOG_DATA, "pgn %6d(%3d):\n", pgn->pgn, session->driver.nmea2000.unit);
+ return(0);
+ }
+@@ -116,7 +117,7 @@ static gps_mask_t hnd_126464(unsigned char *bu, int len, PGN *pgn, struct gps_de
+
+ static gps_mask_t hnd_126996(unsigned char *bu, int len, PGN *pgn, struct gps_device_t *session)
+ {
+- (void)print_data(bu, len, pgn);
++ print_data(bu, len, pgn);
+ gpsd_report(LOG_DATA, "pgn %6d(%3d):\n", pgn->pgn, session->driver.nmea2000.unit);
+ return(0);
+ }
+@@ -124,7 +125,7 @@ static gps_mask_t hnd_126996(unsigned char *bu, int len, PGN *pgn, struct gps_de
+
+ static gps_mask_t hnd_129025(unsigned char *bu, int len, PGN *pgn, struct gps_device_t *session)
+ {
+- (void)print_data(bu, len, pgn);
++ print_data(bu, len, pgn);
+ gpsd_report(LOG_DATA, "pgn %6d(%3d):\n", pgn->pgn, session->driver.nmea2000.unit);
+
+ /*@-type@*//* splint has a bug here */
+@@ -140,7 +141,7 @@ static gps_mask_t hnd_129025(unsigned char *bu, int len, PGN *pgn, struct gps_de
+
+ static gps_mask_t hnd_129026(unsigned char *bu, int len, PGN *pgn, struct gps_device_t *session)
+ {
+- (void)print_data(bu, len, pgn);
++ print_data(bu, len, pgn);
+ gpsd_report(LOG_DATA, "pgn %6d(%3d):\n", pgn->pgn, session->driver.nmea2000.unit);
+
+ session->driver.nmea2000.sid[0] = bu[0];
+@@ -161,10 +162,10 @@ static gps_mask_t hnd_126992(unsigned char *bu, int len, PGN *pgn, struct gps_de
+ //uint8_t sid;
+ //uint8_t source;
+
+- (void)print_data(bu, len, pgn);
++ print_data(bu, len, pgn);
+ gpsd_report(LOG_DATA, "pgn %6d(%3d):\n", pgn->pgn, session->driver.nmea2000.unit);
+
+- (void)print_data(bu, len, pgn);
++ print_data(bu, len, pgn);
+ gpsd_report(LOG_DATA, "pgn %6d(%3d):\n", pgn->pgn, session->driver.nmea2000.unit);
+
+ //sid = bu[0];
+@@ -187,7 +188,7 @@ static gps_mask_t hnd_129539(unsigned char *bu, int len, PGN *pgn, struct gps_de
+ {
+ gps_mask_t mask;
+
+- (void)print_data(bu, len, pgn);
++ print_data(bu, len, pgn);
+ gpsd_report(LOG_DATA, "pgn %6d(%3d):\n", pgn->pgn, session->driver.nmea2000.unit);
+
+ mask = 0;
+@@ -222,7 +223,7 @@ static gps_mask_t hnd_129540(unsigned char *bu, int len, PGN *pgn, struct gps_de
+ {
+ int l1, l2;
+
+- (void)print_data(bu, len, pgn);
++ print_data(bu, len, pgn);
+ gpsd_report(LOG_DATA, "pgn %6d(%3d):\n", pgn->pgn, session->driver.nmea2000.unit);
+
+ session->driver.nmea2000.sid[2] = bu[0];
+@@ -261,7 +262,7 @@ static gps_mask_t hnd_129029(unsigned char *bu, int len, PGN *pgn, struct gps_de
+ {
+ gps_mask_t mask;
+
+- (void)print_data(bu, len, pgn);
++ print_data(bu, len, pgn);
+ gpsd_report(LOG_DATA, "pgn %6d(%3d):\n", pgn->pgn, session->driver.nmea2000.unit);
+
+ mask = 0;
+@@ -326,7 +327,7 @@ static gps_mask_t hnd_129029(unsigned char *bu, int len, PGN *pgn, struct gps_de
+
+ static gps_mask_t hnd_129038(unsigned char *bu, int len, PGN *pgn, struct gps_device_t *session)
+ {
+- (void)print_data(bu, len, pgn);
++ print_data(bu, len, pgn);
+ gpsd_report(LOG_DATA, "pgn %6d(%3d):\n", pgn->pgn, session->driver.nmea2000.unit);
+ return(0);
+ }
+@@ -334,7 +335,7 @@ static gps_mask_t hnd_129038(unsigned char *bu, int len, PGN *pgn, struct gps_de
+
+ static gps_mask_t hnd_129039(unsigned char *bu, int len, PGN *pgn, struct gps_device_t *session)
+ {
+- (void)print_data(bu, len, pgn);
++ print_data(bu, len, pgn);
+ gpsd_report(LOG_DATA, "pgn %6d(%3d):\n", pgn->pgn, session->driver.nmea2000.unit);
+ return(0);
+ }
+@@ -342,7 +343,7 @@ static gps_mask_t hnd_129039(unsigned char *bu, int len, PGN *pgn, struct gps_de
+
+ static gps_mask_t hnd_129040(unsigned char *bu, int len, PGN *pgn, struct gps_device_t *session)
+ {
+- (void)print_data(bu, len, pgn);
++ print_data(bu, len, pgn);
+ gpsd_report(LOG_DATA, "pgn %6d(%3d):\n", pgn->pgn, session->driver.nmea2000.unit);
+ return(0);
+ }
+@@ -350,7 +351,7 @@ static gps_mask_t hnd_129040(unsigned char *bu, int len, PGN *pgn, struct gps_de
+
+ static gps_mask_t hnd_129794(unsigned char *bu, int len, PGN *pgn, struct gps_device_t *session)
+ {
+- (void)print_data(bu, len, pgn);
++ print_data(bu, len, pgn);
+ gpsd_report(LOG_DATA, "pgn %6d(%3d):\n", pgn->pgn, session->driver.nmea2000.unit);
+ return(0);
+ }
+@@ -358,7 +359,7 @@ static gps_mask_t hnd_129794(unsigned char *bu, int len, PGN *pgn, struct gps_de
+
+ static gps_mask_t hnd_129798(unsigned char *bu, int len, PGN *pgn, struct gps_device_t *session)
+ {
+- (void)print_data(bu, len, pgn);
++ print_data(bu, len, pgn);
+ gpsd_report(LOG_DATA, "pgn %6d(%3d):\n", pgn->pgn, session->driver.nmea2000.unit);
+ return(0);
+ }
+@@ -366,7 +367,7 @@ static gps_mask_t hnd_129798(unsigned char *bu, int len, PGN *pgn, struct gps_de
+
+ static gps_mask_t hnd_129802(unsigned char *bu, int len, PGN *pgn, struct gps_device_t *session)
+ {
+- (void)print_data(bu, len, pgn);
++ print_data(bu, len, pgn);
+ gpsd_report(LOG_DATA, "pgn %6d(%3d):\n", pgn->pgn, session->driver.nmea2000.unit);
+ return(0);
+ }
+@@ -374,7 +375,7 @@ static gps_mask_t hnd_129802(unsigned char *bu, int len, PGN *pgn, struct gps_de
+
+ static gps_mask_t hnd_129809(unsigned char *bu, int len, PGN *pgn, struct gps_device_t *session)
+ {
+- (void)print_data(bu, len, pgn);
++ print_data(bu, len, pgn);
+ gpsd_report(LOG_DATA, "pgn %6d(%3d):\n", pgn->pgn, session->driver.nmea2000.unit);
+ return(0);
+ }
+@@ -382,7 +383,7 @@ static gps_mask_t hnd_129809(unsigned char *bu, int len, PGN *pgn, struct gps_de
+
+ static gps_mask_t hnd_129810(unsigned char *bu, int len, PGN *pgn, struct gps_device_t *session)
+ {
+- (void)print_data(bu, len, pgn);
++ print_data(bu, len, pgn);
+ gpsd_report(LOG_DATA, "pgn %6d(%3d):\n", pgn->pgn, session->driver.nmea2000.unit);
+ return(0);
+ }
+--
+1.7.8.6
+
diff --git a/sci-geosciences/gpsd/files/gpsd-3.6-rpath.patch b/sci-geosciences/gpsd/files/gpsd-3.6-rpath.patch
new file mode 100644
index 000000000000..ecff094e4a9f
--- /dev/null
+++ b/sci-geosciences/gpsd/files/gpsd-3.6-rpath.patch
@@ -0,0 +1,13 @@
+don't set the -rpath flag to the install dir as this breaks DESTDIR
+
+--- a/SConstruct
++++ b/SConstruct
+@@ -268,7 +268,7 @@ def installdir(dir, add_destdir=True):
+
+ # Honor the specified installation prefix in link paths.
+ env.Prepend(LIBPATH=[installdir('libdir')])
+-if env["shared"]:
++if env["shared"] and env["chrpath"]:
+ env.Prepend(RPATH=[installdir('libdir')])
+
+ # Give deheader a way to set compiler flags
diff --git a/sci-geosciences/gpsd/gpsd-3.6.ebuild b/sci-geosciences/gpsd/gpsd-3.6.ebuild
new file mode 100644
index 000000000000..89841abb45d1
--- /dev/null
+++ b/sci-geosciences/gpsd/gpsd-3.6.ebuild
@@ -0,0 +1,163 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-3.6.ebuild,v 1.1 2012/05/23 14:20:01 vapier Exp $
+
+EAPI="4"
+
+PYTHON_DEPEND="python? 2:2.6"
+RESTRICT_PYTHON_ABIS="3.*"
+SUPPORT_PYTHON_ABIS="1"
+SCONS_MIN_VERSION="1.2.1"
+
+inherit eutils user multilib distutils scons-utils toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.savannah.nongnu.org/gpsd.git"
+ inherit git-2
+else
+ SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+fi
+
+DESCRIPTION="GPS daemon and library to support USB/serial GPS devices and various GPS/mapping clients"
+HOMEPAGE="http://catb.org/gpsd/"
+
+LICENSE="BSD"
+SLOT="0"
+
+GPSD_PROTOCOLS=(
+ ashtech aivdm clientdebug earthmate evermore fv18 garmin
+ garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver
+ oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip
+ tripmate tnt ubx
+)
+IUSE_GPSD_PROTOCOLS=${GPSD_PROTOCOLS[@]/#/gpsd_protocols_}
+IUSE="${IUSE_GPSD_PROTOCOLS} bluetooth cxx debug dbus ipv6 ncurses ntp python qt4 +shm +sockets test udev usb X"
+REQUIRED_USE="X? ( python )"
+
+RDEPEND="X? ( dev-python/pygtk:2 )
+ ncurses? ( sys-libs/ncurses )
+ bluetooth? ( net-wireless/bluez )
+ usb? ( virtual/libusb:1 )
+ dbus? (
+ sys-apps/dbus
+ dev-libs/dbus-glib
+ )
+ ntp? ( net-misc/ntp )
+ qt4? ( x11-libs/qt-gui )"
+DEPEND="${RDEPEND}
+ test? ( sys-devel/bc )"
+
+# xml packages are for man page generation
+if [[ ${PV} == "9999" ]] ; then
+ DEPEND+="
+ app-text/xmlto
+ =app-text/docbook-xml-dtd-4.1*"
+fi
+
+pkg_setup() {
+ use python && python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.3-ldflags.patch
+ epatch "${FILESDIR}"/${PN}-3.4-always-install-man-pages.patch
+ epatch "${FILESDIR}"/${PN}-3.4-no-man-gen.patch
+ epatch "${FILESDIR}"/${PN}-3.6-debug.patch
+ epatch "${FILESDIR}"/${PN}-3.6-rpath.patch
+
+ # Avoid useless -L paths to the install dir
+ sed -i \
+ -e '/^env.Prepend(LIBPATH=.installdir(.libdir.).)$/d' \
+ -e 's:\<STAGING_PREFIX\>:SYSROOT:g' \
+ SConstruct || die
+
+ # Extract python info out of SConstruct so we can use saner distribute
+ if use python ; then
+ pyvar() { sed -n "/^ *$1 *=/s:.*= *::p" SConstruct ; }
+ local pybins=$(pyvar python_progs)
+ local pysrcs=$(sed -n '/^ *python_extensions = {/,/}/{s:^ *::;s:os[.]sep:"/":g;p}' SConstruct)
+ local packet=$(python -c "${pysrcs}; print(python_extensions['gps/packet'])")
+ local client=$(python -c "${pysrcs}; print(python_extensions['gps/clienthelpers'])")
+ sed \
+ -e "s|@VERSION@|$(pyvar gpsd_version)|" \
+ -e "s|@URL@|$(pyvar website)|" \
+ -e "s|@EMAIL@|$(pyvar devmail)|" \
+ -e "s|@SCRIPTS@|${pybins}|" \
+ -e "s|@GPS_PACKET_SOURCES@|${packet}|" \
+ -e "s|@GPS_CLIENT_SOURCES@|${client}|" \
+ -e "s|@SCRIPTS@|$(pyvar python_progs)|" \
+ "${FILESDIR}"/${PN}-3.3-setup.py > setup.py || die
+ distutils_src_prepare
+ fi
+}
+
+src_configure() {
+ myesconsargs=(
+ prefix="${EPREFIX}/usr"
+ libdir="\$prefix/$(get_libdir)"
+ chrpath=False
+ gpsd_user=gpsd
+ gpsd_group=uucp
+ strip=False
+ python=False
+ $(use_scons bluetooth bluez)
+ $(use_scons cxx libgpsmm)
+ $(use_scons debug)
+ $(use_scons dbus dbus_export)
+ $(use_scons ipv6)
+ $(use_scons ncurses)
+ $(use_scons ntp ntpshm)
+ $(use_scons ntp pps)
+ $(use_scons shm shm_export)
+ $(use_scons sockets socket_export)
+ $(use_scons qt4 libQgpsmm)
+ $(use_scons usb)
+ )
+
+ # enable specified protocols
+ local protocol
+ for protocol in ${GPSD_PROTOCOLS[@]} ; do
+ myesconsargs+=( $(use_scons gpsd_protocols_${protocol} ${protocol}) )
+ done
+}
+
+src_compile() {
+ tc-export CC CXX PKG_CONFIG
+ export SHLINKFLAGS=${LDFLAGS} LINKFLAGS=${LDFLAGS}
+ escons
+
+ use python && distutils_src_compile
+}
+
+src_install() {
+ DESTDIR="${D}" escons install $(usex udev udev-install "")
+
+ newconfd "${FILESDIR}"/gpsd.conf-2 gpsd
+ newinitd "${FILESDIR}"/gpsd.init-2 gpsd
+
+ if use python ; then
+ distutils_src_install
+ # Delete all X related packages if user doesn't want them
+ if ! use X ; then
+ local p
+ for p in $(grep -Il 'import .*pygtk' *) ; do
+ find "${D}"/usr/bin -name "${p}*" -delete
+ done
+ fi
+ fi
+}
+
+pkg_preinst() {
+ # Run the gpsd daemon as gpsd and group uucp; create it here
+ # as it doesn't seem to be needed during compile/install ...
+ enewuser gpsd -1 -1 -1 "uucp"
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}