summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2013-07-01 11:08:56 +0000
committerAndrey Grozin <grozin@gentoo.org>2013-07-01 11:08:56 +0000
commitd96bddf8e1466bb9d7d42396c68f3bd7856a2ce4 (patch)
tree5c67a36923b104d07c5a6da93eeddf6c078b842d /sci-geosciences
parentopenvas: bump of meta-ebuild (diff)
downloadgentoo-2-d96bddf8e1466bb9d7d42396c68f3bd7856a2ce4.tar.gz
gentoo-2-d96bddf8e1466bb9d7d42396c68f3bd7856a2ce4.tar.bz2
gentoo-2-d96bddf8e1466bb9d7d42396c68f3bd7856a2ce4.zip
Version bump, closing #438316
(Portage version: 2.2.0_alpha185/cvs/Linux i686, signed Manifest commit with key 0x3AFFCE974D34BD8C!)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/viking/ChangeLog9
-rw-r--r--sci-geosciences/viking/viking-1.4.1.ebuild62
2 files changed, 69 insertions, 2 deletions
diff --git a/sci-geosciences/viking/ChangeLog b/sci-geosciences/viking/ChangeLog
index b70e2296cf15..9a350ef0622e 100644
--- a/sci-geosciences/viking/ChangeLog
+++ b/sci-geosciences/viking/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-geosciences/viking
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/viking/ChangeLog,v 1.22 2012/05/31 14:59:43 scarabeus Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/viking/ChangeLog,v 1.23 2013/07/01 11:08:56 grozin Exp $
+
+*viking-1.4.1 (01 Jul 2013)
+
+ 01 Jul 2013; Andrey Grozin <grozin@gentoo.org> +viking-1.4.1.ebuild:
+ Version bump, closing #438316
*viking-1.3 (31 May 2012)
diff --git a/sci-geosciences/viking/viking-1.4.1.ebuild b/sci-geosciences/viking/viking-1.4.1.ebuild
new file mode 100644
index 000000000000..2d836d186008
--- /dev/null
+++ b/sci-geosciences/viking/viking-1.4.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/viking/viking-1.4.1.ebuild,v 1.1 2013/07/01 11:08:56 grozin Exp $
+
+EAPI=5
+
+DESCRIPTION="GPS data editor and analyzer"
+HOMEPAGE="http://viking.sourceforge.net/"
+IUSE="doc gps nls"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ doc? ( mirror://sourceforge/${PN}/${PN}.pdf )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+COMMONDEPEND="dev-libs/expat
+ dev-libs/glib:2
+ net-misc/curl
+ sys-libs/zlib
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ gps? ( >=sci-geosciences/gpsd-2.96 )
+"
+RDEPEND="${COMMONDEPEND}
+ sci-geosciences/gpsbabel
+"
+DEPEND="${COMMONDEPEND}
+ app-text/gnome-doc-utils
+ dev-util/intltool
+ dev-util/gtk-doc-am
+ app-text/rarian
+ dev-libs/libxslt
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+src_configure() {
+ econf \
+ --disable-deprecations \
+ --with-libcurl \
+ --with-expat \
+ --enable-google \
+ --enable-terraserver \
+ --enable-expedia \
+ --enable-openstreetmap \
+ --enable-bluemarble \
+ --enable-geonames \
+ --enable-geocaches \
+ --enable-spotmaps \
+ --disable-dem24k \
+ $(use_enable gps realtime-gps-tracking) \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins "${DISTDIR}"/${PN}.pdf
+ fi
+}