summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-03-31 14:53:53 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-03-31 14:53:53 +0000
commit437150d1ccf52bdc6eff849c341f4e3ea61a7a94 (patch)
treef40811924854135f5a291bd122e37ca1b8e9d533 /sci-libs/acml
parentUpdated SRC_URI to use rubyforge mirrors (diff)
downloadgentoo-2-437150d1ccf52bdc6eff849c341f4e3ea61a7a94.tar.gz
gentoo-2-437150d1ccf52bdc6eff849c341f4e3ea61a7a94.tar.bz2
gentoo-2-437150d1ccf52bdc6eff849c341f4e3ea61a7a94.zip
Forced -Wl,--no-as-needed in the pkg-config files. Now blas and lapack pkg-config point to the static acml directory instead of the dynamic libblas and liblapack
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-libs/acml')
-rw-r--r--sci-libs/acml/ChangeLog9
-rw-r--r--sci-libs/acml/acml-3.6.0-r1.ebuild5
-rw-r--r--sci-libs/acml/acml-3.6.1-r1.ebuild5
-rw-r--r--sci-libs/acml/acml-4.0.1.ebuild5
-rw-r--r--sci-libs/acml/files/blas.pc.in2
-rw-r--r--sci-libs/acml/files/lapack.pc.in2
6 files changed, 22 insertions, 6 deletions
diff --git a/sci-libs/acml/ChangeLog b/sci-libs/acml/ChangeLog
index c99c0266e418..8df323034a1b 100644
--- a/sci-libs/acml/ChangeLog
+++ b/sci-libs/acml/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/acml
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/ChangeLog,v 1.31 2008/01/08 09:46:17 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/ChangeLog,v 1.32 2008/03/31 14:53:52 bicatali Exp $
+
+ 31 Mar 2008; Sébastien Fabbro <bicatali@gentoo.org> files/blas.pc.in,
+ files/lapack.pc.in, acml-3.6.0-r1.ebuild, acml-3.6.1-r1.ebuild,
+ acml-4.0.1.ebuild:
+ Forced -Wl,--no-as-needed in the pkg-config files. Now blas and lapack
+ pkg-config point to the static acml directory instead of the dynamic
+ libblas and liblapack
08 Jan 2008; Sébastien Fabbro <bicatali@gentoo.org> files/blas.pc.in,
files/lapack.pc.in, acml-3.6.0-r1.ebuild, acml-3.6.1-r1.ebuild,
diff --git a/sci-libs/acml/acml-3.6.0-r1.ebuild b/sci-libs/acml/acml-3.6.0-r1.ebuild
index 7d0349efe685..0138f36c2468 100644
--- a/sci-libs/acml/acml-3.6.0-r1.ebuild
+++ b/sci-libs/acml/acml-3.6.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-3.6.0-r1.ebuild,v 1.7 2008/01/08 09:46:17 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-3.6.0-r1.ebuild,v 1.8 2008/03/31 14:53:52 bicatali Exp $
inherit eutils toolchain-funcs fortran
@@ -95,6 +95,7 @@ src_install() {
# install profiles
ESELECT_PROF=acml-${FORTRANC}
local acmldir=${instdir}/${fort}
+ local acmllibs="-lacml -lacml_mv"
local libname=${acmldir}/lib/libacml
local extlibs
local extflags
@@ -102,6 +103,7 @@ src_install() {
if [[ ${fort} =~ _mp ]]; then
ESELECT_PROF=${ESELECT_PROF}-openmp
extlibs="${extlibs} -lpthread"
+ acmllibs="-lacml_mp -lacml_mv"
libname=${libname}_mp
extflags="${extflags} -openmp"
fi
@@ -110,6 +112,7 @@ src_install() {
sed -e "s:@LIBDIR@:$(get_libdir):" \
-e "s:@PV@:${PV}:" \
-e "s:@ACMLDIR@:${acmldir}:g" \
+ -e "s:@ACMLLIBS@:${acmllibs}:g" \
-e "s:@EXTLIBS@:${extlibs}:g" \
-e "s:@EXTFLAGS@:${extflags}:g" \
"${FILESDIR}"/${l}.pc.in > ${l}.pc \
diff --git a/sci-libs/acml/acml-3.6.1-r1.ebuild b/sci-libs/acml/acml-3.6.1-r1.ebuild
index 2b2bc7f5ed76..bec23a3c0192 100644
--- a/sci-libs/acml/acml-3.6.1-r1.ebuild
+++ b/sci-libs/acml/acml-3.6.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-3.6.1-r1.ebuild,v 1.7 2008/01/08 09:46:17 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-3.6.1-r1.ebuild,v 1.8 2008/03/31 14:53:52 bicatali Exp $
inherit eutils toolchain-funcs fortran
@@ -107,6 +107,7 @@ src_install() {
# install profiles
ESELECT_PROF=acml-${FORTRANC}
local acmldir=${instdir}/${fort}
+ local acmllibs="-lacml -lacml_mv"
local libname=${acmldir}/lib/libacml
local extlibs
local extflags
@@ -118,6 +119,7 @@ src_install() {
if [[ ${fort} =~ _mp ]]; then
ESELECT_PROF=${ESELECT_PROF}-openmp
extlibs="${extlibs} -lpthread"
+ acmllibs="-lacml_mp -lacml_mv"
libname=${libname}_mp
extflags="${extflags} -fopenmp"
fi
@@ -126,6 +128,7 @@ src_install() {
sed -e "s:@LIBDIR@:$(get_libdir):" \
-e "s:@PV@:${PV}:" \
-e "s:@ACMLDIR@:${acmldir}:g" \
+ -e "s:@ACMLLIBS@:${acmllibs}:g" \
-e "s:@EXTLIBS@:${extlibs}:g" \
-e "s:@EXTFLAGS@:${extflags}:g" \
"${FILESDIR}"/${l}.pc.in > ${l}.pc \
diff --git a/sci-libs/acml/acml-4.0.1.ebuild b/sci-libs/acml/acml-4.0.1.ebuild
index e7fc3726243e..514ff6fa50d4 100644
--- a/sci-libs/acml/acml-4.0.1.ebuild
+++ b/sci-libs/acml/acml-4.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-4.0.1.ebuild,v 1.3 2008/01/08 09:46:17 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-4.0.1.ebuild,v 1.4 2008/03/31 14:53:52 bicatali Exp $
inherit eutils toolchain-funcs fortran
@@ -107,6 +107,7 @@ src_install() {
# install profiles
ESELECT_PROF=acml-${FORTRANC}
local acmldir=${instdir}/${fort}
+ local acmllibs="-lacml -lacml_mv"
local libname=${acmldir}/lib/libacml
local extlibs=
local extflags=
@@ -118,6 +119,7 @@ src_install() {
if [[ ${fort} =~ _mp ]]; then
ESELECT_PROF=${ESELECT_PROF}-openmp
extlibs="${extlibs} -lpthread"
+ acmllibs="-lacml_mp -lacml_mv"
libname=${libname}_mp
extflags="${extflags} -fopenmp"
fi
@@ -126,6 +128,7 @@ src_install() {
sed -e "s:@LIBDIR@:$(get_libdir):" \
-e "s:@PV@:${PV}:" \
-e "s:@ACMLDIR@:${acmldir}:g" \
+ -e "s:@ACMLLIBS@:${acmllibs}:g" \
-e "s:@EXTLIBS@:${extlibs}:g" \
-e "s:@EXTFLAGS@:${extflags}:g" \
"${FILESDIR}"/${l}.pc.in > ${l}.pc \
diff --git a/sci-libs/acml/files/blas.pc.in b/sci-libs/acml/files/blas.pc.in
index d9f7f4087943..523aabc1204c 100644
--- a/sci-libs/acml/files/blas.pc.in
+++ b/sci-libs/acml/files/blas.pc.in
@@ -7,5 +7,5 @@ Name: blas
Description: ACML implementations of the Basic Linear Algebra Subroutines
Version: @PV@
URL: http://developer.amd.com/acml.jsp
-Libs: -L${libdir} -lblas -lacml_mv @EXTLIBS@
+Libs: -Wl,--no-as-needed -L${libdir} @ACMLLIBS@ @EXTLIBS@
Cflags: @EXTFLAGS@
diff --git a/sci-libs/acml/files/lapack.pc.in b/sci-libs/acml/files/lapack.pc.in
index d2453f180759..48fef122dfe4 100644
--- a/sci-libs/acml/files/lapack.pc.in
+++ b/sci-libs/acml/files/lapack.pc.in
@@ -7,5 +7,5 @@ Name: lapack
Description: ACML implementation of the F77 Linear Algebra PACKage
Version: @PV@
URL: http://developer.amd.com/acml.jsp
-Libs: -L${libdir} -llapack -lacml_mv @EXTLIBS@
+Libs: -Wl,--no-as-needed -L${libdir} @ACMLLIBS@ @EXTLIBS@
Cflags: @EXTFLAGS@