summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2007-03-13 00:24:34 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2007-03-13 00:24:34 +0000
commit41c885de393b87298ca9a4a63c5075b3ba6904bf (patch)
tree7f7636dc06eb0b6b563727d37b1959f8a2d446f0 /sci-libs/blas-atlas
parentReplaced text-markup by tex (text-markup split). (diff)
downloadgentoo-2-41c885de393b87298ca9a4a63c5075b3ba6904bf.tar.gz
gentoo-2-41c885de393b87298ca9a4a63c5075b3ba6904bf.tar.bz2
gentoo-2-41c885de393b87298ca9a4a63c5075b3ba6904bf.zip
QA: which -> type -P
(Portage version: 2.1.2.1-r1)
Diffstat (limited to 'sci-libs/blas-atlas')
-rw-r--r--sci-libs/blas-atlas/ChangeLog7
-rw-r--r--sci-libs/blas-atlas/blas-atlas-3.6.0-r1.ebuild8
-rw-r--r--sci-libs/blas-atlas/blas-atlas-3.6.0-r2.ebuild8
-rw-r--r--sci-libs/blas-atlas/blas-atlas-3.6.0.ebuild6
-rw-r--r--sci-libs/blas-atlas/blas-atlas-3.7.11-r1.ebuild8
-rw-r--r--sci-libs/blas-atlas/blas-atlas-3.7.11.ebuild6
6 files changed, 24 insertions, 19 deletions
diff --git a/sci-libs/blas-atlas/ChangeLog b/sci-libs/blas-atlas/ChangeLog
index b4db45af41ab..f21fa3de4a34 100644
--- a/sci-libs/blas-atlas/ChangeLog
+++ b/sci-libs/blas-atlas/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/blas-atlas
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/ChangeLog,v 1.54 2007/01/23 14:01:50 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/ChangeLog,v 1.55 2007/03/13 00:24:34 kugelfang Exp $
+
+ 13 Mar 2007; Danny van Dyk <kugelfang@gentoo.org> blas-atlas-3.6.0.ebuild,
+ blas-atlas-3.6.0-r1.ebuild, blas-atlas-3.6.0-r2.ebuild,
+ blas-atlas-3.7.11.ebuild, blas-atlas-3.7.11-r1.ebuild:
+ QA: which -> type -P
23 Jan 2007; Markus Dittrich <markusle@gentoo.org>
-blas-atlas-3.7.23.ebuild:
diff --git a/sci-libs/blas-atlas/blas-atlas-3.6.0-r1.ebuild b/sci-libs/blas-atlas/blas-atlas-3.6.0-r1.ebuild
index 09312f1962c6..81bf08e6134f 100644
--- a/sci-libs/blas-atlas/blas-atlas-3.6.0-r1.ebuild
+++ b/sci-libs/blas-atlas/blas-atlas-3.6.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.6.0-r1.ebuild,v 1.11 2006/06/17 00:34:47 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.6.0-r1.ebuild,v 1.12 2007/03/13 00:24:34 kugelfang Exp $
inherit eutils toolchain-funcs
@@ -24,13 +24,13 @@ PROVIDE="virtual/blas"
S=${WORKDIR}/ATLAS
-# Libraries will be installed in ${RPATH}/atlas
+# Libraries will be installed in ${RPATH}/atlas
# and ${RPATH}/threaded-atlas:
RPATH="${DESTTREE}/lib/blas"
pkg_setup() {
- if [ -z `which g77` ]; then
+ if [[ -z `type -P g77` ]]; then
eerror "No fortran compiler found on the system!"
eerror "Please add fortran to your USE flags and reemerge gcc!"
die
diff --git a/sci-libs/blas-atlas/blas-atlas-3.6.0-r2.ebuild b/sci-libs/blas-atlas/blas-atlas-3.6.0-r2.ebuild
index 7901075df308..9937dda3c0d7 100644
--- a/sci-libs/blas-atlas/blas-atlas-3.6.0-r2.ebuild
+++ b/sci-libs/blas-atlas/blas-atlas-3.6.0-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.6.0-r2.ebuild,v 1.3 2006/08/17 18:22:29 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.6.0-r2.ebuild,v 1.4 2007/03/13 00:24:34 kugelfang Exp $
inherit eutils toolchain-funcs
@@ -25,13 +25,13 @@ PROVIDE="virtual/blas"
S=${WORKDIR}/ATLAS
-# Libraries will be installed in ${RPATH}/atlas
+# Libraries will be installed in ${RPATH}/atlas
# and ${RPATH}/threaded-atlas:
RPATH="${DESTTREE}/lib/blas"
pkg_setup() {
- if [ -z `which g77` ]; then
+ if [[ -z `type -P g77` ]]; then
eerror "No fortran compiler found on the system!"
eerror "Please add fortran to your USE flags and reemerge gcc!"
die
diff --git a/sci-libs/blas-atlas/blas-atlas-3.6.0.ebuild b/sci-libs/blas-atlas/blas-atlas-3.6.0.ebuild
index f6b83f8f0b59..ec00f42ed9e4 100644
--- a/sci-libs/blas-atlas/blas-atlas-3.6.0.ebuild
+++ b/sci-libs/blas-atlas/blas-atlas-3.6.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.6.0.ebuild,v 1.7 2006/01/28 15:32:30 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.6.0.ebuild,v 1.8 2007/03/13 00:24:34 kugelfang Exp $
inherit eutils toolchain-funcs
@@ -25,7 +25,7 @@ PROVIDE="virtual/blas"
S=${WORKDIR}/ATLAS
pkg_setup() {
- if [ -z `which g77` ]; then
+ if [[ -z `type -P g77` ]]; then
eerror "No fortran compiler found on the system!"
eerror "Please add fortran to your USE flags and reemerge gcc!"
die
diff --git a/sci-libs/blas-atlas/blas-atlas-3.7.11-r1.ebuild b/sci-libs/blas-atlas/blas-atlas-3.7.11-r1.ebuild
index a7a6d2434387..c93c241fc818 100644
--- a/sci-libs/blas-atlas/blas-atlas-3.7.11-r1.ebuild
+++ b/sci-libs/blas-atlas/blas-atlas-3.7.11-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.7.11-r1.ebuild,v 1.7 2006/10/04 14:52:26 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.7.11-r1.ebuild,v 1.8 2007/03/13 00:24:34 kugelfang Exp $
inherit eutils toolchain-funcs fortran
@@ -164,8 +164,8 @@ src_install () {
doins "${S}"/include/cblas.h "${S}"/include/atlas_misc.h
doins "${S}"/include/atlas_enum.h
- # These headers contain the architecture-specific
- # optimizations determined by ATLAS. The atlas-lapack build
+ # These headers contain the architecture-specific
+ # optimizations determined by ATLAS. The atlas-lapack build
# is much shorter if they are available, so save them:
doins "${S}/include/${ATLAS_ARCH}"/*.h
diff --git a/sci-libs/blas-atlas/blas-atlas-3.7.11.ebuild b/sci-libs/blas-atlas/blas-atlas-3.7.11.ebuild
index b091b35730e2..82ad54e8ab09 100644
--- a/sci-libs/blas-atlas/blas-atlas-3.7.11.ebuild
+++ b/sci-libs/blas-atlas/blas-atlas-3.7.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.7.11.ebuild,v 1.17 2007/01/03 02:36:46 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.7.11.ebuild,v 1.18 2007/03/13 00:24:34 kugelfang Exp $
inherit eutils toolchain-funcs fortran
@@ -165,8 +165,8 @@ src_install () {
doins "${S}"/include/cblas.h "${S}"/include/atlas_misc.h
doins "${S}"/include/atlas_enum.h
- # These headers contain the architecture-specific
- # optimizations determined by ATLAS. The atlas-lapack build
+ # These headers contain the architecture-specific
+ # optimizations determined by ATLAS. The atlas-lapack build
# is much shorter if they are available, so save them:
doins "${S}/include/${ATLAS_ARCH}"/*.h