summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-08-20 14:38:26 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-08-20 14:38:26 +0000
commit367a7d270355ca796ce8ae3c693ab171288bbb94 (patch)
tree49f95da9064d9348ce0f61365430289948462c36 /sci-libs/blas-goto
parentUpdated description for graphviz's pango USE flag (diff)
downloadgentoo-2-367a7d270355ca796ce8ae3c693ab171288bbb94.tar.gz
gentoo-2-367a7d270355ca796ce8ae3c693ab171288bbb94.tar.bz2
gentoo-2-367a7d270355ca796ce8ae3c693ab171288bbb94.zip
Removed obsolete versions.
(Portage version: 2.1.3.6)
Diffstat (limited to 'sci-libs/blas-goto')
-rw-r--r--sci-libs/blas-goto/ChangeLog6
-rw-r--r--sci-libs/blas-goto/blas-goto-1.09.ebuild129
-rw-r--r--sci-libs/blas-goto/blas-goto-1.11.ebuild141
-rw-r--r--sci-libs/blas-goto/files/digest-blas-goto-1.093
-rw-r--r--sci-libs/blas-goto/files/digest-blas-goto-1.113
5 files changed, 5 insertions, 277 deletions
diff --git a/sci-libs/blas-goto/ChangeLog b/sci-libs/blas-goto/ChangeLog
index 3ffb9a754e37..ea9504f20d41 100644
--- a/sci-libs/blas-goto/ChangeLog
+++ b/sci-libs/blas-goto/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/blas-goto
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-goto/ChangeLog,v 1.8 2007/08/20 13:42:22 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-goto/ChangeLog,v 1.9 2007/08/20 14:38:26 markusle Exp $
+
+ 20 Aug 2007; Markus Dittrich <markusle@gentoo.org> -blas-goto-1.09.ebuild,
+ -blas-goto-1.11.ebuild:
+ Removed obsolete versions.
*blas-goto-1.16 (20 Aug 2007)
diff --git a/sci-libs/blas-goto/blas-goto-1.09.ebuild b/sci-libs/blas-goto/blas-goto-1.09.ebuild
deleted file mode 100644
index 1f23259724f4..000000000000
--- a/sci-libs/blas-goto/blas-goto-1.09.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-goto/blas-goto-1.09.ebuild,v 1.1 2006/11/22 15:11:30 dberkholz Exp $
-
-inherit eutils fortran toolchain-funcs
-
-MY_PN="GotoBLAS"
-MY_P="${MY_PN}-${PV}"
-DESCRIPTION="The fastest implementations of the Basic Linear Algebra Subroutines"
-HOMEPAGE="http://www.tacc.utexas.edu/resources/software/software.php"
-SRC_URI="http://www.tacc.utexas.edu/resources/software/login/gotoblas/${MY_P}.tar.gz"
-LICENSE="tacc"
-SLOT="0"
-# See http://www.tacc.utexas.edu/resources/software/gotoblasfaq.php
-# for supported architectures
-KEYWORDS="~x86"
-IUSE="threads"
-RESTRICT="mirror"
-RDEPEND="app-admin/eselect-blas"
-DEPEND="${RDEPEND}"
-S="${WORKDIR}/${MY_PN}"
-FORTRAN="g77 gfortran" # ifc g95 pgf77 pathf90 f90 f77
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Set up C compiler
- if [[ $(tc-getCC) = *gcc ]]; then
- C_COMPILER="GNU"
- elif [[ $(tc-getCC) = icc ]]; then
- C_COMPILER="INTEL"
- else
- die "tc-getCC() returned an invalid C compiler; valid are gcc or icc."
- fi
-
- # Set up Fortran compiler
- if [[ ${FORTRANC} = g77 ]]; then
- F_COMPILER="G77"
- elif [[ ${FORTRANC} = gfortran ]]; then
- F_COMPILER="GFORTRAN"
- # Otherwise, we get undefined reference to _gfortran_runtime_error
- FORTRAN_LIB="-lgfortran"
-# elif [[ ${FORTRANC} = ifc ]]; then
-# F_COMPILER="INTEL"
-# elif [[ ${FORTRANC} = g95 ]]; then
-# F_COMPILER="G95"
-# elif [[ ${FORTRANC} = pgf77 ]]; then
-# F_COMPILER="PGI"
-# elif [[ ${FORTRANC} = pathf90 ]]; then
-# F_COMPILER="PATHSCALE"
-# elif [[ ${FORTRANC} = f90 ]] || [[ ${FORTRANC} = f77 ]]; then
-# F_COMPILER="SUN"
-# elif [[ ${FORTRANC} = xlf ]]; then
-# F_COMPILER="IBM"
- else
- die "fortran.eclass returned an invalid Fortran compiler \'${FORTRANC}\'; valid are ${FORTRAN}."
- fi
-
- # Fix shared lib build
- sed -i \
- -e "s:\(&& echo OK\):${FORTRAN_LIB} \1:g" \
- "${S}"/exports/Makefile
-
- # Set up compilers
- sed -i \
- -e "s:^\(C_COMPILER =\) GNU:\1 ${C_COMPILER}:g" \
- -e "s:^# \(F_COMPILER =\) G77:\1 ${F_COMPILER}:g" \
- -e "s:^# \(SMP = 1\):\1:g" \
- "${S}"/Makefile.rule
-
- # Threaded?
- if use threads; then
- sed -i \
- -e "s:^# \(SMP = 1\):\1:g" \
- "${S}"/Makefile.rule
- fi
-
- # If you need a 64-bit binary
- # If you need a 64-bit integer interface, also do this for "INTERFACE64 = 1"
- if use amd64; then
- sed -i \
- -e "s:^# \(BINARY64 = 1\):\1:g" \
- "${S}"/Makefile.rule
- fi
-
- # Respect CFLAGS/FFLAGS
- sed -i \
- -e "/^COMMON_OPT += -O2$/d" \
- "${S}"/Makefile.rule
- sed -i \
- -e "s:^\(CCOMMON_OPT +=\)$:\1 ${CFLAGS}:g" \
- -e "s:^\(FCOMMON_OPT +=\)$:\1 ${FFLAGS:- -O2}:g" \
- "${S}"/Makefile.rule
-}
-
-src_compile() {
- # Make static library
- emake || die "emake failed"
-
- # Make shared library
- cd exports
- emake so -j1 || die "emake failed"
-}
-
-src_install() {
- local MAIN_DIR="/usr/$(get_libdir)/blas"
- local DIR="${MAIN_DIR}/goto"
-
- # dolib.so doesn't support our alternate locations
- exeinto ${DIR}
- doexe libgoto_*.so
- dosym libgoto_*.so ${DIR}/libgoto.so
- dosym libgoto_*.so ${DIR}/libgoto.so.0
- dosym libgoto_*.so ${DIR}/libgoto.so.0.0.0
-
- # dolib.a doesn't support our alternate locations
- insinto ${DIR}
- doins libgoto_*.a
- dosym libgoto_*.a ${DIR}/libgoto.a
-
- eselect blas add $(get_libdir) "${FILESDIR}"/eselect-goto goto
-}
-
-pkg_postinst() {
- if [[ -z $(eselect blas show) ]]; then
- eselect blas set goto
- fi
-}
diff --git a/sci-libs/blas-goto/blas-goto-1.11.ebuild b/sci-libs/blas-goto/blas-goto-1.11.ebuild
deleted file mode 100644
index 97b9f8903066..000000000000
--- a/sci-libs/blas-goto/blas-goto-1.11.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-goto/blas-goto-1.11.ebuild,v 1.1 2007/02/19 16:21:09 bicatali Exp $
-
-inherit eutils fortran flag-o-matic toolchain-funcs
-
-MY_PN="GotoBLAS"
-MY_P="${MY_PN}-${PV}"
-DESCRIPTION="The fastest implementations of the Basic Linear Algebra Subroutines"
-HOMEPAGE="http://www.tacc.utexas.edu/resources/software/software.php"
-SRC_URI="http://www.tacc.utexas.edu/resources/software/login/gotoblas/${MY_P}.tar.gz"
-LICENSE="tacc"
-SLOT="0"
-# See http://www.tacc.utexas.edu/resources/software/gotoblasfaq.php
-# for supported architectures
-KEYWORDS="~x86 ~amd64"
-IUSE="threads"
-RESTRICT="mirror"
-RDEPEND="app-admin/eselect-blas"
-DEPEND="${RDEPEND}"
-S="${WORKDIR}/${MY_PN}"
-FORTRAN="g77 gfortran" # ifc g95 pgf77 pathf90 f90 f77
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Set up C compiler
- if [[ $(tc-getCC) = *gcc ]]; then
- C_COMPILER="GNU"
- elif [[ $(tc-getCC) = icc ]]; then
- C_COMPILER="INTEL"
- else
- die "tc-getCC() returned an invalid C compiler; valid are gcc or icc."
- fi
-
- # Set up Fortran compiler
- if [[ ${FORTRANC} = g77 ]]; then
- F_COMPILER="G77"
- elif [[ ${FORTRANC} = gfortran ]]; then
- F_COMPILER="GFORTRAN"
- # Otherwise, we get undefined reference to _gfortran_runtime_error
- FORTRAN_LIB="-lgfortran"
-# elif [[ ${FORTRANC} = ifc ]]; then
-# F_COMPILER="INTEL"
-# elif [[ ${FORTRANC} = g95 ]]; then
-# F_COMPILER="G95"
-# elif [[ ${FORTRANC} = pgf77 ]]; then
-# F_COMPILER="PGI"
-# elif [[ ${FORTRANC} = pathf90 ]]; then
-# F_COMPILER="PATHSCALE"
-# elif [[ ${FORTRANC} = f90 ]] || [[ ${FORTRANC} = f77 ]]; then
-# F_COMPILER="SUN"
-# elif [[ ${FORTRANC} = xlf ]]; then
-# F_COMPILER="IBM"
- else
- die "fortran.eclass returned an invalid Fortran compiler \'${FORTRANC}\'; valid are ${FORTRAN}."
- fi
-
- # Fix shared lib build
- sed -i \
- -e "s:\(&& echo OK\):${FORTRAN_LIB} \1:g" \
- "${S}"/exports/Makefile
-
- # Set up compilers
- sed -i \
- -e "s:^\(C_COMPILER =\) GNU:\1 ${C_COMPILER}:g" \
- -e "s:^# \(F_COMPILER =\) G77:\1 ${F_COMPILER}:g" \
- -e "s:^# \(SMP = 1\):\1:g" \
- -e "s:\$(COMPILER_PREFIX)ar:$(tc-getAR):" \
- -e "s:\$(COMPILER_PREFIX)as:$(tc-getAS):" \
- -e "s:\$(COMPILER_PREFIX)ld:$(tc-getLD):" \
- -e "s:\$(COMPILER_PREFIX)ranlib:$(tc-getRANLIB):" \
- "${S}"/Makefile.rule
-
- # Threaded?
- if use threads; then
- sed -i \
- -e "s:^# \(SMP = 1\):\1:g" \
- "${S}"/Makefile.rule
- fi
-
- # If you need a 64-bit binary
- # If you need a 64-bit integer interface, also do this for "INTERFACE64 = 1"
- if use amd64; then
- sed -i \
- -e "s:^# \(BINARY64 = 1\):\1:g" \
- "${S}"/Makefile.rule
- fi
-
- # Respect CFLAGS/FFLAGS
- sed -i \
- -e "/^COMMON_OPT += -O2$/d" \
- "${S}"/Makefile.rule
- sed -i \
- -e "s:^\(CCOMMON_OPT +=\)$:\1 ${CFLAGS}:g" \
- -e "s:^\(FCOMMON_OPT +=\)$:\1 ${FFLAGS:- -O2}:g" \
- "${S}"/Makefile.rule
-}
-
-src_compile() {
-
- # Make static library
- emake LDFLAGS=$(raw_ldflags) || die "emake failed"
-
- # Make shared library
- cd exports
- emake so -j1 || die "emake failed"
-}
-
-src_test() {
- cd test
- emake || die "emake test failed"
-}
-
-src_install() {
- local MAIN_DIR="/usr/$(get_libdir)/blas"
- local DIR="${MAIN_DIR}/goto"
-
- # dolib.so doesn't support our alternate locations
- exeinto ${DIR}
- doexe libgoto_*.so
- dosym libgoto_*.so ${DIR}/libgoto.so
- dosym libgoto_*.so ${DIR}/libgoto.so.0
- dosym libgoto_*.so ${DIR}/libgoto.so.0.0.0
-
- # dolib.a doesn't support our alternate locations
- insinto ${DIR}
- doins libgoto_*.a
- dosym libgoto_*.a ${DIR}/libgoto.a
-
- dodoc 01 Readme.txt 03History.txt 04FAQ.txt
-
- eselect blas add $(get_libdir) "${FILESDIR}"/eselect-goto goto
-}
-
-pkg_postinst() {
- if [[ -z $(eselect blas show) ]]; then
- eselect blas set goto
- fi
-}
diff --git a/sci-libs/blas-goto/files/digest-blas-goto-1.09 b/sci-libs/blas-goto/files/digest-blas-goto-1.09
deleted file mode 100644
index 2a95ce1befb2..000000000000
--- a/sci-libs/blas-goto/files/digest-blas-goto-1.09
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 df24e67b50ad56723a6595682afe5856 GotoBLAS-1.09.tar.gz 1552150
-RMD160 4c5326aaabf8af495d51a1159b2f4eb0edc145e4 GotoBLAS-1.09.tar.gz 1552150
-SHA256 075876000fd1a94f9036edf5e49f6aac2e543798107a73a78e59a41a5c6eae1b GotoBLAS-1.09.tar.gz 1552150
diff --git a/sci-libs/blas-goto/files/digest-blas-goto-1.11 b/sci-libs/blas-goto/files/digest-blas-goto-1.11
deleted file mode 100644
index 0ed778d1664c..000000000000
--- a/sci-libs/blas-goto/files/digest-blas-goto-1.11
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 0790d4de9f6680ffe429801299bad00d GotoBLAS-1.11.tar.gz 1632357
-RMD160 292f119f53d5b88a4b95998f294fd55cc1f6b3f9 GotoBLAS-1.11.tar.gz 1632357
-SHA256 05697c943f9679fcda4513fe7cd32f475407d1204cc71b6608dfbd522547fafc GotoBLAS-1.11.tar.gz 1632357