summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-08-26 06:18:25 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-08-26 06:18:25 +0000
commitc5e8d326a640e79d4d276b4aa5cd07f933d6173d (patch)
tree29f08c7593cf31d55767f71863812d4d5babf7d8 /sci-libs/cfitsio
parentInitial commit. (diff)
downloadgentoo-2-c5e8d326a640e79d4d276b4aa5cd07f933d6173d.tar.gz
gentoo-2-c5e8d326a640e79d4d276b4aa5cd07f933d6173d.tar.bz2
gentoo-2-c5e8d326a640e79d4d276b4aa5cd07f933d6173d.zip
Better autotools patch, ready to resend upstream
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/cfitsio')
-rw-r--r--sci-libs/cfitsio/ChangeLog8
-rw-r--r--sci-libs/cfitsio/files/cfitsio-3.140-autotools.patch160
2 files changed, 100 insertions, 68 deletions
diff --git a/sci-libs/cfitsio/ChangeLog b/sci-libs/cfitsio/ChangeLog
index dea69edfa791..f87896c82ddf 100644
--- a/sci-libs/cfitsio/ChangeLog
+++ b/sci-libs/cfitsio/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/cfitsio
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cfitsio/ChangeLog,v 1.30 2009/03/28 13:31:17 bluebird Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cfitsio/ChangeLog,v 1.31 2009/08/26 06:18:24 bicatali Exp $
+
+ 26 Aug 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ files/cfitsio-3.140-autotools.patch:
+ Better autotools patch, ready to resend upstream
28 Mar 2009; Friedrich Oslage <bluebird@gentoo.org>
cfitsio-3.100-r1.ebuild:
diff --git a/sci-libs/cfitsio/files/cfitsio-3.140-autotools.patch b/sci-libs/cfitsio/files/cfitsio-3.140-autotools.patch
index dd73fa65da9a..7acd8eb9cb89 100644
--- a/sci-libs/cfitsio/files/cfitsio-3.140-autotools.patch
+++ b/sci-libs/cfitsio/files/cfitsio-3.140-autotools.patch
@@ -1,6 +1,24 @@
---- configure.ac.absent 1970-01-01 01:00:00.000000000 +0100
-+++ configure.ac 2008-06-02 01:08:32.000000000 +0100
-@@ -0,0 +1,158 @@
+--- cfitsio.pc.in.orig 2008-06-02 01:20:50.000000000 +0100
++++ cfitsio.pc.in 2008-06-02 01:22:14.000000000 +0100
+@@ -1,10 +1,10 @@
+ prefix=@prefix@
+ exec_prefix=@exec_prefix@
+-libdir=${exec_prefix}/lib
+-includedir=${prefix}/include
++libdir=@libdir@
++includedir=@includedir@
+
+-Name: cfitsio
++Name: @PACKAGE_NAME@
+ Description: FITS File Subroutine Library
+-Version: 3.006
+-Libs: -L${libdir} -lcfitsio @LIBS@ -lm
++Version: @PACKAGE_VERSION@
++Libs: -L${libdir} -lcfitsio @LIBS@
+ Cflags: -I${includedir}
+--- configure.ac.orig 1970-01-01 01:00:00.000000000 +0100
++++ configure.ac 2009-08-20 00:25:49.000000000 +0100
+@@ -0,0 +1,181 @@
+AC_PREREQ(2.59)
+AC_INIT([cfitsio], [3.140], [pence@tetra.gsfc.nasa.gov])
+AC_CONFIG_SRCDIR([fitscore.c])
@@ -17,29 +35,34 @@
+
+AC_MSG_CHECKING([whether to enable fortran interface])
+AC_ARG_ENABLE([fortran],
-+ AS_HELP_STRING([--enable-fortran], [Build the fortran interface]),
-+ [ENABLE_FORTRAN=$enableval
-+ AC_MSG_RESULT([$enableval])],
-+ [ENABLE_FORTRAN=no
-+ AC_MSG_RESULT([no])]
-+)
++ [AS_HELP_STRING([--enable-fortran], [Compile the fortran interface [default=yes]])],
++ [ENABLE_FORTRAN=$enableval])
+
-+if test x"$ENABLE_FORTRAN" = x"yes" ; then
-+ AC_PROG_F77
-+ if test x$F77 = xg77; then
++case x"$ENABLE_FORTRAN" in
++ *)
++ ENABLE_FORTRAN=yes
++ AC_MSG_RESULT([yes])
++ AC_PROG_F77
++ if test x$F77 = xg77; then
+ cfortran_def=g77Fortran
-+ elif test x$F77 = xifort ; then
++ elif test x$F77 = xifort ; then
+ cfortran_def=INTEL_COMPILER
-+ elif test x$F77 = xgfortran ; then
++ elif test x$F77 = xgfortran ; then
+ cfortran_def=gFortran
-+ elif test x$F77 = xpgf77 ; then
++ elif test x$F77 = xpgf77 ; then
+ cfortran_def=pgiFortran
-+ else
++ else
+ cfortran_def=f2cFortran
-+ fi
-+ CPPFLAGS_FORTRAN="-D$cfortran_def"
-+ AC_SUBST(CPPFLAGS_FORTRAN)
-+fi
++ fi
++ CPPFLAGS_FORTRAN="-D$cfortran_def"
++ AC_SUBST(CPPFLAGS_FORTRAN)
++ ;;
++ xno)
++ ENABLE_FORTRAN=no
++ AC_MSG_RESULT([no])
++ ;;
++esac
++
+AC_SUBST([ENABLE_FORTRAN])
+AM_CONDITIONAL([ENABLE_FORTRAN], test "x$ENABLE_FORTRAN" = "xyes")
+
@@ -93,6 +116,7 @@
+ [Define to 1 if your compiler supports long long])]
+)
+dnl check for flock_t
++AC_MSG_CHECKING([for flock_t in sys/fcntl.h])
+AC_COMPILE_IFELSE(
+ [AC_LANG_PROGRAM([[
+#include <sys/fcntl.h>
@@ -100,10 +124,11 @@
+flock_t filler;
+ ]])],
+ [AC_DEFINE(HAVE_FLOCK_T, 1, [if you have flock_t])
-+ AC_MSG_RESULT("yes")],
-+ [AC_MSG_RESULT("no") ])
++ AC_MSG_RESULT([yes])],
++ [AC_MSG_RESULT([no]) ])
+
+if test "$HAVE_FLOCK_T" != 1; then
++ AC_MSG_CHECKING([for flock_t in sys/flock.h])
+ AC_COMPILE_IFELSE([
+ AC_LANG_PROGRAM([[
+#include <sys/flock.h>
@@ -111,8 +136,8 @@
+flock_t filler;
+ ]])],
+ [AC_DEFINE(HAVE_FLOCK_T, 1, [if you have flock_t])
-+ AC_MSG_RESULT("yes")],
-+ [AC_MSG_RESULT("no") ])
++ AC_MSG_RESULT([yes])],
++ [AC_MSG_RESULT([no]) ])
+fi
+
+# check for union semun type
@@ -128,40 +153,56 @@
+dnl this quick check will add -lm to LIBS
+AC_CHECK_LIB(m, cos)
+
-+AC_ARG_WITH(gsiftp-flavour,
-+ [ --with-gsiftp-flavour[[=PATH]] Enable Globus Toolkit gsiftp protocol support ],
-+ [ if test "x$withval" != "xno"; then
++AC_ARG_WITH([gsiftp-flavour],
++ [AC_HELP_STRING([--with-gsiftp-flavour[=PATH]], [Compile with a given Globus Toolkit gsiftp protocol flavour])],
++ ,
++ [withval=no])
+
-+ if test "x$withval" != "xyes" ; then
-+ GSIFTP_FLAVOUR=${withval}
-+ fi
-+ AC_DEFINE(GSIFTP_FLAVOUR, [1],
++case x$withval in
++ xno)
++ AC_MSG_CHECKING([for Globus flavor])
++ AC_MSG_RESULT([none])
++ ;;
++ xyes)
++ AC_MSG_RESULT([yes])
++ ;;
++ *)
++ AC_MSG_RESULT([$withval])
++ GSIFTP_FLAVOUR=$withval
++ AC_DEFINE(GSIFTP_FLAVOUR, [1],
+ [Define to 1 if you want Globus Toolkit architecture])
-+ fi
-+ ]
-+)
++ ;;
++esac
+
+AC_ARG_WITH(gsiftp,
-+ [ --with-gsiftp[[=PATH]] Enable Globus Toolkit gsiftp protocol support ],
-+ [ if test "x$withval" != "xno"; then
-+ if test "x$withval" != "xyes" ; then
-+ CPPFLAGS_GLOBUS="-I${withval}/include/${GSIFTP_FLAVOUR}"
-+ LIBS_GLOBUS="-L${withval}/lib -lglobus_ftp_client_${GSIFTP_FLAVOUR}"
-+ HAVE_GSIFTP=yes
-+ fi
-+ AC_DEFINE(HAVE_GSIFTP, [1],
++ [AC_HELP_STRING([--with-gsiftp[=PATH]], [Compile with Globus Toolkit gsiftp protocol support [default=no]])],
++ ,
++ [withval=no])
++case "x$withval" in
++ xno)
++ AC_MSG_CHECKING([for Globus Toolkit])
++ AC_MSG_RESULT([no])
++ ;;
++ xyes)
++ AC_MSG_RESULT([yes])
++ ;;
++ *)
++ AC_MSG_RESULT([yes])
++ CPPFLAGS_GLOBUS="-I${withval}/include/${GSIFTP_FLAVOUR}"
++ LIBS_GLOBUS="-L${withval}/lib -lglobus_ftp_client_${GSIFTP_FLAVOUR}"
++ HAVE_GSIFTP=yes
++ AC_DEFINE(HAVE_GSIFTP, [1],
+ [Define if you want Globus Toolkit gsiftp protocol support])
-+ fi
-+ ]
-+)
++ ;;
++esac
+
+AC_SUBST(CPPFLAGS_GLOBUS)
+AC_SUBST(LIBS_GLOBUS)
+AC_CONFIG_FILES([Makefile cfitsio.pc])
+AC_OUTPUT
---- Makefile.am.absent 1970-01-01 01:00:00.000000000 +0100
-+++ Makefile.am 2008-06-02 01:07:45.000000000 +0100
-@@ -0,0 +1,81 @@
+--- Makefile.am.orig 1970-01-01 01:00:00.000000000 +0100
++++ Makefile.am 2009-08-20 00:45:37.000000000 +0100
+@@ -0,0 +1,86 @@
+lib_LTLIBRARIES = libcfitsio.la
+
+C_SOURCES = \
@@ -184,6 +225,9 @@
+AM_YFLAGS = -d -v
+
+include_HEADERS = fitsio.h fitsio2.h longnam.h drvrsmem.h
++noinst_HEADERS = cfortran.h drvrgsiftp.h eval_defs.h f77_wrap.h group.h \
++ compress.h eval_tab.h fpack.h grparser.h region.h
++
+libcfitsio_la_SOURCES = $(C_SOURCES) $(F77_SOURCES) $(include_HEADERS)
+libcfitsio_la_LDFLAGS = -no-undefined -version-info @SHARED_VERSION_INFO@
+libcfitsio_la_CPPFLAGS = @CPPFLAGS_FORTRAN@ @CPPFLAGS_EXTRA@ @CPPFLAGS_GLOBUS@
@@ -214,6 +258,8 @@
+testf77_SOURCES = testf77.f
+endif
+
++EXTRA_DIST = README README.MacOS README.win32 License.txt changes.txt cfitsio.doc fitsio.doc cfitsio.tex fitsio.tex quick.tex
++
+check-local: $(check_PROGRAMS)
+ @total=0; failed=0; \
+ for i in $(check_PROGRAMS); do \
@@ -243,21 +289,3 @@
+ sed -e 's/yy/ff/g' -e 's/YY/FF/g' y.tab.c > eval_y.c; \
+ sed -e 's/yy/ff/g' -e 's/YY/FF/g' y.tab.h > eval_tab.h; \
+ rm -f y.tab.c y.tab.h
---- cfitsio.pc.in.orig 2008-06-02 01:20:50.000000000 +0100
-+++ cfitsio.pc.in 2008-06-02 01:22:14.000000000 +0100
-@@ -1,10 +1,10 @@
- prefix=@prefix@
- exec_prefix=@exec_prefix@
--libdir=${exec_prefix}/lib
--includedir=${prefix}/include
-+libdir=@libdir@
-+includedir=@includedir@
-
--Name: cfitsio
-+Name: @PACKAGE_NAME@
- Description: FITS File Subroutine Library
--Version: 3.006
--Libs: -L${libdir} -lcfitsio @LIBS@ -lm
-+Version: @PACKAGE_VERSION@
-+Libs: -L${libdir} -lcfitsio @LIBS@
- Cflags: -I${includedir}