summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2012-04-12 19:55:44 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2012-04-12 19:55:44 +0000
commitb370752aa8f797b9e95162a5209fd77fd0a87e0d (patch)
tree91891577fe370c94fe57021b6ca187a8c8830e28 /sci-libs/clapack/clapack-3.2.1-r6.ebuild
parentversion bump (bug #411787) (diff)
downloadgentoo-2-b370752aa8f797b9e95162a5209fd77fd0a87e0d.tar.gz
gentoo-2-b370752aa8f797b9e95162a5209fd77fd0a87e0d.tar.bz2
gentoo-2-b370752aa8f797b9e95162a5209fd77fd0a87e0d.zip
Remove old; filter -ftree-vectorize as it causes an internal compiler error on gcc-4.6.2
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/clapack/clapack-3.2.1-r6.ebuild')
-rw-r--r--sci-libs/clapack/clapack-3.2.1-r6.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/sci-libs/clapack/clapack-3.2.1-r6.ebuild b/sci-libs/clapack/clapack-3.2.1-r6.ebuild
index b8400d15d6b3..8bfa73482b64 100644
--- a/sci-libs/clapack/clapack-3.2.1-r6.ebuild
+++ b/sci-libs/clapack/clapack-3.2.1-r6.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/clapack/clapack-3.2.1-r6.ebuild,v 1.4 2011/12/07 22:09:32 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/clapack/clapack-3.2.1-r6.ebuild,v 1.5 2012/04/12 19:55:43 dilfridge Exp $
EAPI=4
-inherit base cmake-utils
+inherit flag-o-matic base cmake-utils
DESCRIPTION="f2c'ed version of LAPACK"
HOMEPAGE="http://www.netlib.org/clapack/"
@@ -29,6 +29,9 @@ PATCHES=(
)
src_configure() {
+ filter-flags -ftree-vectorize
+ # causes an internal compiler error with gcc-4.6.2
+
local mycmakeargs=( $(cmake-utils_use_enable test TESTS) )
cmake-utils_src_configure
}