summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-07-29 23:38:25 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-07-29 23:38:25 +0000
commit2645c8f3ba9e36ddee780d7811d6e1a465688997 (patch)
tree97d67e72f4df5da594553230af21462af1ddbc71 /sci-libs/fftw
parentOld. (diff)
downloadgentoo-2-2645c8f3ba9e36ddee780d7811d6e1a465688997.tar.gz
gentoo-2-2645c8f3ba9e36ddee780d7811d6e1a465688997.tar.bz2
gentoo-2-2645c8f3ba9e36ddee780d7811d6e1a465688997.zip
restore accidentally removed version
(Portage version: 2.2.0_alpha120/cvs/Linux i686)
Diffstat (limited to 'sci-libs/fftw')
-rw-r--r--sci-libs/fftw/ChangeLog7
-rw-r--r--sci-libs/fftw/fftw-3.3.2.ebuild143
2 files changed, 149 insertions, 1 deletions
diff --git a/sci-libs/fftw/ChangeLog b/sci-libs/fftw/ChangeLog
index 59743aae7074..15d9c8e091e6 100644
--- a/sci-libs/fftw/ChangeLog
+++ b/sci-libs/fftw/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/fftw
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.127 2012/07/29 22:07:37 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.128 2012/07/29 23:38:25 ottxor Exp $
+
+*fftw-3.3.2 (29 Jul 2012)
+
+ 29 Jul 2012; Christoph Junghans <ottxor@gentoo.org> +fftw-3.3.2.ebuild:
+ restore accidentally removed version
29 Jul 2012; Sébastien Fabbro <bicatali@gentoo.org> -fftw-3.3.2.ebuild,
fftw-2.1.5-r8.ebuild:
diff --git a/sci-libs/fftw/fftw-3.3.2.ebuild b/sci-libs/fftw/fftw-3.3.2.ebuild
new file mode 100644
index 000000000000..caa30a053b41
--- /dev/null
+++ b/sci-libs/fftw/fftw-3.3.2.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.3.2.ebuild,v 1.4 2012/07/29 23:38:25 ottxor Exp $
+
+EAPI=4
+
+#AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils eutils flag-o-matic fortran-2 toolchain-funcs
+
+DESCRIPTION="Fast C library for the Discrete Fourier Transform"
+HOMEPAGE="http://www.fftw.org/"
+SRC_URI="http://www.fftw.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="3.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="altivec avx doc fortran mpi neon openmp quad sse sse2 static-libs threads zbus"
+
+DEPEND="
+ fortran? ( virtual/fortran[openmp?] )
+ mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if use openmp; then
+ if [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then
+ ewarn "OpenMP is not available in your current selected gcc"
+ die "need openmp capable gcc"
+ fi
+ FORTRAN_NEED_OPENMP=1
+ fi
+ use fortran && fortran-2_pkg_setup
+ FFTW_DIRS="single double longdouble"
+ if use quad; then
+ if [[ $(tc-getCC) == *gcc ]] && ! version_is_at_least 4.6 $(gcc-version); then
+ ewarn "quad precision only available for gcc >= 4.6"
+ die "need quad precision capable gcc"
+ fi
+ FFTW_DIRS+= "quad"
+ fi
+}
+
+src_prepare() {
+ # fix info file for category directory
+ sed -i \
+ -e 's/Texinfo documentation system/Libraries/' \
+ doc/fftw3.info || die "failed to fix info file"
+
+ # why?
+ #rm m4/lt* m4/libtool.m4
+}
+
+src_configure() {
+ local x
+
+ # filter -Os according to docs
+ replace-flags -Os -O2
+
+ for x in ${FFTW_DIRS}; do
+ myeconfargs=(
+ $(use_enable fortran)
+ $(use_enable zbus mips-zbus-timer)
+ $(use_enable threads)
+ $(use_enable openmp)
+ )
+ if [[ $x == single ]]; then
+ #altivec, sse, single-paired only work for single
+ myeconfargs+=(
+ --enable-single
+ $(use_enable altivec)
+ $(use_enable avx)
+ $(use_enable sse)
+ $(use_enable mpi)
+ $(use_enable neon)
+ )
+ elif [[ $x == double ]]; then
+ myeconfargs+=(
+ $(use_enable avx)
+ $(use_enable sse2)
+ $(use_enable mpi)
+ )
+ elif [[ $x == longdouble ]]; then
+ myeconfargs+=(
+ --enable-long-double
+ $(use_enable mpi)
+ )
+ elif [[ $x == quad ]]; then
+ #quad does not support mpi
+ myeconfargs+=( --enable-quad-precision )
+ else
+ die "${x} precision not implemented in this ebuild"
+ fi
+
+ einfo "Configuring for ${x} precision"
+ AUTOTOOLS_BUILD_DIR="${S}-${x}" \
+ autotools-utils_src_configure
+ done
+}
+
+src_compile() {
+ for x in ${FFTW_DIRS}; do
+ einfo "Compiling for ${x} precision"
+ AUTOTOOLS_BUILD_DIR="${S}-${x}" \
+ autotools-utils_src_compile
+ done
+}
+
+src_test () {
+ # We want this to be a reasonably quick test, but that is still hard...
+ ewarn "This test series will take 30 minutes on a modern 2.5Ghz machine"
+ # Do not increase the number of threads, it will not help your performance
+ #local testbase="perl check.pl --nthreads=1 --estimate"
+ # ${testbase} -${p}d || die "Failure: $n"
+ for x in ${FFTW_DIRS}; do
+ cd "${S}-${x}/tests"
+ einfo "Testing ${x} precision"
+ emake smallcheck
+ done
+}
+
+src_install () {
+ local u x
+ DOCS=( AUTHORS ChangeLog NEWS README TODO COPYRIGHT CONVENTIONS )
+ HTML_DOCS=( doc/html/ )
+ for x in ${FFTW_DIRS}; do
+ AUTOTOOLS_BUILD_DIR="${S}-${x}" \
+ autotools-utils_src_install
+ done
+
+ if use doc; then
+ dodoc doc/*.pdf
+ insinto /usr/share/doc/${PF}/faq
+ doins -r doc/FAQ/fftw-faq.html/*
+ else
+ rm -r "${ED}"/usr/share/doc/${PF}/html
+ fi
+
+ for x in "${ED}"/usr/lib*/pkgconfig/*.pc; do
+ for u in $(usev mpi) $(usev threads) $(usex openmp omp ""); do
+ sed -e "s|-lfftw3[flq]\?|&_$u &|" "$x" > "${x%.pc}_$u.pc" || die
+ done
+ done
+}