summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-11-26 00:20:49 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-11-26 00:20:49 +0000
commitea8482186488e22793728ac95905122c54f2ab8d (patch)
tree2c686b185b3455e6fec815ede78f0dd0fba22a49 /sci-libs/fftw
parentVersion bump (bug #407733). (diff)
downloadgentoo-2-ea8482186488e22793728ac95905122c54f2ab8d.tar.gz
gentoo-2-ea8482186488e22793728ac95905122c54f2ab8d.tar.bz2
gentoo-2-ea8482186488e22793728ac95905122c54f2ab8d.zip
version bump
(Portage version: 2.2.0_alpha142/cvs/Linux i686, signed Manifest commit with key C2000586)
Diffstat (limited to 'sci-libs/fftw')
-rw-r--r--sci-libs/fftw/ChangeLog8
-rw-r--r--sci-libs/fftw/fftw-3.3.3.ebuild143
-rw-r--r--sci-libs/fftw/metadata.xml1
3 files changed, 151 insertions, 1 deletions
diff --git a/sci-libs/fftw/ChangeLog b/sci-libs/fftw/ChangeLog
index 1eba9aac870f..82b0a6bb3610 100644
--- a/sci-libs/fftw/ChangeLog
+++ b/sci-libs/fftw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/fftw
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.131 2012/10/18 21:42:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.132 2012/11/26 00:20:49 ottxor Exp $
+
+*fftw-3.3.3 (26 Nov 2012)
+
+ 26 Nov 2012; Christoph Junghans <ottxor@gentoo.org> +fftw-3.3.3.ebuild,
+ metadata.xml:
+ version bump
18 Oct 2012; Justin Lecher <jlec@gentoo.org> fftw-2.1.5-r8.ebuild,
fftw-3.2.2.ebuild, fftw-3.2.2-r2.ebuild, fftw-3.3.2.ebuild:
diff --git a/sci-libs/fftw/fftw-3.3.3.ebuild b/sci-libs/fftw/fftw-3.3.3.ebuild
new file mode 100644
index 000000000000..9a1eae98a6c7
--- /dev/null
+++ b/sci-libs/fftw/fftw-3.3.3.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.3.3.ebuild,v 1.1 2012/11/26 00:20:49 ottxor Exp $
+
+EAPI=4
+
+#AUTOTOOLS_AUTORECONF=1
+FORTRAN_NEEDED=fortran
+
+inherit autotools-utils eutils flag-o-matic fortran-2 toolchain-funcs versionator
+
+DESCRIPTION="Fast C library for the Discrete Fourier Transform"
+HOMEPAGE="http://www.fftw.org/"
+SRC_URI="http://www.fftw.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="3.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="altivec avx doc fma fortran mpi neon openmp quad sse sse2 static-libs threads zbus"
+
+DEPEND="mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if use openmp; then
+ if [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then
+ ewarn "OpenMP is not available in your current selected gcc"
+ die "need openmp capable gcc"
+ fi
+ FORTRAN_NEED_OPENMP=1
+ fi
+ fortran-2_pkg_setup
+ FFTW_DIRS="single double longdouble"
+ if use quad; then
+ if [[ $(tc-getCC) == *gcc ]] && ! version_is_at_least 4.6 $(gcc-version); then
+ ewarn "quad precision only available for gcc >= 4.6"
+ die "need quad precision capable gcc"
+ fi
+ FFTW_DIRS+=" quad"
+ fi
+}
+
+src_prepare() {
+ # fix info file for category directory
+ sed -i \
+ -e 's/Texinfo documentation system/Libraries/' \
+ doc/fftw3.info || die "failed to fix info file"
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local x
+
+ # filter -Os according to docs
+ replace-flags -Os -O2
+
+ for x in ${FFTW_DIRS}; do
+ myeconfargs=(
+ $(use_enable fma)
+ $(use_enable fortran)
+ $(use_enable zbus mips-zbus-timer)
+ $(use_enable threads)
+ $(use_enable openmp)
+ )
+ if [[ $x == single ]]; then
+ #altivec, sse, single-paired only work for single
+ myeconfargs+=(
+ --enable-single
+ $(use_enable altivec)
+ $(use_enable avx)
+ $(use_enable sse)
+ $(use_enable mpi)
+ $(use_enable neon)
+ )
+ elif [[ $x == double ]]; then
+ myeconfargs+=(
+ $(use_enable avx)
+ $(use_enable sse2)
+ $(use_enable mpi)
+ )
+ elif [[ $x == longdouble ]]; then
+ myeconfargs+=(
+ --enable-long-double
+ $(use_enable mpi)
+ )
+ elif [[ $x == quad ]]; then
+ #quad does not support mpi
+ myeconfargs+=( --enable-quad-precision )
+ else
+ die "${x} precision not implemented in this ebuild"
+ fi
+
+ einfo "Configuring for ${x} precision"
+ AUTOTOOLS_BUILD_DIR="${S}-${x}" \
+ autotools-utils_src_configure
+ done
+}
+
+src_compile() {
+ for x in ${FFTW_DIRS}; do
+ einfo "Compiling for ${x} precision"
+ AUTOTOOLS_BUILD_DIR="${S}-${x}" \
+ autotools-utils_src_compile
+ done
+}
+
+src_test () {
+ # We want this to be a reasonably quick test, but that is still hard...
+ ewarn "This test series will take 30 minutes on a modern 2.5Ghz machine"
+ # Do not increase the number of threads, it will not help your performance
+ #local testbase="perl check.pl --nthreads=1 --estimate"
+ # ${testbase} -${p}d || die "Failure: $n"
+ for x in ${FFTW_DIRS}; do
+ cd "${S}-${x}/tests"
+ einfo "Testing ${x} precision"
+ emake smallcheck
+ done
+}
+
+src_install () {
+ local u x
+ DOCS=( AUTHORS ChangeLog NEWS README TODO COPYRIGHT CONVENTIONS )
+ HTML_DOCS=( doc/html/ )
+ for x in ${FFTW_DIRS}; do
+ AUTOTOOLS_BUILD_DIR="${S}-${x}" \
+ autotools-utils_src_install
+ done
+
+ if use doc; then
+ dodoc doc/*.pdf
+ insinto /usr/share/doc/${PF}/faq
+ doins -r doc/FAQ/fftw-faq.html/*
+ else
+ rm -r "${ED}"/usr/share/doc/${PF}/html
+ fi
+
+ for x in "${ED}"/usr/lib*/pkgconfig/*.pc; do
+ for u in $(usev mpi) $(usev threads) $(usex openmp omp ""); do
+ sed -e "s|-lfftw3[flq]\?|&_$u &|" "$x" > "${x%.pc}_$u.pc" || die
+ done
+ done
+}
diff --git a/sci-libs/fftw/metadata.xml b/sci-libs/fftw/metadata.xml
index e6d20c6a3cd5..86851ca008e8 100644
--- a/sci-libs/fftw/metadata.xml
+++ b/sci-libs/fftw/metadata.xml
@@ -15,6 +15,7 @@
<flag name="avx">Adds support for Advanced Vector Extensions</flag>
<flag name="float">Link default library to single precision instead of
double (symlinks only and fftw-2.1)</flag>
+ <flag name="fma">Use the Fused Multiply Add instruction set</flag>
<flag name="paired-single">Adds support for pair-single optimizations of mips</flag>
<flag name="quad">Build quadruple precision lib</flag>
<flag name="zbus">Adds support for ZBus cycle-counter of mips</flag>