summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-11-26 22:55:43 +0000
committerMichał Górny <mgorny@gentoo.org>2011-11-26 22:55:43 +0000
commitf562616c24286a311d073f93da89dd720a46823e (patch)
tree7cc93f8dc7f9c752b083ba24bd7dcf3ae9406620 /sci-libs/freesteam
parentFix build issue when USE=-utp, bug #290737. (diff)
downloadgentoo-2-f562616c24286a311d073f93da89dd720a46823e.tar.gz
gentoo-2-f562616c24286a311d073f93da89dd720a46823e.tar.bz2
gentoo-2-f562616c24286a311d073f93da89dd720a46823e.zip
Introduce the initial ebuild for freesteam, free IF97 steam tables implementation.
(Portage version: 2.2.0_alpha77/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/freesteam')
-rw-r--r--sci-libs/freesteam/ChangeLog12
-rw-r--r--sci-libs/freesteam/files/freesteam-flags.patch28
-rw-r--r--sci-libs/freesteam/files/freesteam-soname-symlinks.patch39
-rw-r--r--sci-libs/freesteam/freesteam-2.0.ebuild49
-rw-r--r--sci-libs/freesteam/metadata.xml8
5 files changed, 136 insertions, 0 deletions
diff --git a/sci-libs/freesteam/ChangeLog b/sci-libs/freesteam/ChangeLog
new file mode 100644
index 000000000000..1c75a12dcc57
--- /dev/null
+++ b/sci-libs/freesteam/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for sci-libs/freesteam
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/freesteam/ChangeLog,v 1.1 2011/11/26 22:55:43 mgorny Exp $
+
+*freesteam-2.0 (26 Nov 2011)
+
+ 26 Nov 2011; Michał Górny <mgorny@gentoo.org> +freesteam-2.0.ebuild,
+ +files/freesteam-flags.patch, +files/freesteam-soname-symlinks.patch,
+ +metadata.xml:
+ Introduce the initial ebuild for freesteam, free IF97 steam tables
+ implementation.
+
diff --git a/sci-libs/freesteam/files/freesteam-flags.patch b/sci-libs/freesteam/files/freesteam-flags.patch
new file mode 100644
index 000000000000..615bdc050321
--- /dev/null
+++ b/sci-libs/freesteam/files/freesteam-flags.patch
@@ -0,0 +1,28 @@
+From 6a68348f4b1fb755724e1df34bff4d6986d07dab Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <gentoo@mgorny.alt.pl>
+Date: Sat, 26 Nov 2011 22:30:15 +0100
+Subject: [PATCH] Merge CFLAGS and LDFLAGS from the environment.
+
+---
+ SConstruct | 5 +++++
+ 1 files changed, 5 insertions(+), 0 deletions(-)
+
+diff --git a/SConstruct b/SConstruct
+index 9dc17f5..e529e88 100644
+--- a/SConstruct
++++ b/SConstruct
+@@ -194,6 +194,11 @@ SConsEnvironment.InstallLibraryAs = lambda env, dest, files: InstallPermAs(env,
+
+ vars.Update(env)
+
++# Merge environment CFLAGS & LDFLAGS
++
++env.MergeFlags([os.environ.get('CFLAGS', ''),
++ os.environ.get('LDFLAGS', '')])
++
+ #----------------
+ # SWIG
+
+--
+1.7.8.rc3.31.g017d.dirty
+
diff --git a/sci-libs/freesteam/files/freesteam-soname-symlinks.patch b/sci-libs/freesteam/files/freesteam-soname-symlinks.patch
new file mode 100644
index 000000000000..dbd8b2a64c26
--- /dev/null
+++ b/sci-libs/freesteam/files/freesteam-soname-symlinks.patch
@@ -0,0 +1,39 @@
+From dd03d6b29fd29f9978022291f0c023e4fe5dd345 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <gentoo@mgorny.alt.pl>
+Date: Sat, 26 Nov 2011 23:18:37 +0100
+Subject: [PATCH] Fix SONAME symlinks - make them relative.
+
+---
+ SConstruct | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/SConstruct b/SConstruct
+index 1794691..d84a13a 100644
+--- a/SConstruct
++++ b/SConstruct
+@@ -5,7 +5,7 @@
+ # We don't currently propose to support building freesteam from MSVS but
+ # that shouldn't be necessary, as you should be able to use the MinGW-generated
+ # DLL even with MSVS, because it only uses C code.
+-import platform, sys, distutils.sysconfig, os
++import platform, sys, distutils.sysconfig, os, os.path
+
+ #version number for this copy of freesteam
+ version = "2.1"
+@@ -436,11 +436,11 @@ else:
+
+ install_link1 = None
+ if env.subst(link1) != env.subst(libname):
+- install_link1 = env.Command("${INSTALL_ROOT}"+link1,install_lib,"ln -s %s $TARGET" % libname)
++ install_link1 = env.Command("${INSTALL_ROOT}"+link1,install_lib,"ln -s %s $TARGET" % os.path.basename(libname))
+
+ install_link2 = None
+ if env.get("SONAME_MINOR"):
+- install_link2 = env.Command("${INSTALL_ROOT}"+link2,install_lib,"ln -s %s $TARGET"%libname)
++ install_link2 = env.Command("${INSTALL_ROOT}"+link2,install_lib,"ln -s %s $TARGET"%os.path.basename(libname))
+
+ env['installedfiles'] += [install_link1, install_link2]
+
+--
+1.7.8.rc3.31.g017d.dirty
+
diff --git a/sci-libs/freesteam/freesteam-2.0.ebuild b/sci-libs/freesteam/freesteam-2.0.ebuild
new file mode 100644
index 000000000000..549d7fd94482
--- /dev/null
+++ b/sci-libs/freesteam/freesteam-2.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/freesteam/freesteam-2.0.ebuild,v 1.1 2011/11/26 22:55:43 mgorny Exp $
+
+EAPI=4
+
+inherit base multilib scons-utils toolchain-funcs
+
+DESCRIPTION="Open source implementation of IF97 steam tables"
+HOMEPAGE="http://freesteam.sourceforge.net/"
+SRC_URI="mirror://sourceforge/freesteam/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sci-libs/gsl"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}"/${PN}-flags.patch
+ "${FILESDIR}"/${PN}-soname-symlinks.patch
+ )
+
+ base_src_prepare
+}
+
+src_configure() {
+ myesconsargs=(
+ INSTALL_PREFIX=/usr
+ INSTALL_LIB=/usr/$(get_libdir)
+ INSTALL_ROOT="${D}"
+
+ CC="$(tc-getCC)"
+ SWIG=false
+ )
+
+ mkdir -p "${D}" || die
+}
+
+src_compile() {
+ escons
+}
+
+src_install() {
+ escons install
+}
diff --git a/sci-libs/freesteam/metadata.xml b/sci-libs/freesteam/metadata.xml
new file mode 100644
index 000000000000..5cb9324943ab
--- /dev/null
+++ b/sci-libs/freesteam/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+</pkgmetadata>