summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2006-12-16 11:11:54 +0000
committerTiziano Müller <dev-zero@gentoo.org>2006-12-16 11:11:54 +0000
commit5f1fe78d2e7da42a203401d1113c33c62ebb8dc0 (patch)
tree6c4e4b03211b81e967865d86a021709ae27f08aa /sci-libs/geos
parentInitial import (diff)
downloadgentoo-2-5f1fe78d2e7da42a203401d1113c33c62ebb8dc0.tar.gz
gentoo-2-5f1fe78d2e7da42a203401d1113c33c62ebb8dc0.tar.bz2
gentoo-2-5f1fe78d2e7da42a203401d1113c33c62ebb8dc0.zip
Added patch to fix #158262
(Portage version: 2.1.2_rc3)
Diffstat (limited to 'sci-libs/geos')
-rw-r--r--sci-libs/geos/ChangeLog6
-rw-r--r--sci-libs/geos/files/geos-3.0.0_rc3-amd64.patch33
-rw-r--r--sci-libs/geos/geos-3.0.0_rc3.ebuild10
3 files changed, 47 insertions, 2 deletions
diff --git a/sci-libs/geos/ChangeLog b/sci-libs/geos/ChangeLog
index 8ab4fb4c929b..f784bfdb9560 100644
--- a/sci-libs/geos/ChangeLog
+++ b/sci-libs/geos/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/geos
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.22 2006/12/14 20:51:32 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.23 2006/12/16 11:11:54 dev-zero Exp $
+
+ 16 Dec 2006; Tiziano Müller <dev-zero@gentoo.org>
+ +files/geos-3.0.0_rc3-amd64.patch, geos-3.0.0_rc3.ebuild:
+ Added patch to fix #158262
*geos-3.0.0_rc3 (14 Dec 2006)
*geos-2.2.3 (14 Dec 2006)
diff --git a/sci-libs/geos/files/geos-3.0.0_rc3-amd64.patch b/sci-libs/geos/files/geos-3.0.0_rc3-amd64.patch
new file mode 100644
index 000000000000..9376051ded4c
--- /dev/null
+++ b/sci-libs/geos/files/geos-3.0.0_rc3-amd64.patch
@@ -0,0 +1,33 @@
+--- swig/geos.i.orig 2006-12-16 11:47:15.000000000 +0100
++++ swig/geos.i 2006-12-16 11:48:33.000000000 +0100
+@@ -127,7 +127,7 @@
+
+ void checkCoordSeqBounds(const GEOSCoordSeq coordSeq, const size_t index)
+ {
+- size_t size = 0;
++ unsigned int size = 0;
+ GEOSCoordSeq_getSize(coordSeq, &size);
+
+ if (index < 0 || index >= size)
+@@ -223,17 +223,17 @@
+ return result;
+ }
+
+- int getSize()
++ unsigned int getSize()
+ {
+- size_t result;
++ unsigned int result;
+ GEOSCoordSeq coords = (GEOSCoordSeq) self;
+ GEOSCoordSeq_getSize(coords, &result);
+ return result;
+ }
+
+- int getDimensions()
++ unsigned int getDimensions()
+ {
+- size_t result;
++ unsigned int result;
+ GEOSCoordSeq coords = (GEOSCoordSeq) self;
+ GEOSCoordSeq_getDimensions(coords, &result);
+ return result;
diff --git a/sci-libs/geos/geos-3.0.0_rc3.ebuild b/sci-libs/geos/geos-3.0.0_rc3.ebuild
index 4fcf25155a2e..b7f924ab7998 100644
--- a/sci-libs/geos/geos-3.0.0_rc3.ebuild
+++ b/sci-libs/geos/geos-3.0.0_rc3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.0.0_rc3.ebuild,v 1.1 2006/12/14 20:51:32 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.0.0_rc3.ebuild,v 1.2 2006/12/16 11:11:54 dev-zero Exp $
+
+inherit eutils
MY_P=${PN}-${PV/_/}
@@ -22,6 +24,12 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-amd64.patch"
+}
+
src_compile() {
local myconf="--with-pic"