summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-08-08 17:11:25 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-08-08 17:11:25 +0000
commit90ffccbdaa9f23c248416aff46e9f4acbd91899d (patch)
treef00a8f2d278b2523d16ac1e47e68af5f04985a3f /sci-libs/gerris
parentWorkaround to make test pass with ruby19 and rake 0.8. This is already fixed ... (diff)
downloadgentoo-2-90ffccbdaa9f23c248416aff46e9f4acbd91899d.tar.gz
gentoo-2-90ffccbdaa9f23c248416aff46e9f4acbd91899d.tar.bz2
gentoo-2-90ffccbdaa9f23c248416aff46e9f4acbd91899d.zip
Restricting test because it requires pre-installation of gerris. Added more mpi flag requirements, and a patch to compile with hypre when mpi is not set
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/gerris')
-rw-r--r--sci-libs/gerris/ChangeLog7
-rw-r--r--sci-libs/gerris/files/gerris-hypre-no-mpi.patch21
-rw-r--r--sci-libs/gerris/gerris-20120731.ebuild16
3 files changed, 39 insertions, 5 deletions
diff --git a/sci-libs/gerris/ChangeLog b/sci-libs/gerris/ChangeLog
index f309725de1de..5ba4ef95b6e1 100644
--- a/sci-libs/gerris/ChangeLog
+++ b/sci-libs/gerris/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/gerris
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gerris/ChangeLog,v 1.16 2012/08/02 21:30:17 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gerris/ChangeLog,v 1.17 2012/08/08 17:11:25 bicatali Exp $
+
+ 08 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/gerris-hypre-no-mpi.patch, gerris-20120731.ebuild:
+ Restricting test because it requires pre-installation of gerris. Added more
+ mpi flag requirements, and a patch to compile with hypre when mpi is not set
*gerris-20120731 (02 Aug 2012)
diff --git a/sci-libs/gerris/files/gerris-hypre-no-mpi.patch b/sci-libs/gerris/files/gerris-hypre-no-mpi.patch
new file mode 100644
index 000000000000..2e3aede8b7d6
--- /dev/null
+++ b/sci-libs/gerris/files/gerris-hypre-no-mpi.patch
@@ -0,0 +1,21 @@
+--- configure.in.orig 2012-08-08 17:19:49.374366942 +0100
++++ configure.in 2012-08-08 17:20:40.585155226 +0100
+@@ -334,7 +334,8 @@
+
+ # Build hypre module if HYPRE is installed
+ hypre=no
+-if test "x$use_mpicc" = "xyes" ; then # HYPRE needs MPI
++# hypre does not need mpi
++#if test "x$use_mpicc" = "xyes" ; then # HYPRE needs MPI
+ AC_CHECK_LIB(HYPRE, HYPRE_IJMatrixCreate, hypre="yes", hypre="no", [-lm])
+ if test x$hypre = xyes; then
+ AC_CHECK_HEADERS(HYPRE.h, hypre="yes", hypre="no")
+@@ -342,7 +343,7 @@
+ if test x$hypre = xno; then
+ AC_MSG_WARN([HYPRE not found. hypre Module won't be available.])
+ fi
+-fi
++#fi
+ AM_CONDITIONAL(BUILD_HYPRE, test x$hypre = xyes)
+
+ # Build lis module if lis is installed
diff --git a/sci-libs/gerris/gerris-20120731.ebuild b/sci-libs/gerris/gerris-20120731.ebuild
index 7732277a4ccc..82b465505371 100644
--- a/sci-libs/gerris/gerris-20120731.ebuild
+++ b/sci-libs/gerris/gerris-20120731.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gerris/gerris-20120731.ebuild,v 1.1 2012/08/02 21:30:17 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gerris/gerris-20120731.ebuild,v 1.2 2012/08/08 17:11:25 bicatali Exp $
EAPI=4
-inherit autotools eutils flag-o-matic
+inherit eutils flag-o-matic autotools
MYP=${P/-20/-snapshot-}
@@ -26,8 +26,8 @@ RDEPEND="dev-libs/glib:2
sci-libs/netcdf
sci-libs/gsl
sci-libs/gts
- sci-libs/hypre
- sci-libs/lis
+ sci-libs/hypre[mpi?]
+ sci-libs/lis[mpi?]
sci-libs/proj
>=sci-libs/fftw-3
virtual/lapack
@@ -37,6 +37,14 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MYP}"
+# buggy tests, need extra packages and require gerris to be installed
+RESTRICT=test
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-hypre-no-mpi.patch
+ eautoreconf
+}
+
src_configure() {
append-cppflags "-I${EPREFIX}/usr/include/hypre"
econf \