summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-11-21 07:25:56 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-11-21 07:25:56 +0000
commit07eab094c29e9388799268275028c3ef5215caf8 (patch)
tree8323245a71ae62a5ad8f71958dd5f892a6485ac6 /sci-libs/klu
parentVersion bump (diff)
downloadgentoo-2-07eab094c29e9388799268275028c3ef5215caf8.tar.gz
gentoo-2-07eab094c29e9388799268275028c3ef5215caf8.tar.bz2
gentoo-2-07eab094c29e9388799268275028c3ef5215caf8.zip
Version bump
(Portage version: 2.2_rc50/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/klu')
-rw-r--r--sci-libs/klu/ChangeLog9
-rw-r--r--sci-libs/klu/klu-1.1.0.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/sci-libs/klu/ChangeLog b/sci-libs/klu/ChangeLog
index 6fa20bded504..9928dce84e54 100644
--- a/sci-libs/klu/ChangeLog
+++ b/sci-libs/klu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/klu
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/klu/ChangeLog,v 1.1 2008/02/05 18:42:23 bicatali Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/klu/ChangeLog,v 1.2 2009/11/21 07:25:56 bicatali Exp $
+
+*klu-1.1.0 (21 Nov 2009)
+
+ 21 Nov 2009; Sébastien Fabbro <bicatali@gentoo.org> +klu-1.1.0.ebuild:
+ Version bump
*klu-1.0.1 (05 Feb 2008)
diff --git a/sci-libs/klu/klu-1.1.0.ebuild b/sci-libs/klu/klu-1.1.0.ebuild
new file mode 100644
index 000000000000..3f899e1570cb
--- /dev/null
+++ b/sci-libs/klu/klu-1.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/klu/klu-1.1.0.ebuild,v 1.1 2009/11/21 07:25:56 bicatali Exp $
+
+EAPI=2
+inherit autotools eutils
+
+MY_PN=KLU
+DESCRIPTION="Sparse LU factorization for circuit simulation"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/klu"
+SRC_URI="http://www.cise.ufl.edu/research/sparse/${PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+DEPEND="sci-libs/amd
+ sci-libs/btf
+ sci-libs/colamd"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.1-autotools.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README.txt Doc/ChangeLog || die "dodoc failed"
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins Doc/*.pdf || die
+ fi
+}