summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-12-27 18:55:33 +0000
committerJustin Lecher <jlec@gentoo.org>2012-12-27 18:55:33 +0000
commit27451f27605e7025e1396cf8cf9175ebe1ce352f (patch)
tree4bedff94a123d7da0ee463696eaa82ccc5704e0d /sci-libs/libcmatrix
parentmercurial.eclass respects now (diff)
downloadgentoo-2-27451f27605e7025e1396cf8cf9175ebe1ce352f.tar.gz
gentoo-2-27451f27605e7025e1396cf8cf9175ebe1ce352f.tar.bz2
gentoo-2-27451f27605e7025e1396cf8cf9175ebe1ce352f.zip
sci-libs/libcmatrix: Moved to EAPI=5 and autotools-utils.eclass
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-libs/libcmatrix')
-rw-r--r--sci-libs/libcmatrix/ChangeLog5
-rw-r--r--sci-libs/libcmatrix/libcmatrix-3.11.0.ebuild40
2 files changed, 24 insertions, 21 deletions
diff --git a/sci-libs/libcmatrix/ChangeLog b/sci-libs/libcmatrix/ChangeLog
index 2b3879855314..d32dade31a1b 100644
--- a/sci-libs/libcmatrix/ChangeLog
+++ b/sci-libs/libcmatrix/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/libcmatrix
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libcmatrix/ChangeLog,v 1.13 2012/12/27 18:31:20 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libcmatrix/ChangeLog,v 1.14 2012/12/27 18:55:33 jlec Exp $
+
+ 27 Dec 2012; Justin Lecher <jlec@gentoo.org> libcmatrix-3.11.0.ebuild:
+ Moved to EAPI=5 and autotools-utils.eclass
27 Dec 2012; Justin Lecher <jlec@gentoo.org> metadata.xml:
Drop local USE
diff --git a/sci-libs/libcmatrix/libcmatrix-3.11.0.ebuild b/sci-libs/libcmatrix/libcmatrix-3.11.0.ebuild
index e97db11b75f7..0284b92e62fa 100644
--- a/sci-libs/libcmatrix/libcmatrix-3.11.0.ebuild
+++ b/sci-libs/libcmatrix/libcmatrix-3.11.0.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libcmatrix/libcmatrix-3.11.0.ebuild,v 1.5 2012/12/27 18:30:44 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libcmatrix/libcmatrix-3.11.0.ebuild,v 1.6 2012/12/27 18:55:33 jlec Exp $
-EAPI="3"
+EAPI=5
-inherit autotools eutils
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
MY_P="${PN}${PV}_lite"
@@ -18,38 +20,36 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="sse threads"
-RDEPEND="
- sci-libs/atlas[lapack]
- sci-libs/minuit"
+RDEPEND="sci-libs/minuit"
DEPEND="${RDEPEND}"
S="${WORKDIR}"/${PN}R3
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PV}-shared.patch \
- "${FILESDIR}"/3.2.1-minuit2.patch \
- "${FILESDIR}"/3.2.1-gcc4.4.patch \
- "${FILESDIR}"/3.2.1-gcc4.6.patch \
- "${FILESDIR}"/3.2.1-gcc4.7.patch \
- "${FILESDIR}"/3.9.0-atlas.patch
- eautoreconf
-}
+PATCHES=(
+ "${FILESDIR}"/${PV}-shared.patch
+ "${FILESDIR}"/3.2.1-minuit2.patch
+ "${FILESDIR}"/3.2.1-gcc4.4.patch
+ "${FILESDIR}"/3.2.1-gcc4.6.patch
+ "${FILESDIR}"/3.2.1-gcc4.7.patch
+ "${FILESDIR}"/3.9.0-atlas.patch
+ )
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
src_configure() {
econf \
--with-minuit \
- --with-atlas \
+ --without-atlas \
--with-sysroot="${EROOT}" \
$(use_with sse) \
$(use_with threads)
}
src_install() {
- dolib.so lib/*.so* || die "install failed"
+ dolib.so lib/*.so*
insinto /usr/include/${PN}R3
- doins include/* || die "no includes"
+ doins include/*
- dodoc CHANGES docs/* || die "no docs"
+ dodoc CHANGES docs/*
}