summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2009-04-19 01:00:39 +0000
committerSteve Arnold <nerdboy@gentoo.org>2009-04-19 01:00:39 +0000
commit57885107c140b7ae015dbc6d0024c1ef9bc9b6ea (patch)
tree76d4f2087c65776dffe649f6df2039b9f2075b84 /sci-libs/libdap
parentVersion bump, mostly bugfixes. (diff)
downloadgentoo-2-57885107c140b7ae015dbc6d0024c1ef9bc9b6ea.tar.gz
gentoo-2-57885107c140b7ae015dbc6d0024c1ef9bc9b6ea.tar.bz2
gentoo-2-57885107c140b7ae015dbc6d0024c1ef9bc9b6ea.zip
New ebuild for OPeNDAP C++ library, a required dependency for ferret.
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/libdap')
-rw-r--r--sci-libs/libdap/ChangeLog10
-rw-r--r--sci-libs/libdap/libdap-3.9.2.ebuild51
-rw-r--r--sci-libs/libdap/metadata.xml16
3 files changed, 77 insertions, 0 deletions
diff --git a/sci-libs/libdap/ChangeLog b/sci-libs/libdap/ChangeLog
new file mode 100644
index 000000000000..0464c4930fd4
--- /dev/null
+++ b/sci-libs/libdap/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/libdap
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libdap/ChangeLog,v 1.1 2009/04/19 01:00:39 nerdboy Exp $
+
+*libdap-3.9.2 (19 Apr 2009)
+
+ 19 Apr 2009; Steve Arnold <nerdboy@gentoo.org> +metadata.xml,
+ +libdap-3.9.2.ebuild:
+ New ebuild for OPeNDAP C++ library, a required dependency for ferret.
+
diff --git a/sci-libs/libdap/libdap-3.9.2.ebuild b/sci-libs/libdap/libdap-3.9.2.ebuild
new file mode 100644
index 000000000000..dd9289e32c9c
--- /dev/null
+++ b/sci-libs/libdap/libdap-3.9.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libdap/libdap-3.9.2.ebuild,v 1.1 2009/04/19 01:00:39 nerdboy Exp $
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="A C++ SDK which contains an implementation of DAP 2.0 and 3.2, both Client- and Server-side support."
+HOMEPAGE="http://opendap.org/index.html"
+SRC_URI="http://www.opendap.org/pub/source/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-util/cppunit
+ dev-util/dejagnu"
+
+DEPEND="${RDEPEND}
+ sys-libs/zlib
+ >=dev-libs/libxml2-2.5.7
+ >=net-misc/curl-7.10.6
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ eaclocal
+ eautoreconf
+}
+
+src_compile() {
+ local myconf="--disable-dependency-tracking"
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+
+ if use doc; then
+ make docs || die "make docs failed"
+ fi
+}
+
+src_test() {
+ make check || die "make check failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc README NEWS README.dodsrc README.AIS
+ use doc && dohtml docs/html/*
+}
diff --git a/sci-libs/libdap/metadata.xml b/sci-libs/libdap/metadata.xml
new file mode 100644
index 000000000000..4bbe0bb1adb6
--- /dev/null
+++ b/sci-libs/libdap/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-geosciences</herd>
+<maintainer>
+ <email>nerdboy@gentoo.org</email>
+</maintainer>
+<longdescription>
+libdap is a C++ implementation of OPeNDAP which allows access to data over the
+internet, from programs that weren't originally designed for that purpose, as
+well as some that were. While OPeNDAP is the original developer of the Data
+Access Protocol (DAP) which it's software uses, many other groups have adopted
+DAP and provide compatible clients, servers and software development kits.
+DAP is a NASA community standard: http://www.esdswg.org/spg/rfc/ese-rfc-004
+</longdescription>
+</pkgmetadata>