summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2008-11-27 19:19:26 +0000
committerPatrick Lauer <patrick@gentoo.org>2008-11-27 19:19:26 +0000
commit3b7ca252ab4143c97e318f2a219f726593e09a5d (patch)
treee139f0616c8433b3e8a286de93439aa84b8fb26c /sci-libs/libghemical
parentBump to 1.14 (diff)
downloadgentoo-2-3b7ca252ab4143c97e318f2a219f726593e09a5d.tar.gz
gentoo-2-3b7ca252ab4143c97e318f2a219f726593e09a5d.tar.bz2
gentoo-2-3b7ca252ab4143c97e318f2a219f726593e09a5d.zip
Bump to 2.98
(Portage version: 2.2_rc16/cvs/Linux 2.6.26.5 x86_64)
Diffstat (limited to 'sci-libs/libghemical')
-rw-r--r--sci-libs/libghemical/ChangeLog7
-rw-r--r--sci-libs/libghemical/libghemical-2.98.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/sci-libs/libghemical/ChangeLog b/sci-libs/libghemical/ChangeLog
index bd89ac211b9d..e98a8fadd267 100644
--- a/sci-libs/libghemical/ChangeLog
+++ b/sci-libs/libghemical/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/libghemical
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libghemical/ChangeLog,v 1.17 2008/08/07 07:38:08 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libghemical/ChangeLog,v 1.18 2008/11/27 19:19:26 patrick Exp $
+
+*libghemical-2.98 (27 Nov 2008)
+
+ 27 Nov 2008; Patrick Lauer <patrick@gentoo.org> +libghemical-2.98.ebuild:
+ Bump to 2.98
07 Aug 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/sci-libs/libghemical/libghemical-2.98.ebuild b/sci-libs/libghemical/libghemical-2.98.ebuild
new file mode 100644
index 000000000000..52c2c6eab453
--- /dev/null
+++ b/sci-libs/libghemical/libghemical-2.98.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libghemical/libghemical-2.98.ebuild,v 1.1 2008/11/27 19:19:26 patrick Exp $
+
+inherit autotools
+
+DESCRIPTION="Chemical quantum mechanics and molecular mechanics"
+HOMEPAGE="http://bioinformatics.org/ghemical/"
+SRC_URI="http://www.bioinformatics.org/ghemical/download/current/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="mopac7 mpqc"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.15"
+RDEPEND="mopac7? ( >=sci-chemistry/mopac7-1.13-r1 )
+ mpqc? ( >=sci-chemistry/mpqc-2.3.1-r1
+ virtual/blas
+ virtual/lapack )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-gcc43.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable mopac7) \
+ $(use_enable mpqc) \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+}