summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-06-07 15:21:27 +0000
committerMichał Górny <mgorny@gentoo.org>2012-06-07 15:21:27 +0000
commite8890cbfa12f62d958baf96e394e03642496a7b3 (patch)
treea5aee88a02be3144ff491ecb928419f4c0cc7594 /sci-libs/libh2oxx
parentppc stable (bug 410601) (diff)
downloadgentoo-2-e8890cbfa12f62d958baf96e394e03642496a7b3.tar.gz
gentoo-2-e8890cbfa12f62d958baf96e394e03642496a7b3.tar.bz2
gentoo-2-e8890cbfa12f62d958baf96e394e03642496a7b3.zip
Version bump. The new version introduces properties for heat capacity & speed of sound. It also introduces initialized() property and is more strict regarding invalid use.
(Portage version: 2.2.0_alpha109_p1/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/libh2oxx')
-rw-r--r--sci-libs/libh2oxx/ChangeLog9
-rw-r--r--sci-libs/libh2oxx/libh2oxx-0.2.ebuild27
2 files changed, 35 insertions, 1 deletions
diff --git a/sci-libs/libh2oxx/ChangeLog b/sci-libs/libh2oxx/ChangeLog
index 27489943e378..e3fd261d7bf8 100644
--- a/sci-libs/libh2oxx/ChangeLog
+++ b/sci-libs/libh2oxx/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/libh2oxx
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libh2oxx/ChangeLog,v 1.1 2012/06/05 18:06:23 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libh2oxx/ChangeLog,v 1.2 2012/06/07 15:21:27 mgorny Exp $
+
+*libh2oxx-0.2 (07 Jun 2012)
+
+ 07 Jun 2012; Michał Górny <mgorny@gentoo.org> +libh2oxx-0.2.ebuild:
+ Version bump. The new version introduces properties for heat capacity & speed
+ of sound. It also introduces initialized() property and is more strict
+ regarding invalid use.
*libh2oxx-0.1 (05 Jun 2012)
diff --git a/sci-libs/libh2oxx/libh2oxx-0.2.ebuild b/sci-libs/libh2oxx/libh2oxx-0.2.ebuild
new file mode 100644
index 000000000000..004d902ef8cf
--- /dev/null
+++ b/sci-libs/libh2oxx/libh2oxx-0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libh2oxx/libh2oxx-0.2.ebuild,v 1.1 2012/06/07 15:21:27 mgorny Exp $
+
+EAPI=4
+
+inherit autotools-utils
+
+DESCRIPTION="C++ bindings for libh2o"
+HOMEPAGE="https://bitbucket.org/mgorny/libh2oxx/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug static-libs"
+
+RDEPEND=">=sci-libs/libh2o-0.2"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ )
+
+ autotools-utils_src_configure
+}