summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-10-18 16:57:39 +0000
committerJustin Lecher <jlec@gentoo.org>2012-10-18 16:57:39 +0000
commitb64bb793df34d1665332a238dd68ab204aed932b (patch)
tree0b13030bdb90cb8b66485be5bf85f38c779d1d5a /sci-libs/libpdb++
parentsci-libs/libpdb: Straighten ebuild by cleaning the buildsystem (diff)
downloadgentoo-2-b64bb793df34d1665332a238dd68ab204aed932b.tar.gz
gentoo-2-b64bb793df34d1665332a238dd68ab204aed932b.tar.bz2
gentoo-2-b64bb793df34d1665332a238dd68ab204aed932b.zip
sci-libs/libpdb++: Fix silent errors
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-libs/libpdb++')
-rw-r--r--sci-libs/libpdb++/ChangeLog6
-rw-r--r--sci-libs/libpdb++/files/libpdb++-040728-dynlib+flags.patch23
-rw-r--r--sci-libs/libpdb++/libpdb++-040728-r1.ebuild4
3 files changed, 18 insertions, 15 deletions
diff --git a/sci-libs/libpdb++/ChangeLog b/sci-libs/libpdb++/ChangeLog
index 42769992276a..2367bd5e7ae4 100644
--- a/sci-libs/libpdb++/ChangeLog
+++ b/sci-libs/libpdb++/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/libpdb++
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libpdb++/ChangeLog,v 1.2 2012/10/18 16:46:29 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libpdb++/ChangeLog,v 1.3 2012/10/18 16:57:39 jlec Exp $
+
+ 18 Oct 2012; Justin Lecher <jlec@gentoo.org> libpdb++-040728-r1.ebuild,
+ files/libpdb++-040728-dynlib+flags.patch:
+ Fix silent errors
*libpdb++-040728-r1 (18 Oct 2012)
diff --git a/sci-libs/libpdb++/files/libpdb++-040728-dynlib+flags.patch b/sci-libs/libpdb++/files/libpdb++-040728-dynlib+flags.patch
index 62603fbb2377..3600481f4c72 100644
--- a/sci-libs/libpdb++/files/libpdb++-040728-dynlib+flags.patch
+++ b/sci-libs/libpdb++/files/libpdb++-040728-dynlib+flags.patch
@@ -1,8 +1,8 @@
- Makefile | 18 ++++++++++++------
- 1 file changed, 12 insertions(+), 6 deletions(-)
+ Makefile | 20 +++++++++++++-------
+ 1 file changed, 13 insertions(+), 7 deletions(-)
diff --git a/Makefile b/Makefile
-index bbf0778..bb55ee9 100644
+index bbf0778..1dc6c62 100644
--- a/Makefile
+++ b/Makefile
@@ -4,22 +4,22 @@
@@ -32,7 +32,7 @@ index bbf0778..bb55ee9 100644
OBJS = pdb_read.o pdb_sprntf.o pdb_sscanf.o pdb_chars.o \
pdb_type.o pdb++.o pdbinput.o
SRCS = pdb_read.cc pdb_sprntf.cc pdb_sscanf.cc pdb_chars.cc \
-@@ -30,12 +30,18 @@ all: $(LIBARCH)
+@@ -30,10 +30,16 @@ all: $(LIBARCH)
install: $(LIBARCH)
install -F /usr/local/lib $(LIBARCH)
@@ -40,16 +40,15 @@ index bbf0778..bb55ee9 100644
+$(LIBARCH).a: $(OBJS)
@echo "Loading $(LIBARCH) ... "
- @ar cru $(LIBARCH) $(OBJS)
-+ @$(AR) cru $(LIBARCH) $(OBJS)
- @$(RANLIB) $(LIBARCH)
- @echo "done"
-
+- @$(RANLIB) $(LIBARCH)
++ $(AR) cru $@ $(OBJS)
++ $(RANLIB) $@
++ @echo "done"
++
+$(LIBARCH).so: $(OBJS)
+ $(CXX) $(LDFLAGS) -shared -Wl,--soname,libpdb++.so.0 -o libpdb++.so.0.1 $(OBJS)
+ ln -sf libpdb++.so.0.1 libpdb++.so.0
+ ln -sf libpdb++.so.0.1 libpdb++.so
-+ @echo "done"
-+
- clean:; @rm -f $(OBJS)
+ @echo "done"
- spotless:; @rm -f $(OBJS) $(LIBARCH)
+ clean:; @rm -f $(OBJS)
diff --git a/sci-libs/libpdb++/libpdb++-040728-r1.ebuild b/sci-libs/libpdb++/libpdb++-040728-r1.ebuild
index a97e14ed8dcc..9c243dcb010d 100644
--- a/sci-libs/libpdb++/libpdb++-040728-r1.ebuild
+++ b/sci-libs/libpdb++/libpdb++-040728-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libpdb++/libpdb++-040728-r1.ebuild,v 1.1 2012/10/18 16:46:29 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libpdb++/libpdb++-040728-r1.ebuild,v 1.2 2012/10/18 16:57:39 jlec Exp $
EAPI=4
@@ -27,7 +27,7 @@ src_unpack() {
src_prepare() {
epatch "${FILESDIR}"/${P}-dynlib+flags.patch
- tc-export CXX
+ tc-export CXX AR RANLIB
}
src_compile() {