summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2006-03-15 04:39:07 +0000
committerOlivier Fisette <ribosome@gentoo.org>2006-03-15 04:39:07 +0000
commit81a8da0aa0ae9148cd0f1cc2950205891b9dce15 (patch)
tree20e4d431302d1b7eacc12a471ab3f43d2f8a0155 /sci-libs/libticables
parentamd64 stable on the virtual too. Removed old versions. (diff)
downloadgentoo-2-81a8da0aa0ae9148cd0f1cc2950205891b9dce15.tar.gz
gentoo-2-81a8da0aa0ae9148cd0f1cc2950205891b9dce15.tar.bz2
gentoo-2-81a8da0aa0ae9148cd0f1cc2950205891b9dce15.zip
New version
(Portage version: 2.0.54)
Diffstat (limited to 'sci-libs/libticables')
-rw-r--r--sci-libs/libticables/ChangeLog10
-rw-r--r--sci-libs/libticables/Manifest16
-rw-r--r--sci-libs/libticables/files/digest-libticables-3.9.61
-rw-r--r--sci-libs/libticables/libticables-3.9.6.ebuild43
4 files changed, 56 insertions, 14 deletions
diff --git a/sci-libs/libticables/ChangeLog b/sci-libs/libticables/ChangeLog
index abffb40d6b2e..8cc99c5528ee 100644
--- a/sci-libs/libticables/ChangeLog
+++ b/sci-libs/libticables/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/libticables
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libticables/ChangeLog,v 1.4 2005/03/11 11:46:10 sekretarz Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libticables/ChangeLog,v 1.5 2006/03/15 04:39:07 ribosome Exp $
+
+*libticables-3.9.6 (15 Mar 2006)
+
+ 15 Mar 2006; Olivier Fisette <ribosome@gentoo.org>
+ +libticables-3.9.6.ebuild:
+ New version.
11 Mar 2005; Karol Wojtaszek <sekretarz@gentoo.org>
libticables-3.8.6.ebuild:
diff --git a/sci-libs/libticables/Manifest b/sci-libs/libticables/Manifest
index 3645e76cdcca..e6911c7f08c5 100644
--- a/sci-libs/libticables/Manifest
+++ b/sci-libs/libticables/Manifest
@@ -1,14 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 f549cb6ac1747e0467c86c6225432b4d libticables-3.8.6.ebuild 1145
MD5 59ac1520ffdfae74bbac229c1b32110d ChangeLog 1944
-MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 3ff798f8e75c90793abe96a6d0d58658 files/digest-libticables-3.8.6 77
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFCMZMnZ/iYVBmujdURApg5AKDjLVfPHkjn5UF8DyPp/jG2+/0LygCdFVT3
-Eo59vzohhTvLG2pr/1EcZME=
-=udno
------END PGP SIGNATURE-----
+MD5 90381b4ef1d96e6ffe1bfa51de44664a files/digest-libticables-3.9.6 69
+MD5 f549cb6ac1747e0467c86c6225432b4d libticables-3.8.6.ebuild 1145
+MD5 fce454de4cae748b21b82925984c345d libticables-3.9.6.ebuild 1094
+MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
diff --git a/sci-libs/libticables/files/digest-libticables-3.9.6 b/sci-libs/libticables/files/digest-libticables-3.9.6
new file mode 100644
index 000000000000..603f45da4d2d
--- /dev/null
+++ b/sci-libs/libticables/files/digest-libticables-3.9.6
@@ -0,0 +1 @@
+MD5 8f62d28c225fb4418dc204e3e7c56465 libticables-3.9.6.tar.gz 576711
diff --git a/sci-libs/libticables/libticables-3.9.6.ebuild b/sci-libs/libticables/libticables-3.9.6.ebuild
new file mode 100644
index 000000000000..8281d9eb6279
--- /dev/null
+++ b/sci-libs/libticables/libticables-3.9.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libticables/libticables-3.9.6.ebuild,v 1.1 2006/03/15 04:39:07 ribosome Exp $
+
+inherit eutils
+
+DESCRIPTION="Link cables support for the TiLP calculator linking program"
+HOMEPAGE="http://tilp.info/"
+#SRC_URI="mirror://sourceforge/tilp/${P}.tar.gz"
+SRC_URI="http://nico.hibou.free.fr/hibnet/gentoo/distfiles/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="debug nls"
+
+RDEPEND="virtual/libc
+ nls? ( sys-devel/gettext )"
+
+DEPEND="${RDEPEND}
+ sys-devel/bison"
+
+src_compile() {
+ local myconf="$(use_enable nls) $(use_enable debug logging)"
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D}
+ dobin ticables-config
+ dodoc AUTHORS LOGO NEWS README
+ doman ticables-config.1
+}
+
+pkg_postinst() {
+ einfo "To use \"${PN}\", you might need one of the following"
+ einfo "kernel modules: \"tipar\", \"tiser\" or \"tiusb\". If you install"
+ einfo "one of these modules, you might have to reinstall"
+ einfo "\"${PN}\". Please read the file:"
+ einfo "\"/usr/share/doc/${PF}/README.gz\" for more"
+ einfo "details."
+}