summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-07-09 16:50:55 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-07-09 16:50:55 +0000
commit08a6e8e949246ba87d960d08e46ccaf00ac69879 (patch)
tree0d9458d8d808d22af22808e8604fce9f4c3a5b86 /sci-libs/libticalcs2
parentRemove old. (diff)
downloadgentoo-2-08a6e8e949246ba87d960d08e46ccaf00ac69879.tar.gz
gentoo-2-08a6e8e949246ba87d960d08e46ccaf00ac69879.tar.bz2
gentoo-2-08a6e8e949246ba87d960d08e46ccaf00ac69879.zip
Version bump. Switch to autototools-utils eclass
(Portage version: 2.2.01.22120-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs/libticalcs2')
-rw-r--r--sci-libs/libticalcs2/ChangeLog9
-rw-r--r--sci-libs/libticalcs2/libticalcs2-1.1.8.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/sci-libs/libticalcs2/ChangeLog b/sci-libs/libticalcs2/ChangeLog
index 4e96f828c14e..282e320bbd5f 100644
--- a/sci-libs/libticalcs2/ChangeLog
+++ b/sci-libs/libticalcs2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/libticalcs2
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libticalcs2/ChangeLog,v 1.8 2012/08/04 15:02:44 bicatali Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libticalcs2/ChangeLog,v 1.9 2013/07/09 16:50:55 bicatali Exp $
+
+*libticalcs2-1.1.8 (09 Jul 2013)
+
+ 09 Jul 2013; Sébastien Fabbro <bicatali@gentoo.org> +libticalcs2-1.1.8.ebuild:
+ Version bump. Switch to autototools-utils eclass
04 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org> -libticalcs2-1.1.5.ebuild,
libticalcs2-1.1.7.ebuild:
diff --git a/sci-libs/libticalcs2/libticalcs2-1.1.8.ebuild b/sci-libs/libticalcs2/libticalcs2-1.1.8.ebuild
new file mode 100644
index 000000000000..f6db1af32b81
--- /dev/null
+++ b/sci-libs/libticalcs2/libticalcs2-1.1.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libticalcs2/libticalcs2-1.1.8.ebuild,v 1.1 2013/07/09 16:50:55 bicatali Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Library for communication with TI calculators"
+HOMEPAGE="http://lpg.ticalc.org/prj_tilp/"
+SRC_URI="mirror://sourceforge/tilp/tilp2-linux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc nls static-libs"
+
+RDEPEND="
+ dev-libs/glib:2
+ >=sci-libs/libticables2-1.3.3
+ >=sci-libs/libticonv-1.1.3
+ >=sci-libs/libtifiles2-1.1.5
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+DOCS=( AUTHORS LOGO NEWS README ChangeLog docs/api.txt )
+
+src_configure() {
+ local myeconfargs=(
+ --disable-rpath
+ $(use_enable nls)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dohtml docs/html/*
+}