summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-08-08 21:48:11 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-08-08 21:48:11 +0000
commiteab6768135f60dd4884b6cbc0fd4e7a51c3db74e (patch)
treef11672ae25bfd15aa144ed3923cac6995343572d /sci-libs/matio
parentVersion bump. Tentative to remove bundled joblib and atlas (which apparently ... (diff)
downloadgentoo-2-eab6768135f60dd4884b6cbc0fd4e7a51c3db74e.tar.gz
gentoo-2-eab6768135f60dd4884b6cbc0fd4e7a51c3db74e.tar.bz2
gentoo-2-eab6768135f60dd4884b6cbc0fd4e7a51c3db74e.zip
Version bump
(Portage version: 2.2.01.22124-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs/matio')
-rw-r--r--sci-libs/matio/ChangeLog8
-rw-r--r--sci-libs/matio/matio-1.5.2.ebuild (renamed from sci-libs/matio/matio-1.5.0.ebuild)35
2 files changed, 24 insertions, 19 deletions
diff --git a/sci-libs/matio/ChangeLog b/sci-libs/matio/ChangeLog
index 945a2e376a62..a8b5c801eca6 100644
--- a/sci-libs/matio/ChangeLog
+++ b/sci-libs/matio/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/matio
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/matio/ChangeLog,v 1.6 2013/03/22 10:50:10 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/matio/ChangeLog,v 1.7 2013/08/08 21:48:11 bicatali Exp $
+
+*matio-1.5.2 (08 Aug 2013)
+
+ 08 Aug 2013; Sébastien Fabbro <bicatali@gentoo.org> +matio-1.5.2.ebuild,
+ -matio-1.5.0.ebuild:
+ Version bump
22 Mar 2013; Andrey Grozin <grozin@gentoo.org> matio-1.5.1.ebuild:
Fixed docs installation
diff --git a/sci-libs/matio/matio-1.5.0.ebuild b/sci-libs/matio/matio-1.5.2.ebuild
index 854ed4479a7c..01819b7244ec 100644
--- a/sci-libs/matio/matio-1.5.0.ebuild
+++ b/sci-libs/matio/matio-1.5.2.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/matio/matio-1.5.0.ebuild,v 1.2 2012/08/03 22:14:07 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/matio/matio-1.5.2.ebuild,v 1.1 2013/08/08 21:48:11 bicatali Exp $
-EAPI=4
-inherit autotools eutils
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils eutils
DESCRIPTION="Library for reading and writing matlab files"
HOMEPAGE="http://sourceforge.net/projects/matio/"
@@ -17,28 +19,25 @@ RDEPEND="sys-libs/zlib
DEPEND="${RDEPEND}
doc? ( virtual/latex-base )"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-asneeded.patch
- eautoreconf
-}
+PATCHES=( "${FILESDIR}"/${PN}-1.5.0-asneeded.patch )
src_configure() {
- econf \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- --enable-shared \
- $(use_enable hdf5 mat73) \
- $(use_enable sparse extended-sparse) \
- $(use_enable static-libs static)
+ local myeconfargs=(
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ $(use_enable hdf5 mat73)
+ $(use_enable sparse extended-sparse)
+ )
+ autotools-utils_src_configure
}
src_compile() {
- emake
- use doc && emake -C documentation pdf
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile -C documentation pdf
}
src_install() {
- default
- use doc && dodoc documentation/matio_user_guide.pdf
+ autotools-utils_src_install
+ use doc && dodoc "${WORKDIR}"/${P}_build/documentation/matio_user_guide.pdf
if use examples; then
insinto /usr/share/doc/${PF}/examples
doins test/test*