summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-26 09:39:04 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-26 09:39:04 +0000
commit0b116478e7db801cbee03c2e81282721142f793e (patch)
treeb8045553eaa6e2175a14ee3dec1e4ab7075bc209 /sci-libs/metis
parentApply patch from Mateusz Dziadko <matidz.gentoo@gmail.com> to compile against... (diff)
downloadgentoo-2-0b116478e7db801cbee03c2e81282721142f793e.tar.gz
gentoo-2-0b116478e7db801cbee03c2e81282721142f793e.tar.bz2
gentoo-2-0b116478e7db801cbee03c2e81282721142f793e.zip
Bumped EAPI and corrected structure
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/metis')
-rw-r--r--sci-libs/metis/ChangeLog6
-rw-r--r--sci-libs/metis/metadata.xml10
-rw-r--r--sci-libs/metis/metis-4.0.1-r1.ebuild18
-rw-r--r--sci-libs/metis/metis-5.0_pre2-r1.ebuild40
4 files changed, 33 insertions, 41 deletions
diff --git a/sci-libs/metis/ChangeLog b/sci-libs/metis/ChangeLog
index 9586fb9c1778..51a668d02eec 100644
--- a/sci-libs/metis/ChangeLog
+++ b/sci-libs/metis/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/metis
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/metis/ChangeLog,v 1.22 2011/06/21 15:12:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/metis/ChangeLog,v 1.23 2011/06/26 09:39:04 jlec Exp $
+
+ 26 Jun 2011; Justin Lecher <jlec@gentoo.org> metis-4.0.1-r1.ebuild,
+ metis-5.0_pre2-r1.ebuild, metadata.xml:
+ Bumped EAPI and corrected structure
21 Jun 2011; Justin Lecher <jlec@gentoo.org> metis-4.0.1-r1.ebuild,
metis-5.0_pre2-r1.ebuild:
diff --git a/sci-libs/metis/metadata.xml b/sci-libs/metis/metadata.xml
index 61d4cce06889..ec25180123fe 100644
--- a/sci-libs/metis/metadata.xml
+++ b/sci-libs/metis/metadata.xml
@@ -1,15 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
METIS is a set of serial programs for partitioning graphs,
partitioning finite element meshes, and producing fill reducing
orderings for sparse matrices. The algorithms implemented in METIS are
based on the multilevel recursive-bisection, multilevel k-way, and
multi-constraint partitioning schemes.
</longdescription>
-<use>
- <flag name='int64'>Build the 64 bits integer library (metis >=5 only)</flag>
-</use>
+ <use>
+ <flag name="int64">Build the 64 bits integer library (metis &gt;=5 only)</flag>
+ </use>
</pkgmetadata>
diff --git a/sci-libs/metis/metis-4.0.1-r1.ebuild b/sci-libs/metis/metis-4.0.1-r1.ebuild
index 6a273c7fc7a6..67ab1d7e93a5 100644
--- a/sci-libs/metis/metis-4.0.1-r1.ebuild
+++ b/sci-libs/metis/metis-4.0.1-r1.ebuild
@@ -1,32 +1,32 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/metis/metis-4.0.1-r1.ebuild,v 1.17 2011/06/21 15:12:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/metis/metis-4.0.1-r1.ebuild,v 1.18 2011/06/26 09:39:04 jlec Exp $
inherit autotools eutils fortran-2
MYP=${PN}-4.0
+
DESCRIPTION="A package for unstructured serial graph partitioning"
HOMEPAGE="http://www-users.cs.umn.edu/~karypis/metis/metis/index.html"
SRC_URI="http://glaros.dtc.umn.edu/gkhome/fetch/sw/${PN}/${MYP}.tar.gz"
+SLOT="0"
KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86"
LICENSE="free-noncomm"
-
IUSE="doc static-libs"
-SLOT="0"
-DEPEND="
- virtual/fortran
- "
-RDEPEND="!sci-libs/parmetis"
+DEPEND="virtual/fortran"
+RDEPEND="${DEPEND}
+ !sci-libs/parmetis"
S="${WORKDIR}/${MYP}"
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${P}-autotools.patch
- epatch "${FILESDIR}"/${P}-gcc44.patch
+ epatch \
+ "${FILESDIR}"/${P}-autotools.patch \
+ "${FILESDIR}"/${P}-gcc44.patch
eautoreconf
}
diff --git a/sci-libs/metis/metis-5.0_pre2-r1.ebuild b/sci-libs/metis/metis-5.0_pre2-r1.ebuild
index 15a6a789c7d3..2252a1959d57 100644
--- a/sci-libs/metis/metis-5.0_pre2-r1.ebuild
+++ b/sci-libs/metis/metis-5.0_pre2-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/metis/metis-5.0_pre2-r1.ebuild,v 1.4 2011/06/21 15:12:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/metis/metis-5.0_pre2-r1.ebuild,v 1.5 2011/06/26 09:39:04 jlec Exp $
+
+EAPI=4
inherit autotools eutils fortran-2
@@ -10,36 +12,29 @@ DESCRIPTION="A package for unstructured serial graph partitioning"
HOMEPAGE="http://www-users.cs.umn.edu/~karypis/metis/metis/index.html"
SRC_URI="http://glaros.dtc.umn.edu/gkhome/fetch/sw/metis/metis-${MY_PV}.tar.gz"
+SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
LICENSE="free-noncomm"
-
-IUSE="pcre openmp int64 threads"
-SLOT="0"
+IUSE="int64 openmp pcre threads"
DEPEND="
virtual/fortran
- pcre? ( dev-libs/libpcre )
- openmp? ( || ( >=sys-devel/gcc-4.2 >=dev-lang/icc-9 ) )"
-
+ pcre? ( dev-libs/libpcre )"
RDEPEND="${DEPEND}
!sci-libs/parmetis"
S="${WORKDIR}/metis-${MY_PV}"
pkg_setup() {
- fortran-2_pkg_setup
- if use openmp \
- && [[ $(tc-getCC) == *gcc ]] \
- && [[ $(gcc-major-version)$(gcc-minor-version) -lt 42 ]]; then
- eerror "You need gcc >= 4.2 to use openmp features."
- eerror "Please use gcc-config to switch gcc version >= 4.2"
- die "setup gcc failed"
+ if use openmp; then
+ tc-has-openmp || \
+ die "Please select an OPENMP capable compiler"
+ FORTRAN_NEED_OPENMP=1
fi
+ fortran-2_pkg_setup
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${P}-autotools.patch
if use int64; then
sed -e 's/\(#define IDXTYPEWIDTH\).*32/\1 64/' \
@@ -54,15 +49,8 @@ src_unpack() {
eautoreconf
}
-src_compile() {
+src_configure() {
econf \
$(use_enable pcre) \
- $(use_enable openmp) \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc CHANGES.v5 || die "dodoc failed"
+ $(use_enable openmp)
}