summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-16 15:47:27 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-16 15:47:27 +0000
commit5eb43bec9c67d21e943aa2f388349f12e5cc317f (patch)
tree0d3445a1eb43eedda5e9c38e650d696bd0a978a2 /sci-libs/mkl
parentRemoval of fortran.eclass, #348851 (diff)
downloadgentoo-2-5eb43bec9c67d21e943aa2f388349f12e5cc317f.tar.gz
gentoo-2-5eb43bec9c67d21e943aa2f388349f12e5cc317f.tar.bz2
gentoo-2-5eb43bec9c67d21e943aa2f388349f12e5cc317f.zip
Removal of fortran.eclass, #348851
(Portage version: 2.2.0_alpha8/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/mkl')
-rw-r--r--sci-libs/mkl/ChangeLog6
-rw-r--r--sci-libs/mkl/mkl-10.0.2.018-r2.ebuild17
-rw-r--r--sci-libs/mkl/mkl-10.0.5.025.ebuild20
-rw-r--r--sci-libs/mkl/mkl-9.1.023.ebuild24
4 files changed, 32 insertions, 35 deletions
diff --git a/sci-libs/mkl/ChangeLog b/sci-libs/mkl/ChangeLog
index 1bce4c514d48..8d9ca7a4b31d 100644
--- a/sci-libs/mkl/ChangeLog
+++ b/sci-libs/mkl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/mkl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mkl/ChangeLog,v 1.38 2010/06/17 01:54:40 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mkl/ChangeLog,v 1.39 2010/12/16 15:47:27 jlec Exp $
+
+ 16 Dec 2010; Justin Lecher <jlec@gentoo.org> mkl-9.1.023.ebuild,
+ mkl-10.0.2.018-r2.ebuild, mkl-10.0.5.025.ebuild:
+ Removal of fortran.eclass, #348851
17 Jun 2010; Justin Bronder <jsbronder@gentoo.org>
mkl-10.0.2.018-r2.ebuild, mkl-10.0.5.025.ebuild:
diff --git a/sci-libs/mkl/mkl-10.0.2.018-r2.ebuild b/sci-libs/mkl/mkl-10.0.2.018-r2.ebuild
index a876882bf56e..b9f03a2dcd70 100644
--- a/sci-libs/mkl/mkl-10.0.2.018-r2.ebuild
+++ b/sci-libs/mkl/mkl-10.0.2.018-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mkl/mkl-10.0.2.018-r2.ebuild,v 1.2 2010/06/17 01:54:40 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mkl/mkl-10.0.2.018-r2.ebuild,v 1.3 2010/12/16 15:47:27 jlec Exp $
-inherit eutils toolchain-funcs fortran check-reqs
+inherit eutils toolchain-funcs check-reqs
PID=967
PB=${PN}
@@ -48,16 +48,13 @@ pkg_setup() {
check_reqs
# Check and setup fortran
- FORTRAN="gfortran ifc g77"
- use int64 && FORTRAN="gfortran ifc"
if use fortran95; then
- FORTRAN="gfortran ifc"
# blas95 and lapack95 don't compile with gfortran < 4.2
- [[ $(gcc-major-version)$(gcc-minor-version) -lt 42 ]] && FORTRAN="ifc"
+ [[ $(tc-getFC) == g* ]] && [[ $(gcc-major-version)$(gcc-minor-version) -lt 42 ]] &&
+ die "blas95 and lapack95 don't compile with gfortran < 4.2"
fi
- fortran_pkg_setup
MKL_FC="gnu"
- [[ ${FORTRANC} == if* ]] && MKL_FC="intel"
+ [[ $(tc-getFC) == if* ]] && MKL_FC="intel"
# build profiles according to what compiler is installed
MKL_CC="gnu"
@@ -145,11 +142,11 @@ src_compile() {
if use fortran95; then
einfo "Compiling fortan95 static lib wrappers"
local myconf="lib${MKL_ARCH}"
- [[ ${FORTRANC} == gfortran ]] && \
+ [[ $(tc-getFC) == gfortran ]] && \
myconf="${myconf} FC=gfortran"
if use int64; then
myconf="${myconf} interface=ilp64"
- [[ ${FORTRANC} == gfortran ]] && \
+ [[ $(tc-getFC) == gfortran ]] && \
myconf="${myconf} FOPTS=-fdefault-integer-8"
fi
for x in blas95 lapack95; do
diff --git a/sci-libs/mkl/mkl-10.0.5.025.ebuild b/sci-libs/mkl/mkl-10.0.5.025.ebuild
index fa803cb811f7..dd6fcdd67d1f 100644
--- a/sci-libs/mkl/mkl-10.0.5.025.ebuild
+++ b/sci-libs/mkl/mkl-10.0.5.025.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mkl/mkl-10.0.5.025.ebuild,v 1.4 2010/06/17 01:54:40 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mkl/mkl-10.0.5.025.ebuild,v 1.5 2010/12/16 15:47:27 jlec Exp $
-inherit eutils toolchain-funcs fortran check-reqs
+inherit eutils toolchain-funcs check-reqs
PID=1232
PB=${PN}
@@ -26,6 +26,9 @@ RDEPEND="${DEPEND}
MKL_DIR=/opt/intel/${PN}/${PV}
INTEL_LIC_DIR=/opt/intel/licenses
+QA_EXECSTACK="opt/intel/${PN}/${PV}/*"
+QA_TEXTRELS="opt/intel/${PN}/${PV}/*"
+
pkg_setup() {
# Check the license
if [[ -z ${MKL_LICENSE} ]]; then
@@ -45,16 +48,13 @@ pkg_setup() {
check_reqs
# Check and setup fortran
- FORTRAN="gfortran ifc g77"
- use int64 && FORTRAN="gfortran ifc"
if use fortran95; then
- FORTRAN="gfortran ifc"
# blas95 and lapack95 don't compile with gfortran < 4.2
- [[ $(gcc-major-version)$(gcc-minor-version) -lt 42 ]] && FORTRAN="ifc"
+ [[ $(tc-getFC) == g* ]] && [[ $(gcc-major-version)$(gcc-minor-version) -lt 42 ]] &&
+ die "blas95 and lapack95 don't compile with gfortran < 4.2"
fi
- fortran_pkg_setup
MKL_FC="gnu"
- [[ ${FORTRANC} == if* ]] && MKL_FC="intel"
+ [[ $(tc-getFC) == if* ]] && MKL_FC="intel"
# build profiles according to what compiler is installed
MKL_CC="gnu"
@@ -146,11 +146,11 @@ src_compile() {
if use fortran95; then
einfo "Compiling fortan95 static lib wrappers"
local myconf="lib${MKL_ARCH}"
- [[ ${FORTRANC} == gfortran ]] && \
+ [[ $(tc-getFC) == gfortran ]] && \
myconf="${myconf} FC=gfortran"
if use int64; then
myconf="${myconf} interface=ilp64"
- [[ ${FORTRANC} == gfortran ]] && \
+ [[ $(tc-getFC) == gfortran ]] && \
myconf="${myconf} FOPTS=-fdefault-integer-8"
fi
for x in blas95 lapack95; do
diff --git a/sci-libs/mkl/mkl-9.1.023.ebuild b/sci-libs/mkl/mkl-9.1.023.ebuild
index fd9ab2a1b36c..067e88fb8622 100644
--- a/sci-libs/mkl/mkl-9.1.023.ebuild
+++ b/sci-libs/mkl/mkl-9.1.023.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mkl/mkl-9.1.023.ebuild,v 1.9 2008/04/21 15:55:33 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mkl/mkl-9.1.023.ebuild,v 1.10 2010/12/16 15:47:27 jlec Exp $
-inherit eutils versionator toolchain-funcs fortran
+inherit eutils versionator toolchain-funcs
PID=779
PB=${PN}
@@ -51,10 +51,6 @@ pkg_setup() {
# setting up compilers
MKL_CC=gnu
[[ $(tc-getCC) == icc ]] && MKL_CC=icc
- FORTRAN="gfortran ifc g77"
- use fortran95 && FORTRAN="gfortran ifc"
- use int64 && FORTRAN="gfortran ifc"
- fortran_pkg_setup
}
src_unpack() {
@@ -129,9 +125,9 @@ src_unpack() {
fi
# fix a bad makefile in the test
- if [[ ${FORTRANC} == gfortran ]] || [[ ${FORTRANC} == if* ]]; then
+ if [[ $(tc-getFC) == gfortran ]] || [[ $(tc-getFC) == if* ]]; then
sed -i \
- -e "s/g77/${FORTRANC}/" \
+ -e "s/g77/$(tc-getFC)/" \
-e 's/-DGNU_USE//' \
tests/fftf/makefile || die "sed fftf test failed"
fi
@@ -148,7 +144,7 @@ src_compile() {
for x in blas95 lapack95; do
cd "${S}"/interfaces/${x}
emake \
- FC=${FORTRANC} \
+ FC=$(tc-getFC) \
MKL_SUBVERS=${p} \
lib${MKL_ARCH} \
|| die "emake $(basename ${x}) failed"
@@ -173,7 +169,7 @@ src_compile() {
src_test() {
local usegnu
- [[ ${FORTRANC} = g* ]] && usegnu=gnu
+ [[ $(tc-getFC) = g* ]] && usegnu=gnu
# restrict tests for blas and cblas for now.
# for t in blas cblas fft*; do
for t in blas lapack; do
@@ -182,7 +178,7 @@ src_test() {
einfo "Testing ${t} for ${p}"
emake -j1 \
F=${usegnu} \
- FC=${FORTRANC} \
+ FC=$(tc-getFC) \
MKL_SUBVERS=${p} \
lib${MKL_ARCH} \
|| die "emake ${t} failed"
@@ -200,7 +196,7 @@ mkl_install_lib() {
local extlibs="-L${libdir} -lguide -lpthread"
[[ "${1}" == "serial" ]] && extlibs=""
- [[ "${FORTRANC}" == "gfortran" ]] && \
+ [[ "$(tc-getFC)" == "gfortran" ]] && \
gfortranlibs="-L${libdir} -lmkl_gfortran"
cp -pPR "${S}"/${proflib} "${D}"${MKL_DIR}
@@ -290,7 +286,7 @@ pkg_postinst() {
elif use serial; then
ext=serial
fi
- ESELECT_PROF="${PN}-${FORTRANC}-${ext}"
+ ESELECT_PROF="${PN}-$(tc-getFC)-${ext}"
# if blas profile is mkl, set lapack and cblas profiles as mkl
local blas_lib=$(eselect blas show | cut -d' ' -f2)
for p in blas cblas lapack; do