summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-04-27 18:15:48 +0000
committerMichael Weber <xmw@gentoo.org>2013-04-27 18:15:48 +0000
commitc15892d7f9a9eb5074e89821df964bcfff59bf7e (patch)
tree779aaf8e0f25fee004aece6ef6c06430df693433 /sci-libs/opencascade/opencascade-6.5.ebuild
parentMove the ebuild to python-r1 eclasses. Sync with mpv ebuild. Patch by Nikoli. (diff)
downloadgentoo-2-c15892d7f9a9eb5074e89821df964bcfff59bf7e.tar.gz
gentoo-2-c15892d7f9a9eb5074e89821df964bcfff59bf7e.tar.bz2
gentoo-2-c15892d7f9a9eb5074e89821df964bcfff59bf7e.zip
java dependency, automake 1.13 fix
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'sci-libs/opencascade/opencascade-6.5.ebuild')
-rw-r--r--sci-libs/opencascade/opencascade-6.5.ebuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/sci-libs/opencascade/opencascade-6.5.ebuild b/sci-libs/opencascade/opencascade-6.5.ebuild
index 24cbd3634eed..7a28163c87ff 100644
--- a/sci-libs/opencascade/opencascade-6.5.ebuild
+++ b/sci-libs/opencascade/opencascade-6.5.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/opencascade/opencascade-6.5.ebuild,v 1.4 2013/03/03 10:08:32 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/opencascade/opencascade-6.5.ebuild,v 1.5 2013/04/27 18:15:48 xmw Exp $
EAPI=4
+
inherit autotools eutils check-reqs multilib java-pkg-opt-2 flag-o-matic
DESCRIPTION="Software development platform for CAD/CAE, 3D surface/solid modeling and data exchange"
@@ -15,24 +16,25 @@ KEYWORDS="~amd64 ~x86"
IUSE="debug doc examples gl2ps java"
DEPEND="
+ dev-lang/tcl
+ dev-lang/tk
+ dev-tcltk/itcl
+ dev-tcltk/itk
+ dev-tcltk/tix
media-libs/ftgl
virtual/glu
virtual/opengl
x11-libs/libXmu
- >=dev-lang/tcl-8.4
- >=dev-lang/tk-8.4
- >=dev-tcltk/itcl-3.2
- >=dev-tcltk/itk-3.2
- >=dev-tcltk/tix-8.4.2
gl2ps? ( x11-libs/gl2ps )
+ java? ( >=virtual/jdk-0 )
"
RDEPEND=${DEPEND}
S=${WORKDIR}/ros
-RESTRICT="bindist mirror"
# http://bugs.gentoo.org/show_bug.cgi?id=352435
# http://www.gentoo.org/foundation/en/minutes/2011/20110220_trustees.meeting_log.txt
+RESTRICT="bindist mirror"
CHECKREQS_MEMORY="256M"
CHECKREQS_DISK_BUILD="3584M"
@@ -58,10 +60,6 @@ pkg_setup() {
src_prepare() {
java-pkg-opt-2_src_prepare
- sed \
- -e '/AM_C_PROTOTYPES/d' \
- -i configure.* || die
-
# Substitute with our ready-made env.sh script
cp -f "${FILESDIR}"/env.sh.template env.sh || die
@@ -90,6 +88,10 @@ src_prepare() {
append-cxxflags "-fpermissive"
+ sed -e "/^AM_C_PROTOTYPES/d" \
+ -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" \
+ -i configure.* || die
+
eautoreconf
}