summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-21 21:26:09 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-21 21:26:09 +0000
commit3e3ef7e7a18509b60c2be072e391f16a9ceb5430 (patch)
tree156c92a20e72987f5afa02fe89d05ab73419ff69 /sci-libs/qrupdate
parentsci-libs/shogun: Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of ... (diff)
downloadgentoo-2-3e3ef7e7a18509b60c2be072e391f16a9ceb5430.tar.gz
gentoo-2-3e3ef7e7a18509b60c2be072e391f16a9ceb5430.tar.bz2
gentoo-2-3e3ef7e7a18509b60c2be072e391f16a9ceb5430.zip
sci-libs/qrupdate: Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-libs/qrupdate')
-rw-r--r--sci-libs/qrupdate/ChangeLog8
-rw-r--r--sci-libs/qrupdate/metadata.xml4
-rw-r--r--sci-libs/qrupdate/qrupdate-1.1.0.ebuild8
-rw-r--r--sci-libs/qrupdate/qrupdate-1.1.1.ebuild8
-rw-r--r--sci-libs/qrupdate/qrupdate-1.1.2.ebuild11
5 files changed, 22 insertions, 17 deletions
diff --git a/sci-libs/qrupdate/ChangeLog b/sci-libs/qrupdate/ChangeLog
index 9aa0e8d83ea3..3125fe0d964b 100644
--- a/sci-libs/qrupdate/ChangeLog
+++ b/sci-libs/qrupdate/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/qrupdate
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/ChangeLog,v 1.27 2012/10/24 22:27:56 naota Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/ChangeLog,v 1.28 2013/02/21 21:26:09 jlec Exp $
+
+ 21 Feb 2013; Justin Lecher <jlec@gentoo.org> qrupdate-1.1.0.ebuild,
+ qrupdate-1.1.1.ebuild, qrupdate-1.1.2.ebuild, metadata.xml:
+ Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config
24 Oct 2012; <naota@gentoo.org> +files/qrupdate-1.1.2-install.patch,
qrupdate-1.1.2.ebuild:
diff --git a/sci-libs/qrupdate/metadata.xml b/sci-libs/qrupdate/metadata.xml
index 76975a2a58e9..1d85f0ce2843 100644
--- a/sci-libs/qrupdate/metadata.xml
+++ b/sci-libs/qrupdate/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
qrupdate is a library for fast updating of qr and cholesky decompositions.
</longdescription>
</pkgmetadata>
diff --git a/sci-libs/qrupdate/qrupdate-1.1.0.ebuild b/sci-libs/qrupdate/qrupdate-1.1.0.ebuild
index ae6a6c481d45..819d72a1cfb7 100644
--- a/sci-libs/qrupdate/qrupdate-1.1.0.ebuild
+++ b/sci-libs/qrupdate/qrupdate-1.1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/qrupdate-1.1.0.ebuild,v 1.14 2012/10/16 20:02:31 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/qrupdate-1.1.0.ebuild,v 1.15 2013/02/21 21:26:09 jlec Exp $
EAPI="2"
@@ -24,8 +24,8 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.0.1-makefile.patch
- local BLAS_LIBS="$(pkg-config --libs blas)"
- local LAPACK_LIBS="$(pkg-config --libs lapack)"
+ local BLAS_LIBS="$($(tc-getPKG_CONFIG) --libs blas)"
+ local LAPACK_LIBS="$($(tc-getPKG_CONFIG) --libs lapack)"
sed -i Makeconf \
-e "s:gfortran:$(tc-getFC):g" \
diff --git a/sci-libs/qrupdate/qrupdate-1.1.1.ebuild b/sci-libs/qrupdate/qrupdate-1.1.1.ebuild
index 19d39a4a37b6..9ca57b0dbad8 100644
--- a/sci-libs/qrupdate/qrupdate-1.1.1.ebuild
+++ b/sci-libs/qrupdate/qrupdate-1.1.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/qrupdate-1.1.1.ebuild,v 1.7 2012/10/16 20:02:31 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/qrupdate-1.1.1.ebuild,v 1.8 2013/02/21 21:26:09 jlec Exp $
EAPI=4
@@ -24,8 +24,8 @@ src_prepare() {
sed -i Makeconf \
-e "s:gfortran:$(tc-getFC):g" \
-e "s:FFLAGS=.*:FFLAGS=${FFLAGS}:" \
- -e "s:BLAS=.*:BLAS=$(pkg-config --libs blas):" \
- -e "s:LAPACK=.*:LAPACK=$(pkg-config --libs lapack):" \
+ -e "s:BLAS=.*:BLAS=$($(tc-getPKG_CONFIG) --libs blas):" \
+ -e "s:LAPACK=.*:LAPACK=$($(tc-getPKG_CONFIG) --libs lapack):" \
-e "/^LIBDIR=/a\PREFIX=${EPREFIX}/usr" \
-e "s:LIBDIR=lib:LIBDIR=$(get_libdir):" \
|| die "Failed to set up Makeconf"
diff --git a/sci-libs/qrupdate/qrupdate-1.1.2.ebuild b/sci-libs/qrupdate/qrupdate-1.1.2.ebuild
index 9c088b79b11b..9c7e987f333b 100644
--- a/sci-libs/qrupdate/qrupdate-1.1.2.ebuild
+++ b/sci-libs/qrupdate/qrupdate-1.1.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/qrupdate-1.1.2.ebuild,v 1.4 2012/10/24 22:27:55 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/qrupdate-1.1.2.ebuild,v 1.5 2013/02/21 21:26:09 jlec Exp $
EAPI=4
@@ -20,13 +20,14 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.1.1-Makefiles.patch \
+ epatch \
+ "${FILESDIR}"/${PN}-1.1.1-Makefiles.patch \
"${FILESDIR}"/${PN}-1.1.2-install.patch
sed -i Makeconf \
-e "s:gfortran:$(tc-getFC):g" \
-e "s:FFLAGS=.*:FFLAGS=${FFLAGS}:" \
- -e "s:BLAS=.*:BLAS=$(pkg-config --libs blas):" \
- -e "s:LAPACK=.*:LAPACK=$(pkg-config --libs lapack):" \
+ -e "s:BLAS=.*:BLAS=$($(tc-getPKG_CONFIG) --libs blas):" \
+ -e "s:LAPACK=.*:LAPACK=$($(tc-getPKG_CONFIG) --libs lapack):" \
-e "/^LIBDIR=/a\PREFIX=${EPREFIX}/usr" \
-e "s:LIBDIR=lib:LIBDIR=$(get_libdir):" \
|| die "Failed to set up Makeconf"