summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-02-24 23:36:07 +0000
committerChristoph Junghans <ottxor@gentoo.org>2014-02-24 23:36:07 +0000
commit04a903cb7e28627c67542708c28fafa1a017abd5 (patch)
tree1069be58bfc65ba0066e42d2231c28090ba4faa2 /sci-libs/voro++
parentLinux patch 3.4.82 (diff)
downloadgentoo-2-04a903cb7e28627c67542708c28fafa1a017abd5.tar.gz
gentoo-2-04a903cb7e28627c67542708c28fafa1a017abd5.tar.bz2
gentoo-2-04a903cb7e28627c67542708c28fafa1a017abd5.zip
initial commit
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'sci-libs/voro++')
-rw-r--r--sci-libs/voro++/ChangeLog9
-rw-r--r--sci-libs/voro++/Manifest4
-rw-r--r--sci-libs/voro++/files/voro++-0.4.6-cmake.patch141
-rw-r--r--sci-libs/voro++/metadata.xml5
-rw-r--r--sci-libs/voro++/voro++-0.4.6.ebuild21
5 files changed, 180 insertions, 0 deletions
diff --git a/sci-libs/voro++/ChangeLog b/sci-libs/voro++/ChangeLog
new file mode 100644
index 000000000000..6781801bbcc7
--- /dev/null
+++ b/sci-libs/voro++/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sci-libs/voro++
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/voro++/ChangeLog,v 1.1 2014/02/24 23:36:07 ottxor Exp $
+
+*voro++-0.4.6 (24 Feb 2014)
+
+ 24 Feb 2014; Christoph Junghans <ottxor@gentoo.org>
+ +files/voro++-0.4.6-cmake.patch, +metadata.xml, +voro++-0.4.6.ebuild:
+ initial commit
diff --git a/sci-libs/voro++/Manifest b/sci-libs/voro++/Manifest
new file mode 100644
index 000000000000..e5067b07b53f
--- /dev/null
+++ b/sci-libs/voro++/Manifest
@@ -0,0 +1,4 @@
+AUX voro++-0.4.6-cmake.patch 5801 SHA256 50561000e3b294a668c97ac52cd29fd6f4f8bd26c70c7f87c9eb54ac831103c4 SHA512 c85ec6db83413b53be79233dd26ec2eab2c96ac07bffaa53b138b2a79a2c071ede8842ab5a5c7746accc19f1c20a3f7231255ea446971f9b3c27b20ce1d2ea4f WHIRLPOOL 27e2ebaf4ad26f95335d1266d408f127a1390a1790fd31664e09b5741528e708b0968fa9873dfeeae6a6eb64a7eedfedbde8bee8ef0f6dccd2646583b6dd8ad3
+DIST voro++-0.4.6.tar.gz 809124 SHA256 ef7970071ee2ce3800daa8723649ca069dc4c71cc25f0f7d22552387f3ea437e SHA512 aa8c73d7634bb4ec4c0a7d4d18c0df07511ef975338f2517e6f0ec65de56bac10397adccf1c0e13439d29d096b7cb9b4540d7cfc191a1662f15dc0c3c1ff77c1 WHIRLPOOL 120643681c2def042f8446b8da1fa674a4e94354e830f7867a92d3ecdcdf00ede8aacdf8a015717583fdfd3054abcb861cdd12c182a94756000828a514673c79
+EBUILD voro++-0.4.6.ebuild 410 SHA256 0859da414b979d960cbcd36d3e5844e7e7ea317b88b672ed342e032e892f2751 SHA512 84c54630e2c1803693f4379b7e64232f0779d9fc88e755a5d66a04c92e611b8b8b50209536f2a26f2c0a5699eb29b8c84ad1a6c6c35c377ed19057998458aa20 WHIRLPOOL 7c3a7e26d9865dbd64ac5056f699af45c113ea61efcd5d6c1eeb9c7c03199e907aea6ec76b1240107e7fdfd965e22d83ad4d7f248a0e21530787a50089ad6c64
+MISC metadata.xml 158 SHA256 dae7918daac89b300804812d32584889aa1c4e8b9edeced06006900494457a6d SHA512 e4901a5df84502b46aa85ec01804ce680332cebe6148e4a9c8201a38935ee0d4a753bcdb3f18765b06019926a05bf099c0ed61395aa98211610ab7fdb8d7f895 WHIRLPOOL 2f12466ef66cc7b89ec428cd4b498b20f12ca6dbb219f180ac12985dfc4195882ea95809797828a720fe69a0e560d12de9c271f8aacaa06fba09c9c1ccd589e5
diff --git a/sci-libs/voro++/files/voro++-0.4.6-cmake.patch b/sci-libs/voro++/files/voro++-0.4.6-cmake.patch
new file mode 100644
index 000000000000..da67328c6265
--- /dev/null
+++ b/sci-libs/voro++/files/voro++-0.4.6-cmake.patch
@@ -0,0 +1,141 @@
+Index: CMakeLists.txt
+===================================================================
+--- CMakeLists.txt (revision 0)
++++ CMakeLists.txt (working copy)
+@@ -0,0 +1,109 @@
++cmake_minimum_required(VERSION 2.6)
++
++project(voro++)
++
++set(PROJECT_VERSION "0.4.6")
++set(SOVERSION 0)
++
++# Cmake modules/macros are in a subdirectory to keep this file cleaner
++set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/CMakeModules)
++
++if(NOT CMAKE_BUILD_TYPE AND NOT CMAKE_CXX_FLAGS)
++ #release comes with -O3 by default
++ set(CMAKE_BUILD_TYPE Release CACHE STRING "Choose the type of build, options are: None Debug Release RelWithDebInfo MinSizeRel." FORCE)
++endif(NOT CMAKE_BUILD_TYPE AND NOT CMAKE_CXX_FLAGS)
++
++enable_language(CXX)
++
++######################################################################
++# compiler tests
++# these need ot be done early (before further tests).
++#####################################################################
++
++include(CheckCXXCompilerFlag)
++
++########################################################################
++# User input options #
++########################################################################
++option(BUILD_SHARED_LIBS "Build shared libs" ON)
++if (NOT DEFINED LIB)
++ set(LIB "lib")
++endif(NOT DEFINED LIB)
++if (NOT DEFINED MAN)
++ set(MAN "share/man")
++endif(NOT DEFINED MAN)
++if (NOT DEFINED DATA)
++ set(DATA "share/voro++")
++endif(NOT DEFINED DATA)
++
++########################################################################
++#Find external packages
++########################################################################
++find_package(Doxygen)
++
++########################################################################
++# Basic system tests (standard libraries, headers, functions, types) #
++########################################################################
++include(CheckIncludeFileCXX)
++foreach(HEADER cmath cstdio cstdlib cstring ctime fstream iostream queue vector)
++ check_include_file_cxx(${HEADER} FOUND_${HEADER})
++ if(NOT FOUND_${HEADER})
++ message(FATAL_ERROR "Could not find needed header - ${HEADER}")
++ endif(NOT FOUND_${HEADER})
++endforeach(HEADER)
++
++set(MATH_LIBRARIES "m" CACHE STRING "math library")
++mark_as_advanced( MATH_LIBRARIES )
++include(CheckLibraryExists)
++foreach(FUNC sqrt)
++ check_library_exists(${MATH_LIBRARIES} ${FUNC} "" FOUND_${FUNC}_${MATH_LIBRARIES})
++ if(NOT FOUND_${FUNC}_${MATH_LIBRARIES})
++ message(FATAL_ERROR "Could not find needed math function - ${FUNC}")
++ endif(NOT FOUND_${FUNC}_${MATH_LIBRARIES})
++endforeach(FUNC)
++
++######################################
++# Include the following subdirectory #
++######################################
++
++file(GLOB VORO_SOURCES src/*.cc)
++file(GLOB NOT_VORO_SOURCES src/v_base_wl.cc src/cmd_line.cc src/voro++.cc)
++list(REMOVE_ITEM VORO_SOURCES ${NOT_VORO_SOURCES})
++add_library(voro++ ${VORO_SOURCES})
++set_target_properties(voro++ PROPERTIES
++ LIBRARY_OUTPUT_DIRECTORY "${CMAKE_BINARY_DIR}/src"
++ SOVERSION ${SOVERSION})
++install(TARGETS voro++ LIBRARY DESTINATION ${LIB} ARCHIVE DESTINATION ${LIB})
++
++add_executable(cmd_line src/cmd_line.cc)
++target_link_libraries(cmd_line voro++)
++#cannot have two target with the same name
++set_target_properties(cmd_line PROPERTIES OUTPUT_NAME voro++
++ RUNTIME_OUTPUT_DIRECTORY "${CMAKE_BINARY_DIR}/src")
++install(TARGETS cmd_line RUNTIME DESTINATION bin)
++
++#for voto++.hh
++include_directories(${CMAKE_SOURCE_DIR}/src)
++file(GLOB EXAMPLE_SOURCES examples/*/*.cc)
++foreach(SOURCE ${EXAMPLE_SOURCES})
++ string(REGEX REPLACE "^.*/([^/]*)\\.cc$" "\\1" PROGNAME "${SOURCE}")
++ if (NOT PROGNAME STREQUAL ellipsoid) #ellipsoid is broken
++ string(REGEX REPLACE "^.*/(examples/.*)/${PROGNAME}\\.cc$" "\\1" DIRNAME "${SOURCE}")
++ add_executable(${PROGNAME} ${SOURCE})
++ target_link_libraries(${PROGNAME} voro++)
++ set_target_properties(${PROGNAME} PROPERTIES
++ RUNTIME_OUTPUT_DIRECTORY "${CMAKE_BINARY_DIR}/${DIRNAME}" )
++ endif()
++endforeach(SOURCE)
++
++file(GLOB_RECURSE VORO_HEADERS src/voro++.hh)
++install(FILES ${VORO_HEADERS} DESTINATION include)
++install(FILES ${CMAKE_SOURCE_DIR}/man/voro++.1 DESTINATION ${MAN}/man1)
++
++if (DOXYGEN_FOUND)
++ add_custom_target(help COMMAND ${DOXYGEN_EXECUTABLE} src/Doxyfile
++ COMMENT "Build doxygen documentation")
++endif (DOXYGEN_FOUND)
++
++configure_file(${CMAKE_MODULE_PATH}/cmake_uninstall.cmake.in ${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake IMMEDIATE @ONLY)
++add_custom_target(uninstall COMMAND ${CMAKE_COMMAND} -P ${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake)
+Index: CMakeModules/cmake_uninstall.cmake.in
+===================================================================
+--- CMakeModules/cmake_uninstall.cmake.in (revision 0)
++++ CMakeModules/cmake_uninstall.cmake.in (working copy)
+@@ -0,0 +1,22 @@
++IF(NOT EXISTS "@CMAKE_CURRENT_BINARY_DIR@/install_manifest.txt")
++ MESSAGE(FATAL_ERROR "Cannot find install manifest: \"@CMAKE_CURRENT_BINARY_DIR@/install_manifest.txt\"")
++ENDIF(NOT EXISTS "@CMAKE_CURRENT_BINARY_DIR@/install_manifest.txt")
++
++FILE(READ "@CMAKE_CURRENT_BINARY_DIR@/install_manifest.txt" files)
++STRING(REGEX REPLACE "\n" ";" files "${files}")
++FOREACH(file ${files})
++ MESSAGE(STATUS "Uninstalling \"$ENV{DESTDIR}${file}\"")
++ IF(EXISTS "$ENV{DESTDIR}${file}")
++ EXEC_PROGRAM(
++ "@CMAKE_COMMAND@" ARGS "-E remove \"$ENV{DESTDIR}${file}\""
++ OUTPUT_VARIABLE rm_out
++ RETURN_VALUE rm_retval
++ )
++ IF(NOT "${rm_retval}" STREQUAL 0)
++ MESSAGE(FATAL_ERROR "Problem when removing \"$ENV{DESTDIR}${file}\"")
++ ENDIF(NOT "${rm_retval}" STREQUAL 0)
++ ELSE(EXISTS "$ENV{DESTDIR}${file}")
++ MESSAGE(STATUS "File \"$ENV{DESTDIR}${file}\" does not exist.")
++ ENDIF(EXISTS "$ENV{DESTDIR}${file}")
++ENDFOREACH(file)
++
diff --git a/sci-libs/voro++/metadata.xml b/sci-libs/voro++/metadata.xml
new file mode 100644
index 000000000000..897aa2e6b59a
--- /dev/null
+++ b/sci-libs/voro++/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+</pkgmetadata>
diff --git a/sci-libs/voro++/voro++-0.4.6.ebuild b/sci-libs/voro++/voro++-0.4.6.ebuild
new file mode 100644
index 000000000000..985fb3cfb575
--- /dev/null
+++ b/sci-libs/voro++/voro++-0.4.6.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/voro++/voro++-0.4.6.ebuild,v 1.1 2014/02/24 23:36:07 ottxor Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="A 3D Voronoi cell software library"
+HOMEPAGE="http://math.lbl.gov/voro++/"
+SRC_URI="${HOMEPAGE}/download/dir/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" )