summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2013-01-27 04:03:19 +0000
committerChristoph Junghans <ottxor@gentoo.org>2013-01-27 04:03:19 +0000
commit237b6daa8e7671e97e8f104f11d244451be9f839 (patch)
tree82052cfc86ac2218afff153b807243055924ecac /sci-libs/votca-tools
parentUnmask eudev on hardened/linux/uclibc/mips (diff)
downloadgentoo-2-237b6daa8e7671e97e8f104f11d244451be9f839.tar.gz
gentoo-2-237b6daa8e7671e97e8f104f11d244451be9f839.tar.bz2
gentoo-2-237b6daa8e7671e97e8f104f11d244451be9f839.zip
fix build with boost-1.53 (bug #454104)
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'sci-libs/votca-tools')
-rw-r--r--sci-libs/votca-tools/ChangeLog11
-rw-r--r--sci-libs/votca-tools/files/votca-tools-1.2.3-boost-1.53.patch24
-rw-r--r--sci-libs/votca-tools/votca-tools-1.2.3-r1.ebuild (renamed from sci-libs/votca-tools/votca-tools-1.2.3.ebuild)10
3 files changed, 39 insertions, 6 deletions
diff --git a/sci-libs/votca-tools/ChangeLog b/sci-libs/votca-tools/ChangeLog
index 4c1360d74d49..c3f996278d4e 100644
--- a/sci-libs/votca-tools/ChangeLog
+++ b/sci-libs/votca-tools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/votca-tools
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/votca-tools/ChangeLog,v 1.19 2012/12/26 23:22:22 ottxor Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/votca-tools/ChangeLog,v 1.20 2013/01/27 04:03:19 ottxor Exp $
+
+*votca-tools-1.2.3-r1 (27 Jan 2013)
+
+ 27 Jan 2013; Christoph Junghans <ottxor@gentoo.org>
+ +files/votca-tools-1.2.3-boost-1.53.patch, +votca-tools-1.2.3-r1.ebuild,
+ -votca-tools-1.2.3.ebuild:
+ fix build with boost-1.53 (bug #454104)
26 Dec 2012; Christoph Junghans <ottxor@gentoo.org> votca-tools-1.2.2.ebuild,
votca-tools-1.2.3.ebuild:
diff --git a/sci-libs/votca-tools/files/votca-tools-1.2.3-boost-1.53.patch b/sci-libs/votca-tools/files/votca-tools-1.2.3-boost-1.53.patch
new file mode 100644
index 000000000000..4aa7adbf5641
--- /dev/null
+++ b/sci-libs/votca-tools/files/votca-tools-1.2.3-boost-1.53.patch
@@ -0,0 +1,24 @@
+# HG changeset patch
+# User Victor Ruehle <ruehle@votca.org>
+# Date 1359258783 25200
+# Branch stable
+# Node ID f26d7ee778d666babe7f58ae3770b4f3d997aa99
+# Parent d10dec78492a78ad6709e686416615fc8b43c896
+fix build with boost-1.53 (fixes issue 131)
+
+diff -r d10dec78492a -r f26d7ee778d6 include/votca/tools/tokenizer.h
+--- a/include/votca/tools/tokenizer.h Sun Dec 02 21:09:27 2012 -0700
++++ b/include/votca/tools/tokenizer.h Sat Jan 26 20:53:03 2013 -0700
+@@ -93,8 +93,10 @@
+ std::vector<std::string> tmp;
+ ToVector(tmp);
+ v.resize(tmp.size());
+- transform(tmp.begin(), tmp.end(), v.begin(),
+- boost::lexical_cast<T, std::string>);
++ typename std::vector<T>::iterator viter = v.begin();
++ typename std::vector<std::string>::iterator iter;
++ for(iter = tmp.begin(); iter!=tmp.end(); ++iter, ++viter)
++ *viter = boost::lexical_cast<T, std::string>(*iter);
+ }
+
+ private:
diff --git a/sci-libs/votca-tools/votca-tools-1.2.3.ebuild b/sci-libs/votca-tools/votca-tools-1.2.3-r1.ebuild
index 550d5b85f2f4..4677a238af8c 100644
--- a/sci-libs/votca-tools/votca-tools-1.2.3.ebuild
+++ b/sci-libs/votca-tools/votca-tools-1.2.3-r1.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/votca-tools/votca-tools-1.2.3.ebuild,v 1.2 2012/12/26 23:22:22 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/votca-tools/votca-tools-1.2.3-r1.ebuild,v 1.1 2013/01/27 04:03:19 ottxor Exp $
EAPI="3"
inherit cmake-utils eutils multilib
if [ "${PV}" != "9999" ]; then
- SRC_URI="system-boost? ( http://votca.googlecode.com/files/${PF}_pristine.tar.gz )
- !system-boost? ( http://votca.googlecode.com/files/${PF}.tar.gz )"
+ SRC_URI="system-boost? ( http://votca.googlecode.com/files/${P}_pristine.tar.gz )
+ !system-boost? ( http://votca.googlecode.com/files/${P}.tar.gz )"
RESTRICT="primaryuri"
else
SRC_URI=""
@@ -37,6 +37,8 @@ DEPEND="${RDEPEND}
DOCS=( NOTICE )
+PATCHES=( "${FILESDIR}/${P}-boost-1.53.patch" )
+
src_prepare() {
use gsl || ewarn "Disabling gsl will lead to reduced functionality"
use fftw || ewarn "Disabling fftw will lead to reduced functionality"