summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-08-17 03:13:10 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-08-17 03:13:10 +0000
commit53261ff93a46c347ff42a6299cdf64b4c2d96855 (patch)
treef06dca12ab79aeb946aef9a6f89ddd2be14ed20f /sci-libs/votca-tools
parentSecurity bump (bug #431432). (diff)
downloadgentoo-2-53261ff93a46c347ff42a6299cdf64b4c2d96855.tar.gz
gentoo-2-53261ff93a46c347ff42a6299cdf64b4c2d96855.tar.bz2
gentoo-2-53261ff93a46c347ff42a6299cdf64b4c2d96855.zip
version bump
(Portage version: 2.2.0_alpha121/cvs/Linux i686)
Diffstat (limited to 'sci-libs/votca-tools')
-rw-r--r--sci-libs/votca-tools/ChangeLog8
-rw-r--r--sci-libs/votca-tools/votca-tools-1.2.3.ebuild72
2 files changed, 78 insertions, 2 deletions
diff --git a/sci-libs/votca-tools/ChangeLog b/sci-libs/votca-tools/ChangeLog
index e67dd80acba8..324166deb16b 100644
--- a/sci-libs/votca-tools/ChangeLog
+++ b/sci-libs/votca-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/votca-tools
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/votca-tools/ChangeLog,v 1.16 2012/05/04 08:22:49 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/votca-tools/ChangeLog,v 1.17 2012/08/17 03:13:10 ottxor Exp $
+
+*votca-tools-1.2.3 (17 Aug 2012)
+
+ 17 Aug 2012; Christoph Junghans <ottxor@gentoo.org> +votca-tools-1.2.3.ebuild:
+ version bump
04 May 2012; Jeff Horelick <jdhore@gentoo.org> votca-tools-1.2.2.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
@@ -68,4 +73,3 @@
12 Feb 2011; Christoph Junghans <ottxor@gentoo.org>
+votca-tools-1.0.1.ebuild, +metadata.xml:
Initial commit (bug #296707)
-
diff --git a/sci-libs/votca-tools/votca-tools-1.2.3.ebuild b/sci-libs/votca-tools/votca-tools-1.2.3.ebuild
new file mode 100644
index 000000000000..012ae5dca677
--- /dev/null
+++ b/sci-libs/votca-tools/votca-tools-1.2.3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/votca-tools/votca-tools-1.2.3.ebuild,v 1.1 2012/08/17 03:13:10 ottxor Exp $
+
+EAPI="3"
+
+inherit cmake-utils eutils multilib
+
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="system-boost? ( http://votca.googlecode.com/files/${PF}_pristine.tar.gz )
+ !system-boost? ( http://votca.googlecode.com/files/${PF}.tar.gz )"
+ RESTRICT="primaryuri"
+else
+ SRC_URI=""
+ inherit mercurial
+ EHG_REPO_URI="https://tools.votca.googlecode.com/hg"
+ EHG_REVISION="default"
+ S="${WORKDIR}/${EHG_REPO_URI##*/}"
+fi
+
+DESCRIPTION="Votca tools library"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+IUSE="doc +fftw +gsl sqlite +system-boost"
+
+RDEPEND="fftw? ( sci-libs/fftw:3.0 )
+ dev-libs/expat
+ gsl? ( sci-libs/gsl )
+ system-boost? ( dev-libs/boost )
+ sqlite? ( dev-db/sqlite:3 )"
+
+DEPEND="${RDEPEND}
+ doc? ( || ( <app-doc/doxygen-1.7.6.1[-nodot] >=app-doc/doxygen-1.7.6.1[dot] ) )
+ >=app-text/txt2tags-2.5
+ virtual/pkgconfig"
+
+DOCS=( NOTICE )
+
+src_prepare() {
+ use gsl || ewarn "Disabling gsl will lead to reduced functionality"
+ use fftw || ewarn "Disabling fftw will lead to reduced functionality"
+
+ #remove bundled libs
+ if use system-boost; then
+ rm -rf src/libboost
+ fi
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use system-boost EXTERNAL_BOOST)
+ $(cmake-utils_use_with gsl GSL)
+ $(cmake-utils_use_with fftw FFTW)
+ $(cmake-utils_use_with sqlite SQLITE3)
+ -DWITH_RC_FILES=OFF
+ -DLIB=$(get_libdir)
+ )
+ cmake-utils_src_configure || die
+}
+
+src_install() {
+ cmake-utils_src_install || die
+ if use doc; then
+ cd "${CMAKE_BUILD_DIR}" || die
+ cd share/doc || die
+ doxygen || die
+ dohtml -r html/* || die
+ fi
+}