summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-02-22 13:35:13 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-02-22 13:35:13 +0000
commitc18a23c3afe6c513513e3032cbeede8180f5b77d (patch)
tree7c1c4785d4a71a59b36830375ffed88afd657f6c /sci-libs/vtk
parentMove desktop-file-utils to PDEPEND because of dependency cycle, bug 208043. (diff)
downloadgentoo-2-c18a23c3afe6c513513e3032cbeede8180f5b77d.tar.gz
gentoo-2-c18a23c3afe6c513513e3032cbeede8180f5b77d.tar.bz2
gentoo-2-c18a23c3afe6c513513e3032cbeede8180f5b77d.zip
Removed support for mpich and added support for mpich2, openmpi, and lam-mpi. Also fixed some QA issues and added qt4 eclass.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-libs/vtk')
-rw-r--r--sci-libs/vtk/ChangeLog10
-rw-r--r--sci-libs/vtk/files/vtk-5.0.1-python2.5-gentoo.patch12
-rw-r--r--sci-libs/vtk/files/vtk-5.0.3-lammpi.patch45
-rw-r--r--sci-libs/vtk/files/vtk-5.0.3-mpi.patch74
-rw-r--r--sci-libs/vtk/vtk-5.0.3.ebuild51
5 files changed, 115 insertions, 77 deletions
diff --git a/sci-libs/vtk/ChangeLog b/sci-libs/vtk/ChangeLog
index 37b031d9da5c..2a24070a1078 100644
--- a/sci-libs/vtk/ChangeLog
+++ b/sci-libs/vtk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/vtk
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.39 2007/08/19 03:50:36 markusle Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.40 2008/02/22 13:35:13 markusle Exp $
+
+ 21 Feb 2008; Markus Dittrich <markusle@gentoo.org>
+ -files/vtk-5.0.1-python2.5-gentoo.patch, -files/vtk-5.0.3-lammpi.patch,
+ +files/vtk-5.0.3-mpi.patch, vtk-5.0.3.ebuild:
+ Removed support for mpich and added support for mpich2, openmpi, and
+ lam-mpi. Also fixed some QA issues and added qt4 eclass.
19 Aug 2007; Markus Dittrich <markusle@gentoo.org> vtk-5.0.3.ebuild:
Fixed incomplete RDEPEND.
diff --git a/sci-libs/vtk/files/vtk-5.0.1-python2.5-gentoo.patch b/sci-libs/vtk/files/vtk-5.0.1-python2.5-gentoo.patch
deleted file mode 100644
index c1abcd7254ad..000000000000
--- a/sci-libs/vtk/files/vtk-5.0.1-python2.5-gentoo.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur VTK/Common/vtkPythonUtil.cxx VTK-new/Common/vtkPythonUtil.cxx
---- VTK/Common/vtkPythonUtil.cxx 2005-08-04 12:19:14.000000000 -0400
-+++ VTK-new/Common/vtkPythonUtil.cxx 2006-09-23 11:16:06.000000000 -0400
-@@ -768,7 +768,7 @@
- }
- if (strcmp(name, "__doc__") == 0)
- {
-- char *doc = t->tp_doc;
-+ const char *doc = t->tp_doc;
- if (doc != NULL)
- {
- return PyString_FromString(doc);
diff --git a/sci-libs/vtk/files/vtk-5.0.3-lammpi.patch b/sci-libs/vtk/files/vtk-5.0.3-lammpi.patch
deleted file mode 100644
index 4493667cf7db..000000000000
--- a/sci-libs/vtk/files/vtk-5.0.3-lammpi.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-diff -Naur VTK/Parallel/CMakeLists.txt VTK-new/Parallel/CMakeLists.txt
---- VTK/Parallel/CMakeLists.txt 2007-03-28 16:38:46.000000000 -0400
-+++ VTK-new/Parallel/CMakeLists.txt 2007-05-06 08:46:55.000000000 -0400
-@@ -78,6 +78,7 @@
-
- IF (VTK_USE_MPI)
- INCLUDE (${CMAKE_ROOT}/Modules/FindMPI.cmake)
-+ INCLUDE(${VTK_SOURCE_DIR}/Parallel/FindLAMMPI.cmake)
- SET ( Kit_SRCS
- ${Kit_SRCS}
- vtkMPICommunicator.cxx
-@@ -94,6 +95,12 @@
- IF (MPI_EXTRA_LIBRARY)
- SET(KIT_LIBS ${KIT_LIBS} "${MPI_EXTRA_LIBRARY}")
- ENDIF (MPI_EXTRA_LIBRARY)
-+ IF (LAMMPI_LIBRARY)
-+ SET(KIT_LIBS ${KIT_LIBS} "${LAMMPI_LIBRARY}")
-+ ENDIF (LAMMPI_LIBRARY)
-+ IF (LAMMPI_EXTRA_LIBRARY)
-+ SET(KIT_LIBS ${KIT_LIBS} "${LAMMPI_EXTRA_LIBRARY}")
-+ ENDIF (LAMMPI_EXTRA_LIBRARY)
- ENDIF (VTK_USE_MPI)
-
- SET(Kit_EXTRA_SRCS)
-diff -Naur VTK/Parallel/FindLAMMPI.cmake VTK-new/Parallel/FindLAMMPI.cmake
---- VTK/Parallel/FindLAMMPI.cmake 1969-12-31 19:00:00.000000000 -0500
-+++ VTK-new/Parallel/FindLAMMPI.cmake 2007-05-06 18:30:22.000000000 -0400
-@@ -0,0 +1,17 @@
-+# - Find LamMPI
-+FIND_LIBRARY(LAMMPI_LIBRARY
-+ NAMES lam
-+ PATHS /usr/lib /usr/lib64
-+ "$ENV{ProgramFiles}/MPICH/SDK/Lib"
-+ "$ENV{ProgramFiles}/MPICH2/Lib"
-+ "C:/Program Files/MPICH/SDK/Lib"
-+)
-+
-+FIND_LIBRARY(LAMMPI_EXTRA_LIBRARY
-+ NAMES lammpi++
-+ PATHS /usr/lib /usr/lib64
-+ "$ENV{ProgramFiles}/MPICH/SDK/Lib"
-+ "C:/Program Files/MPICH/SDK/Lib"
-+ DOC "If a second mpi library is necessary, specify it here.")
-+
-+MARK_AS_ADVANCED(LAMMPI_LIBRARY LAMMPI_EXTRA_LIBRARY)
diff --git a/sci-libs/vtk/files/vtk-5.0.3-mpi.patch b/sci-libs/vtk/files/vtk-5.0.3-mpi.patch
new file mode 100644
index 000000000000..fec1d67bd0aa
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-5.0.3-mpi.patch
@@ -0,0 +1,74 @@
+diff -Naur VTK/Parallel/CMakeLists.txt VTK.new/Parallel/CMakeLists.txt
+--- VTK/Parallel/CMakeLists.txt 2007-03-28 15:38:46.000000000 -0500
++++ VTK.new/Parallel/CMakeLists.txt 2008-02-21 15:16:04.000000000 -0500
+@@ -78,6 +78,8 @@
+
+ IF (VTK_USE_MPI)
+ INCLUDE (${CMAKE_ROOT}/Modules/FindMPI.cmake)
++ INCLUDE(${VTK_SOURCE_DIR}/Parallel/FindLAMMPI.cmake)
++ INCLUDE(${VTK_SOURCE_DIR}/Parallel/FindOpenmpi.cmake)
+ SET ( Kit_SRCS
+ ${Kit_SRCS}
+ vtkMPICommunicator.cxx
+@@ -94,6 +96,18 @@
+ IF (MPI_EXTRA_LIBRARY)
+ SET(KIT_LIBS ${KIT_LIBS} "${MPI_EXTRA_LIBRARY}")
+ ENDIF (MPI_EXTRA_LIBRARY)
++ IF (LAMMPI_LIBRARY)
++ SET(KIT_LIBS ${KIT_LIBS} "${LAMMPI_LIBRARY}")
++ ENDIF (LAMMPI_LIBRARY)
++ IF (LAMMPI_EXTRA_LIBRARY)
++ SET(KIT_LIBS ${KIT_LIBS} "${LAMMPI_EXTRA_LIBRARY}")
++ ENDIF (LAMMPI_EXTRA_LIBRARY)
++ IF (OPENMPI_LIBRARY)
++ SET(KIT_LIBS ${KIT_LIBS} "${OPENMPI_LIBRARY}")
++ ENDIF (OPENMPI_LIBRARY)
++ IF (OPENMPI_EXTRA_LIBRARY)
++ SET(KIT_LIBS ${KIT_LIBS} "${OPENMPI_EXTRA_LIBRARY}")
++ ENDIF (OPENMPI_EXTRA_LIBRARY)
+ ENDIF (VTK_USE_MPI)
+
+ SET(Kit_EXTRA_SRCS)
+diff -Naur VTK/Parallel/FindLAMMPI.cmake VTK.new/Parallel/FindLAMMPI.cmake
+--- VTK/Parallel/FindLAMMPI.cmake 1969-12-31 19:00:00.000000000 -0500
++++ VTK.new/Parallel/FindLAMMPI.cmake 2008-02-21 15:13:38.000000000 -0500
+@@ -0,0 +1,17 @@
++# - Find LamMPI
++FIND_LIBRARY(LAMMPI_LIBRARY
++ NAMES lam
++ PATHS /usr/lib /usr/lib64
++ "$ENV{ProgramFiles}/MPICH/SDK/Lib"
++ "$ENV{ProgramFiles}/MPICH2/Lib"
++ "C:/Program Files/MPICH/SDK/Lib"
++)
++
++FIND_LIBRARY(LAMMPI_EXTRA_LIBRARY
++ NAMES lammpi++
++ PATHS /usr/lib /usr/lib64
++ "$ENV{ProgramFiles}/MPICH/SDK/Lib"
++ "C:/Program Files/MPICH/SDK/Lib"
++ DOC "If a second mpi library is necessary, specify it here.")
++
++MARK_AS_ADVANCED(LAMMPI_LIBRARY LAMMPI_EXTRA_LIBRARY)
+diff -Naur VTK/Parallel/FindOpenmpi.cmake VTK.new/Parallel/FindOpenmpi.cmake
+--- VTK/Parallel/FindOpenmpi.cmake 1969-12-31 19:00:00.000000000 -0500
++++ VTK.new/Parallel/FindOpenmpi.cmake 2008-02-21 15:14:23.000000000 -0500
+@@ -0,0 +1,18 @@
++# - Find openmpi
++FIND_PATH(MPI_INCLUDE_PATH mpi.h
++ /usr/include
++ /usr/include/openmpi
++)
++
++FIND_LIBRARY(OPENMPI_LIBRARY
++ NAMES mpi
++ PATHS /usr/lib /usr/lib64
++)
++
++FIND_LIBRARY(OPENMPI_EXTRA_LIBRARY
++ NAMES mpi_cxx
++ PATHS /usr/lib /usr/lib64
++ DOC "If a second mpi library is necessary, specify it here.")
++
++MARK_AS_ADVANCED(OPENMPI_LIBRARY OPENMPI_EXTRA_LIBRARY)
++
diff --git a/sci-libs/vtk/vtk-5.0.3.ebuild b/sci-libs/vtk/vtk-5.0.3.ebuild
index fdb8d390ec51..59cba0fd37bb 100644
--- a/sci-libs/vtk/vtk-5.0.3.ebuild
+++ b/sci-libs/vtk/vtk-5.0.3.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.0.3.ebuild,v 1.10 2007/08/19 03:50:36 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.0.3.ebuild,v 1.11 2008/02/22 13:35:13 markusle Exp $
-inherit distutils eutils flag-o-matic toolchain-funcs versionator java-pkg-opt-2 python qt3
+EAPI="1"
+
+inherit distutils eutils flag-o-matic toolchain-funcs versionator java-pkg-opt-2 python qt3 qt4
# Short package version
SPV="$(get_version_component_range 1-2)"
@@ -16,13 +18,16 @@ LICENSE="BSD LGPL-2"
KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE="doc examples mpi patented python tcl tk threads qt3 qt4"
-RDEPEND="mpi? ( virtual/mpi )
+RDEPEND="mpi? ( || (
+ sys-cluster/openmpi
+ sys-cluster/lam-mpi
+ sys-cluster/mpich2 ) )
python? ( >=dev-lang/python-2.0 )
tcl? ( >=dev-lang/tcl-8.2.3 )
tk? ( >=dev-lang/tk-8.2.3 )
java? ( >=virtual/jre-1.5 )
qt3? ( $(qt_min_version 3.3.4) )
- qt4? ( >=x11-libs/qt-4.1.0 )
+ qt4? ( $(qt4_min_version 4.1) )
dev-libs/expat
media-libs/freetype
media-libs/jpeg
@@ -53,12 +58,21 @@ pkg_setup() {
eerror 'build the examples under qt4!'
die "qt4 setup error"
fi
+
+ if use mpi && has_version sys-cluster/mpich2; then
+ append-flags -DMPICH_IGNORE_CXX_SEEK
+ if ! built_with_use sys-cluster/mpich2 cxx; then
+ die "Please re-emerge sys-cluster/mpich2 with USE=\"cxx\""
+ fi
+ fi
+
+ use qt4 && qt4_pkg_setup
}
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${P}-lammpi.patch
+ epatch "${FILESDIR}"/${P}-mpi.patch
}
src_compile() {
@@ -73,13 +87,14 @@ src_compile() {
# Fix Examples cmake file
sed -e "s/MAKEPROGRAM/CMAKE_MAKE_PROGRAM/g" \
- -i ${S}/Examples/CMakeLists.txt || \
+ -i "${S}"/Examples/CMakeLists.txt || \
die "Failed to fix examples CMakeList.txt"
# build list of config variable define's to pass to cmake
local CMAKE_VARIABLES=""
CMAKE_VARIABLES="${CMAKE_VARIABLES} -DCMAKE_SKIP_RPATH:BOOL=YES"
CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_DIR:PATH=${S}"
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_INSTALL_LIB_DIR:PATH=/usr/$(get_libdir)/"
CMAKE_VARIABLES="${CMAKE_VARIABLES} -DCMAKE_INSTALL_PREFIX:PATH=/usr"
CMAKE_VARIABLES="${CMAKE_VARIABLES} -DBUILD_SHARED_LIBS:BOOL=ON"
CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_USE_FREETYPE:BOOL=ON"
@@ -182,7 +197,7 @@ src_install() {
-i "${S}"/Utilities/InstallOnly/*.cmake || \
die "Failed to fix cmake files"
- make DESTDIR=${D} install || die "make install failed"
+ make DESTDIR="${D}" install || die "make install failed"
# install docs
dohtml "${S}"/README.html || die "Failed to install docs"
@@ -206,34 +221,34 @@ src_install() {
if use examples; then
dodir /usr/share/${PN} || \
die "Failed to create examples directory"
- cp -pPR ${S}/Examples ${D}/usr/share/${PN}/examples || \
+ cp -pPR "${S}"/Examples "${D}"/usr/share/${PN}/examples || \
die "Failed to copy example files"
# fix example's permissions
- find ${D}/usr/share/${PN}/examples -type d -exec \
+ find "${D}"/usr/share/${PN}/examples -type d -exec \
chmod 0755 {} \; || \
die "Failed to fix example directories permissions"
- find ${D}/usr/share/${PN}/examples -type f -exec \
+ find "${D}"/usr/share/${PN}/examples -type f -exec \
chmod 0644 {} \; || \
die "Failed to fix example files permissions"
- cp -pPR ${WORKDIR}/VTKData ${D}/usr/share/${PN}/data || \
+ cp -pPR "${WORKDIR}"/VTKData "${D}"/usr/share/${PN}/data || \
die "Failed to copy data files"
# fix data's permissions
- find ${D}/usr/share/${PN}/data -type d -exec \
+ find "${D}"/usr/share/${PN}/data -type d -exec \
chmod 0755 {} \; || \
die "Failed to fix data directories permissions"
- find ${D}/usr/share/${PN}/data -type f -exec \
+ find "${D}"/usr/share/${PN}/data -type f -exec \
chmod 0644 {} \; || \
die "Failed to fix data files permissions"
fi
# environment
- echo "VTK_DATA_ROOT=/usr/share/${PN}/data" >> ${T}/40${PN}
- echo "VTK_DIR=/usr/lib/${PN}-${SPV}" >> ${T}/40${PN}
- echo "VTKHOME=/usr" >> ${T}/40${PN}
- doenvd ${T}/40${PN}
+ echo "VTK_DATA_ROOT=/usr/share/${PN}/data" >> "${T}"/40${PN}
+ echo "VTK_DIR=/usr/lib/${PN}-${SPV}" >> "${T}"/40${PN}
+ echo "VTKHOME=/usr" >> "${T}"/40${PN}
+ doenvd "${T}"/40${PN}
}
pkg_postinst() {