summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-05-09 09:56:23 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-05-09 09:56:23 +0000
commitc28c3d4a118905bb3eea7359511e1d7a2fcaf1ff (patch)
treee80937366b476affa2f99aa0654b4f67e2d9d62e /sci-libs/vtk
parentStable on alpha wrt security bug #169372 (diff)
downloadgentoo-2-c28c3d4a118905bb3eea7359511e1d7a2fcaf1ff.tar.gz
gentoo-2-c28c3d4a118905bb3eea7359511e1d7a2fcaf1ff.tar.bz2
gentoo-2-c28c3d4a118905bb3eea7359511e1d7a2fcaf1ff.zip
Re-added compile flag for javac needed on amd64 (see bug #177506).
(Portage version: 2.1.2.5)
Diffstat (limited to 'sci-libs/vtk')
-rw-r--r--sci-libs/vtk/ChangeLog5
-rw-r--r--sci-libs/vtk/vtk-5.0.3.ebuild13
2 files changed, 14 insertions, 4 deletions
diff --git a/sci-libs/vtk/ChangeLog b/sci-libs/vtk/ChangeLog
index 7e0df7fbacb8..271aa2deece2 100644
--- a/sci-libs/vtk/ChangeLog
+++ b/sci-libs/vtk/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/vtk
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.32 2007/05/07 12:38:32 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.33 2007/05/09 09:56:23 markusle Exp $
+
+ 08 May 2007; Markus Dittrich <markusle@gentoo.org> vtk-5.0.3.ebuild:
+ Re-added compile flag for javac needed on amd64 (see bug #177506).
06 May 2007; Markus Dittrich <markusle@gentoo.org>
+files/vtk-5.0.3-lammpi.patch, vtk-5.0.3.ebuild:
diff --git a/sci-libs/vtk/vtk-5.0.3.ebuild b/sci-libs/vtk/vtk-5.0.3.ebuild
index 3c9eb8a3526b..0d5ef665734d 100644
--- a/sci-libs/vtk/vtk-5.0.3.ebuild
+++ b/sci-libs/vtk/vtk-5.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.0.3.ebuild,v 1.4 2007/05/07 12:38:32 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.0.3.ebuild,v 1.5 2007/05/09 09:56:23 markusle Exp $
inherit distutils eutils flag-o-matic toolchain-funcs versionator java-pkg-opt-2 python qt3
@@ -16,8 +16,7 @@ LICENSE="BSD"
KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE="doc examples mpi patented python tcl tk threads qt3 qt4"
-RDEPEND="java? ( =virtual/jdk-1.5* )
- mpi? ( virtual/mpi )
+RDEPEND="mpi? ( virtual/mpi )
python? ( >=dev-lang/python-2.0 )
tcl? ( >=dev-lang/tcl-8.2.3 )
tk? ( >=dev-lang/tk-8.2.3 )
@@ -30,6 +29,7 @@ RDEPEND="java? ( =virtual/jdk-1.5* )
|| ( x11-libs/libXmu virtual/x11 )"
DEPEND="${RDEPEND}
+ java? ( >=virtual/jdk-1.5 )
>=dev-util/cmake-2.2.3
qt3? ( $(qt_min_version 3.3.4) )
qt4? ( >=x11-libs/qt-4.1.0 )"
@@ -165,6 +165,13 @@ src_compile() {
cmake ${CMAKE_VARIABLES} . && cmake ${CMAKE_VARIABLES} . \
|| die "cmake configuration failed"
+ # fix java.lang.OutOfMemoryError on amd64 (see bug #123178)
+ if use java && [ "${ARCH}" == "amd64" ]; then
+ sed -e "s/javac/javac -J-Xmx256m/" \
+ -i "${S}"/Wrapping/Java/CMakeFiles/VTKBuildAll.dir/build.make \
+ || die "Failed to patch javac"
+ fi
+
emake -j1 || die "emake failed"
}