summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2008-02-09 09:59:01 +0000
committerDenis Dupeyron <calchan@gentoo.org>2008-02-09 09:59:01 +0000
commit01cfbe2e8ff5250b16ffcd5b82cf3d643a4dac9e (patch)
tree5739ce80cb4c4334550066aa2b30de99f37a3cf0 /sci-libs
parentremove old (diff)
downloadgentoo-2-01cfbe2e8ff5250b16ffcd5b82cf3d643a4dac9e.tar.gz
gentoo-2-01cfbe2e8ff5250b16ffcd5b82cf3d643a4dac9e.tar.bz2
gentoo-2-01cfbe2e8ff5250b16ffcd5b82cf3d643a4dac9e.zip
Version bump, bug #204183.
(Portage version: 2.1.4.1)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libgeda/ChangeLog9
-rw-r--r--sci-libs/libgeda/libgeda-1.4.0.ebuild72
2 files changed, 79 insertions, 2 deletions
diff --git a/sci-libs/libgeda/ChangeLog b/sci-libs/libgeda/ChangeLog
index 3de736b18a22..2a93dc21edc2 100644
--- a/sci-libs/libgeda/ChangeLog
+++ b/sci-libs/libgeda/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/libgeda
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/ChangeLog,v 1.39 2007/09/19 11:44:03 calchan Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/ChangeLog,v 1.40 2008/02/09 09:59:01 calchan Exp $
+
+*libgeda-1.4.0 (09 Feb 2008)
+
+ 09 Feb 2008; Denis Dupeyron <calchan@gentoo.org> +libgeda-1.4.0.ebuild:
+ Version bump, bug #204183.
19 Sep 2007; Denis Dupeyron <calchan@gentoo.org> libgeda-1.1.1.ebuild:
Fixed guile dependency.
diff --git a/sci-libs/libgeda/libgeda-1.4.0.ebuild b/sci-libs/libgeda/libgeda-1.4.0.ebuild
new file mode 100644
index 000000000000..8f5e8b079c84
--- /dev/null
+++ b/sci-libs/libgeda/libgeda-1.4.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/libgeda-1.4.0.ebuild,v 1.1 2008/02/09 09:59:01 calchan Exp $
+
+inherit eutils fdo-mime versionator
+
+SUBDIR="v$(get_version_component_range 1-2)"
+
+HOMEPAGE="http://www.geda.seul.org"
+DESCRIPTION="libgeda - this library provides functions needed for the gEDA core suite"
+SRC_URI="http://www.geda.seul.org/release/${SUBDIR}/${PV}/libgeda-${PV}.tar.gz"
+
+IUSE="gd threads"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+SLOT="0"
+
+DEPEND=">=x11-libs/gtk+-2.4
+ >=dev-scheme/guile-1.6.3
+ >=dev-libs/libstroke-0.5.1
+ gd? ( >=media-libs/gd-2 )"
+
+pkg_setup() {
+ if has_version ">=dev-scheme/guile-1.8" ; then
+ built_with_use "dev-scheme/guile" deprecated \
+ || die "You need either <dev-scheme/guile-1.8, or >=dev-scheme/guile-1.8 with USE=deprecated"
+ fi
+ if use gd ; then
+ built_with_use media-libs/gd png || die "media-libs/gd must be compiled with USE=png"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # Skip the share sub-directory, we'll install prolog.ps manually
+ sed -i \
+ -e "s:SUBDIRS = src include scripts docs share:SUBDIRS = src include scripts docs:" \
+ "${S}"/Makefile.in \
+ || die "Patch failed"
+}
+
+src_compile() {
+ local myconf="--disable-threads"
+ use threads || myconf="--enable-threads=posix"
+ econf \
+ ${myconf} \
+ --disable-dependency-tracking \
+ --disable-rpath \
+ --disable-update-mime-database \
+ --with-x \
+ $(use_enable gd) \
+ || die "Configuration failed"
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ insinto /usr/share/gEDA
+ doins share/prolog.ps
+
+ dodoc AUTHORS BUGS ChangeLog README
+}
+
+src_postinst() {
+ fdo-mime_mime_database_update
+}
+
+src_postrm() {
+ fdo-mime_mime_database_update
+}