summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-10-23 16:03:46 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-10-23 16:03:46 +0000
commit0a7f28239585d71c7aedc15f8876d6721c414562 (patch)
treec08ada2b85dac1bba07e416b6f8821c98a73702f /sci-libs
parentrevbump; correction to sed statement to prevent double installation of doc da... (diff)
downloadgentoo-2-0a7f28239585d71c7aedc15f8876d6721c414562.tar.gz
gentoo-2-0a7f28239585d71c7aedc15f8876d6721c414562.tar.bz2
gentoo-2-0a7f28239585d71c7aedc15f8876d6721c414562.zip
initial import, ebuild by me
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libccd/ChangeLog11
-rw-r--r--sci-libs/libccd/libccd-2.0.ebuild60
-rw-r--r--sci-libs/libccd/libccd-9999.ebuild60
-rw-r--r--sci-libs/libccd/metadata.xml11
4 files changed, 142 insertions, 0 deletions
diff --git a/sci-libs/libccd/ChangeLog b/sci-libs/libccd/ChangeLog
new file mode 100644
index 000000000000..66fb2351acd7
--- /dev/null
+++ b/sci-libs/libccd/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-libs/libccd
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libccd/ChangeLog,v 1.1 2014/10/23 16:03:46 aballier Exp $
+
+*libccd-9999 (23 Oct 2014)
+*libccd-2.0 (23 Oct 2014)
+
+ 23 Oct 2014; Alexis Ballier <aballier@gentoo.org> +libccd-2.0.ebuild,
+ +libccd-9999.ebuild, +metadata.xml:
+ initial import, ebuild by me
+
diff --git a/sci-libs/libccd/libccd-2.0.ebuild b/sci-libs/libccd/libccd-2.0.ebuild
new file mode 100644
index 000000000000..6afda46551d5
--- /dev/null
+++ b/sci-libs/libccd/libccd-2.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libccd/libccd-2.0.ebuild,v 1.1 2014/10/23 16:03:46 aballier Exp $
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="http://github.com/danfis/libccd"
+fi
+
+inherit ${SCM} cmake-utils toolchain-funcs
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64"
+ SRC_URI="http://libccd.danfis.cz/files/${P}.tar.gz"
+fi
+
+DESCRIPTION="Library for collision detection between two convex shapes"
+HOMEPAGE="http://libccd.danfis.cz/"
+LICENSE="BSD"
+SLOT="0"
+IUSE="double doc"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+DOCS=( README )
+
+src_configure() {
+ local mycmakeargs=(
+ "-DCCD_DOUBLE=$(usex double TRUE FALSE)"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc ; then
+ cd "${S}/doc"
+ emake SPHINXBUILD=sphinx-build html
+ fi
+}
+
+src_test() {
+ cd src/testsuites
+ tc-export CC
+ LDFLAGS="-L${BUILD_DIR} ${LDFLAGS}" \
+ LD_LIBRARY_PATH="${BUILD_DIR}:${LD_LIBRARY_PATH}" \
+ emake check
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dohtml -r "${S}/doc/_build/html/"*
+}
diff --git a/sci-libs/libccd/libccd-9999.ebuild b/sci-libs/libccd/libccd-9999.ebuild
new file mode 100644
index 000000000000..79d725bcded4
--- /dev/null
+++ b/sci-libs/libccd/libccd-9999.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libccd/libccd-9999.ebuild,v 1.1 2014/10/23 16:03:46 aballier Exp $
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="http://github.com/danfis/libccd"
+fi
+
+inherit ${SCM} cmake-utils toolchain-funcs
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64"
+ SRC_URI="http://libccd.danfis.cz/files/${P}.tar.gz"
+fi
+
+DESCRIPTION="Library for collision detection between two convex shapes"
+HOMEPAGE="http://libccd.danfis.cz/"
+LICENSE="BSD"
+SLOT="0"
+IUSE="double doc"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+DOCS=( README )
+
+src_configure() {
+ local mycmakeargs=(
+ "-DCCD_DOUBLE=$(usex double TRUE FALSE)"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc ; then
+ cd "${S}/doc"
+ emake SPHINXBUILD=sphinx-build html
+ fi
+}
+
+src_test() {
+ cd src/testsuites
+ tc-export CC
+ LDFLAGS="-L${BUILD_DIR} ${LDFLAGS}" \
+ LD_LIBRARY_PATH="${BUILD_DIR}:${LD_LIBRARY_PATH}" \
+ emake check
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dohtml -r "${S}/doc/_build/html/"*
+}
diff --git a/sci-libs/libccd/metadata.xml b/sci-libs/libccd/metadata.xml
new file mode 100644
index 000000000000..5825d26f0d1a
--- /dev/null
+++ b/sci-libs/libccd/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>aballier@gentoo.org</email>
+<name>Alexis Ballier</name>
+</maintainer>
+ <use>
+ <flag name="double">Use double precision floats.</flag>
+ </use>
+</pkgmetadata>