summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-08-07 00:34:18 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-08-07 00:34:18 +0000
commit0d5cceacf03face34c5aa836c3dfc68eded01448 (patch)
treec8b74b402e00b8021c81e34e8c934121c92bd5a4 /sci-libs
parentFix building with USE=doc (remove bundler reference from all copies); fix tes... (diff)
downloadgentoo-2-0d5cceacf03face34c5aa836c3dfc68eded01448.tar.gz
gentoo-2-0d5cceacf03face34c5aa836c3dfc68eded01448.tar.bz2
gentoo-2-0d5cceacf03face34c5aa836c3dfc68eded01448.zip
Version bump, switch to EAPI4
(Portage version: 2.1.10.10/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libnova/ChangeLog8
-rw-r--r--sci-libs/libnova/libnova-0.12.1.ebuild54
-rw-r--r--sci-libs/libnova/libnova-0.14.0.ebuild40
-rw-r--r--sci-libs/libnova/libnova-0.7.0.ebuild37
4 files changed, 47 insertions, 92 deletions
diff --git a/sci-libs/libnova/ChangeLog b/sci-libs/libnova/ChangeLog
index 6e3578ccc5d6..4a85f402fef6 100644
--- a/sci-libs/libnova/ChangeLog
+++ b/sci-libs/libnova/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/libnova
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libnova/ChangeLog,v 1.13 2011/08/04 18:46:05 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libnova/ChangeLog,v 1.14 2011/08/07 00:34:18 bicatali Exp $
+
+*libnova-0.14.0 (07 Aug 2011)
+
+ 07 Aug 2011; Sébastien Fabbro <bicatali@gentoo.org> -libnova-0.7.0.ebuild,
+ -libnova-0.12.1.ebuild, +libnova-0.14.0.ebuild:
+ Version bump, switch to EAPI4
04 Aug 2011; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml:
Switched herd to sci-astronomy
diff --git a/sci-libs/libnova/libnova-0.12.1.ebuild b/sci-libs/libnova/libnova-0.12.1.ebuild
deleted file mode 100644
index a674a74d731a..000000000000
--- a/sci-libs/libnova/libnova-0.12.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libnova/libnova-0.12.1.ebuild,v 1.2 2008/11/02 07:11:28 vapier Exp $
-
-inherit eutils autotools flag-o-matic
-
-DESCRIPTION="Celestial Mechanics and Astronomical Calculation Library"
-HOMEPAGE="http://libnova.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="doc"
-
-DEPEND="doc? ( app-doc/doxygen )"
-RDEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # patch to use user's cflags and make doxygen working
- epatch "${FILESDIR}"/${P}-configure.patch
- eautoconf
-}
-
-src_compile() {
- # 0.12.1 does not pass test with > -02
- replace-flags -O? -O1
-
- econf || die "econf failed"
- emake || die "emake failed"
- if use doc; then
- cd doc
- emake doc || die "emake in doc failed"
- fi
-}
-
-src_test() {
- emake check || die "emake check failed"
- "${S}"/lntest/lntest || die "lntest failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README || die
- if use doc; then
- dohtml doc/html/* || die "dohtml failed"
- make clean
- rm -f examples/Makefile*
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
diff --git a/sci-libs/libnova/libnova-0.14.0.ebuild b/sci-libs/libnova/libnova-0.14.0.ebuild
new file mode 100644
index 000000000000..adafb1b3a081
--- /dev/null
+++ b/sci-libs/libnova/libnova-0.14.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libnova/libnova-0.14.0.ebuild,v 1.1 2011/08/07 00:34:18 bicatali Exp $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Celestial Mechanics and Astronomical Calculation Library"
+HOMEPAGE="http://libnova.sourceforge.net/"
+SRC_URI="http://dev.gentoo.org/~bicatali/${P}.tar.gz"
+# bad tar ball on sf, rebuild it from svn
+#SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="doc examples static-libs"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake
+ use doc && emake doc
+}
+
+src_install() {
+ default
+ use doc && dohtml doc/html/*
+ if use examples; then
+ make clean
+ rm -f examples/Makefile*
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/sci-libs/libnova/libnova-0.7.0.ebuild b/sci-libs/libnova/libnova-0.7.0.ebuild
deleted file mode 100644
index 8936752ec2b3..000000000000
--- a/sci-libs/libnova/libnova-0.7.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libnova/libnova-0.7.0.ebuild,v 1.2 2009/10/09 20:57:34 ssuominen Exp $
-
-DESCRIPTION="Celestial Mechanics and Astronomical Calculation Library"
-HOMEPAGE="http://libnova.sourceforge.net/"
-SRC_URI="mirror://sourceforge/libnova/${P}.tar.gz"
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="x86"
-IUSE=""
-
-DEPEND="app-doc/doxygen"
-RDEPEND=""
-
-src_compile() {
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || die "./configure failed"
- make || die
- cd doc && make doc || die
-}
-
-src_install() {
- dodir /usr/share/aclocal
- make \
- prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- LIBNOVA_MACRO_DIR=${D}/usr/share/aclocal \
- install || die
- dohtml doc/html/*
- doman doc/man/*/*
- dodoc AUTHORS ChangeLog NEWS README
-}