summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-10 18:02:03 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-10 18:02:03 +0000
commit1ad399f80e94663d71609bf2353e3d02e8c97b48 (patch)
treefe6a946e86ee385d6b149f86db932c2cf6aa06a2 /sci-libs
parentAdd latest officially released version of CVS. The 1.11 branch is the only t... (diff)
downloadgentoo-2-1ad399f80e94663d71609bf2353e3d02e8c97b48.tar.gz
gentoo-2-1ad399f80e94663d71609bf2353e3d02e8c97b48.tar.bz2
gentoo-2-1ad399f80e94663d71609bf2353e3d02e8c97b48.zip
Restrict Jython ABIs. Don't install .a files in Python and Ruby directories. Call python_mod_optimize() and python_mod_cleanup().
(Portage version: 2.2.0_alpha23/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/geos/ChangeLog7
-rw-r--r--sci-libs/geos/files/3.2.2-disable_static_modules.patch29
-rw-r--r--sci-libs/geos/geos-3.2.2.ebuild22
3 files changed, 52 insertions, 6 deletions
diff --git a/sci-libs/geos/ChangeLog b/sci-libs/geos/ChangeLog
index 8d5ec36d3c1b..cc2cdffeac66 100644
--- a/sci-libs/geos/ChangeLog
+++ b/sci-libs/geos/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/geos
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.49 2011/01/07 10:11:57 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.50 2011/02/10 18:02:03 arfrever Exp $
+
+ 10 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +files/3.2.2-disable_static_modules.patch, geos-3.2.2.ebuild:
+ Restrict Jython ABIs. Don't install .a files in Python and Ruby directories.
+ Call python_mod_optimize() and python_mod_cleanup().
07 Jan 2011; Hans de Graaff <graaff@gentoo.org> geos-3.1.1.ebuild,
geos-3.2.0.ebuild, geos-3.2.0-r1.ebuild, geos-3.2.2.ebuild:
diff --git a/sci-libs/geos/files/3.2.2-disable_static_modules.patch b/sci-libs/geos/files/3.2.2-disable_static_modules.patch
new file mode 100644
index 000000000000..6df8da74bad5
--- /dev/null
+++ b/sci-libs/geos/files/3.2.2-disable_static_modules.patch
@@ -0,0 +1,29 @@
+--- swig/python/Makefile.am
++++ swig/python/Makefile.am
+@@ -18,9 +18,9 @@
+ _geos_la_SOURCES = geos_wrap.cxx
+
+ # Only need to grab the capi header files
+-_geos_la_CPPFLAGS = $(SWIG_PYTHON_CPPFLAGS) -I$(top_builddir)/capi
++_geos_la_CPPFLAGS = $(SWIG_PYTHON_CPPFLAGS) -I$(top_builddir)/capi -shared
+ # Specify -module and -avoid-version so we can create a file called geos.dll/so which is what Python wants
+-_geos_la_LDFLAGS = -no-undefined -module -avoid-version
++_geos_la_LDFLAGS = -no-undefined -module -avoid-version -shared
+ _geos_la_LIBADD = $(top_builddir)/capi/libgeos_c.la $(PYTHON_LDFLAGS)
+
+
+--- swig/ruby/Makefile.am
++++ swig/ruby/Makefile.am
+@@ -22,10 +22,10 @@
+ geos_la_LIBADD = $(top_builddir)/capi/libgeos_c.la -l$(RUBY_SO_NAME)
+
+ # Only need to grab the capi header files
+-geos_la_CPPFLAGS = -I$(top_builddir)/capi
++geos_la_CPPFLAGS = -I$(top_builddir)/capi -shared
+
+ # Specify -module and -avoid-version so we can create a file called geos.dll/so which is what Ruby wants
+-geos_la_LDFLAGS = -no-undefined -module -avoid-version -L$(RUBY_LIB_DIR)
++geos_la_LDFLAGS = -no-undefined -module -avoid-version -shared -L$(RUBY_LIB_DIR)
+
+ if ENABLE_SWIG
+
diff --git a/sci-libs/geos/geos-3.2.2.ebuild b/sci-libs/geos/geos-3.2.2.ebuild
index d05782b022b5..065f3bfc23c0 100644
--- a/sci-libs/geos/geos-3.2.2.ebuild
+++ b/sci-libs/geos/geos-3.2.2.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.2.2.ebuild,v 1.2 2011/01/07 10:11:57 graaff Exp $
-
-EAPI=3
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.2.2.ebuild,v 1.3 2011/02/10 18:02:03 arfrever Exp $
+EAPI="3"
PYTHON_DEPEND="python? 2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
inherit autotools eutils python
@@ -35,7 +34,8 @@ src_prepare() {
epatch "${FILESDIR}"/3.2.0-multipy.patch \
"${FILESDIR}"/3.2.0-swig2.0.patch \
"${FILESDIR}"/3.2.0-python.patch \
- "${FILESDIR}"/3.2.0-darwin.patch
+ "${FILESDIR}"/3.2.0-darwin.patch \
+ "${FILESDIR}"/3.2.2-disable_static_modules.patch
eautoreconf
echo "#!${EPREFIX}/bin/bash" > py-compile
}
@@ -84,3 +84,15 @@ src_install() {
dohtml -r doxygen_docs/html/* || die
fi
}
+
+pkg_postinst() {
+ if use python; then
+ python_mod_optimize geos/geos.py
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup geos/geos.py
+ fi
+}