summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-07-02 16:51:30 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-07-02 16:51:30 +0000
commit3465b8bc4c6c28d800b7b6c85042d9363c438db7 (patch)
treefcc7ad4bfaf433de12f540dc67d19beb04649de7 /sci-libs
parentamd64 stable, bug #230425 (diff)
downloadgentoo-2-3465b8bc4c6c28d800b7b6c85042d9363c438db7.tar.gz
gentoo-2-3465b8bc4c6c28d800b7b6c85042d9363c438db7.tar.bz2
gentoo-2-3465b8bc4c6c28d800b7b6c85042d9363c438db7.zip
Added gcc-4.3 patch for geos-2.2.3 (bug #227707)
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/geos/ChangeLog6
-rw-r--r--sci-libs/geos/files/geos-2.2.3-gcc43.patch67
-rw-r--r--sci-libs/geos/geos-2.2.3.ebuild3
3 files changed, 74 insertions, 2 deletions
diff --git a/sci-libs/geos/ChangeLog b/sci-libs/geos/ChangeLog
index 36d9591dba52..fbecd70351ac 100644
--- a/sci-libs/geos/ChangeLog
+++ b/sci-libs/geos/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/geos
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.29 2008/05/29 17:51:17 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.30 2008/07/02 16:51:29 bicatali Exp $
+
+ 02 Jul 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/geos-2.2.3-gcc43.patch, geos-2.2.3.ebuild:
+ Added gcc-4.3 patch for geos-2.2.3 (bug #227707)
29 May 2008; Ali Polatel <hawking@gentoo.org> geos-2.2.1.ebuild,
geos-2.2.3.ebuild:
diff --git a/sci-libs/geos/files/geos-2.2.3-gcc43.patch b/sci-libs/geos/files/geos-2.2.3-gcc43.patch
new file mode 100644
index 000000000000..88605a046f28
--- /dev/null
+++ b/sci-libs/geos/files/geos-2.2.3-gcc43.patch
@@ -0,0 +1,67 @@
+--- ./source/capi/geos_c.cpp.orig 2008-07-02 17:37:37.000000000 +0100
++++ ./source/capi/geos_c.cpp 2008-07-02 17:37:58.000000000 +0100
+@@ -15,8 +15,8 @@
+ *
+ ***********************************************************************/
+
+-#include <stdio.h>
+-
++#include <cstdio>
++#include <cstring>
+ #include <string>
+ #include <iostream>
+ #include <sstream>
+--- ./source/index/quadtree/DoubleBits.cpp.orig 2008-07-02 17:31:56.000000000 +0100
++++ ./source/index/quadtree/DoubleBits.cpp 2008-07-02 17:32:57.000000000 +0100
+@@ -15,6 +15,7 @@
+
+ #include <geos/indexQuadtree.h>
+ #include <geos/util.h>
++#include <cstring>
+
+ namespace geos {
+
+--- ./source/io/markup/MarkupSTL.cpp.orig 2008-07-02 17:39:57.000000000 +0100
++++ ./source/io/markup/MarkupSTL.cpp 2008-07-02 17:41:38.000000000 +0100
+@@ -6,8 +6,10 @@
+ // Use in commercial applications requires written permission
+ // This software is provided "as is", with no warranty.
+
++#include <cstring>
+ #include "MarkupSTL.h"
+-#include <stdio.h>
++#include <cstdio>
++
+
+ using namespace std;
+
+--- ./source/io/StringTokenizer.cpp.orig 2008-07-02 17:33:49.000000000 +0100
++++ ./source/io/StringTokenizer.cpp 2008-07-02 17:34:22.000000000 +0100
+@@ -36,6 +36,7 @@
+
+
+ #include <geos/io.h>
++#include <cstring>
+
+ namespace geos {
+
+--- ./source/io/ByteOrderValues.cpp.orig 2008-07-02 17:34:48.000000000 +0100
++++ ./source/io/ByteOrderValues.cpp 2008-07-02 17:35:23.000000000 +0100
+@@ -16,6 +16,7 @@
+
+ #include <geos/io.h>
+ #include <geos/util.h>
++#include <cstring>
+
+ namespace geos {
+
+--- ./source/test/XMLTester.cpp.orig 2008-07-02 17:38:47.000000000 +0100
++++ ./source/test/XMLTester.cpp 2008-07-02 17:39:10.000000000 +0100
+@@ -23,6 +23,7 @@
+ #include <cassert>
+ #include <cctype>
+ #include <cstdlib>
++#include <cstring>
+ #include <fstream>
+ #include <functional>
+ #include <iostream>
diff --git a/sci-libs/geos/geos-2.2.3.ebuild b/sci-libs/geos/geos-2.2.3.ebuild
index d2395aa06956..06b2bdd37c2a 100644
--- a/sci-libs/geos/geos-2.2.3.ebuild
+++ b/sci-libs/geos/geos-2.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-2.2.3.ebuild,v 1.6 2008/05/29 17:51:17 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-2.2.3.ebuild,v 1.7 2008/07/02 16:51:29 bicatali Exp $
USE_RUBY="ruby18"
RUBY_OPTIONAL="yes"
@@ -28,6 +28,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}/${P}-swig.patch"
epatch "${FILESDIR}/${P}-python-shared.patch"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
}
src_compile() {