summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-02-26 17:38:05 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-02-26 17:38:05 +0000
commit39d45ebc9b4bb9462056dadad90519d15f70bfb1 (patch)
tree3a1038dd174ee1ad91c047705d9ccd9b01b3a849 /sci-libs
parentMarking poppler-0.10.4 ppc64 for bug 260266 (diff)
downloadgentoo-2-39d45ebc9b4bb9462056dadad90519d15f70bfb1.tar.gz
gentoo-2-39d45ebc9b4bb9462056dadad90519d15f70bfb1.tar.bz2
gentoo-2-39d45ebc9b4bb9462056dadad90519d15f70bfb1.zip
Version bump. More as-needed fixes, and general cleanup.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/fftw/ChangeLog10
-rw-r--r--sci-libs/fftw/fftw-3.2.1.ebuild125
-rw-r--r--sci-libs/fftw/files/fftw-3.2.1-as-needed.patch82
3 files changed, 215 insertions, 2 deletions
diff --git a/sci-libs/fftw/ChangeLog b/sci-libs/fftw/ChangeLog
index f7ba701c8629..53df34f7e726 100644
--- a/sci-libs/fftw/ChangeLog
+++ b/sci-libs/fftw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/fftw
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.75 2008/11/27 10:39:28 bicatali Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.76 2009/02/26 17:38:05 bicatali Exp $
+
+*fftw-3.2.1 (26 Feb 2009)
+
+ 26 Feb 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/fftw-3.2.1-as-needed.patch, +fftw-3.2.1.ebuild:
+ Version bump. More as-needed fixes, and general cleanup.
27 Nov 2008; Sébastien Fabbro <bicatali@gentoo.org> fftw-3.2.ebuild:
Fixed for older libtool versions and forcing posix threads in the ebuild
diff --git a/sci-libs/fftw/fftw-3.2.1.ebuild b/sci-libs/fftw/fftw-3.2.1.ebuild
new file mode 100644
index 000000000000..cf5aaaa1ebd9
--- /dev/null
+++ b/sci-libs/fftw/fftw-3.2.1.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.2.1.ebuild,v 1.1 2009/02/26 17:38:05 bicatali Exp $
+
+EAPI=2
+inherit flag-o-matic eutils toolchain-funcs autotools fortran
+
+DESCRIPTION="Fast C library for the Discrete Fourier Transform"
+HOMEPAGE="http://www.fftw.org/"
+SRC_URI="http://www.fftw.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="3.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="altivec doc fortran openmp sse sse2 threads"
+
+pkg_setup() {
+ FFTW_THREADS="--disable-threads --disable-openmp"
+ if use openmp; then
+ FFTW_THREADS="--disable-threads --enable-openmp"
+ elif use threads; then
+ FFTW_THREADS="--enable-threads --disable-openmp"
+ fi
+ if use openmp &&
+ [[ $(tc-getCC)$ == *gcc* ]] &&
+ ( [[ $(gcc-major-version)$(gcc-minor-version) -lt 42 ]] ||
+ ! built_with_use sys-devel/gcc openmp )
+ then
+ ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 "
+ ewarn "If you want to build fftw with OpenMP, abort now,"
+ ewarn "and switch CC to an OpenMP capable compiler"
+ ewarn "Otherwise, we will build using POSIX threads."
+ epause 5
+ FFTW_THREADS="--enable-threads --disable-openmp"
+ fi
+ FORTRAN="gfortran ifc g77"
+ use fortran && fortran_pkg_setup
+ FFTW_DIRS="single double longdouble"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+
+ # fix info file for category directory
+ sed -i \
+ -e 's/Texinfo documentation system/Libraries/' \
+ doc/fftw3.info || die "failed to fix info file"
+
+ rm m4/lt* m4/libtool.m4
+
+ AT_M4DIR=m4 eautoreconf
+ for x in ${FFTW_DIRS}; do
+ mkdir "${S}-${x}" || die
+ done
+}
+
+src_configure() {
+ # filter -Os according to docs
+ replace-flags -Os -O2
+
+ local myconfcommon="--enable-shared
+ $(use_enable fortran)
+ ${FFTW_THREADS}"
+
+ local myconfsingle="${myconfcommon} --enable-single"
+ local myconfdouble="${myconfcommon}"
+ local myconflongdouble="${myconfcommon} --enable-long-double"
+ if use sse2; then
+ myconfsingle="${myconfsingle} --enable-sse"
+ myconfdouble="${myconfdouble} --enable-sse2"
+ elif use sse; then
+ myconfsingle="${myconfsingle} --enable-sse"
+ fi
+ # altivec only helps singles, not doubles
+ if use altivec; then
+ myconfsingle="${myconfsingle} --enable-altivec"
+ fi
+
+ for x in ${FFTW_DIRS}; do
+ cd "${S}-${x}"
+ einfo "Configuring for ${x} precision"
+ local p=myconf${x}
+ ECONF_SOURCE="${S}" econf ${!p}
+ done
+}
+
+src_compile() {
+ for x in ${FFTW_DIRS}; do
+ cd "${S}-${x}"
+ einfo "Compiling for ${x} precision"
+ emake || die "emake for ${x} precision failed"
+ done
+}
+
+src_test () {
+ # We want this to be a reasonably quick test, but that is still hard...
+ ewarn "This test series will take 30 minutes on a modern 2.5Ghz machine"
+ # Do not increase the number of threads, it will not help your performance
+ #local testbase="perl check.pl --nthreads=1 --estimate"
+ # ${testbase} -${p}d || die "Failure: $n"
+ for x in ${FFTW_DIRS}; do
+ cd "${S}-${x}/tests"
+ einfo "Testing ${x} precision"
+ emake -j1 check || die "emake test ${x} failed"
+ done
+}
+
+src_install () {
+ # all builds are installed in the same place
+ # libs have distinuguished names; include files, docs etc. identical.
+ for x in ${FFTW_DIRS}; do
+ cd "${S}-${x}"
+ emake DESTDIR="${D}" install || die "emake install for ${x} failed"
+ done
+
+ cd "${S}"
+ dodoc AUTHORS ChangeLog NEWS README TODO COPYRIGHT CONVENTIONS
+ if use doc; then
+ cd doc
+ insinto /usr/share/doc/${PF}
+ doins -r html fftw3.pdf || die "doc install failed"
+ insinto /usr/share/doc/${PF}/faq
+ doins FAQ/fftw-faq.html/*
+ fi
+}
diff --git a/sci-libs/fftw/files/fftw-3.2.1-as-needed.patch b/sci-libs/fftw/files/fftw-3.2.1-as-needed.patch
new file mode 100644
index 000000000000..ee9c12a4df59
--- /dev/null
+++ b/sci-libs/fftw/files/fftw-3.2.1-as-needed.patch
@@ -0,0 +1,82 @@
+diff -Nur fftw-3.2.1.orig/configure.ac fftw-3.2.1/configure.ac
+--- fftw-3.2.1.orig/configure.ac 2009-02-20 19:28:55.832163268 +0000
++++ fftw-3.2.1/configure.ac 2009-02-26 15:02:37.533259854 +0000
+@@ -440,14 +440,15 @@
+ AC_ARG_WITH(combined-threads, [AC_HELP_STRING([--with-combined-threads],[combine threads into main libfftw3])], with_combined_threads=$withval, with_combined_threads=no)
+
+ if test "$enable_openmp"x != nox; then
+- AX_OPENMP([THREADLIBS=" "
++ AX_OPENMP([THREADLIBS="$OPENMP_LIBS"
+ AC_DEFINE(USING_OPENMP_THREADS, 1, [Define if we have and are using OpenMP multithreading directives])
+ CFLAGS="$CFLAGS $OPENMP_CFLAGS"],
+- [AC_MSG_ERROR([don't know how to enable OpenMP])])
++ [AC_MSG_WARN([don't know how to enable OpenMP, reverting to POSIX threads])])
++else
++ THREADLIBS=""
+ fi
+
+ dnl Check for threads library...
+-THREADLIBS=""
+ if test "$enable_threads" = "yes"; then
+ # POSIX threads, the default choice:
+ if test -z "$THREADLIBS"; then
+diff -Nur fftw-3.2.1.orig/m4/ax_openmp.m4 fftw-3.2.1/m4/ax_openmp.m4
+--- fftw-3.2.1.orig/m4/ax_openmp.m4 2009-02-20 19:28:55.792160754 +0000
++++ fftw-3.2.1/m4/ax_openmp.m4 2009-02-26 15:02:08.887255943 +0000
+@@ -54,13 +54,18 @@
+ done
+ []_AC_LANG_PREFIX[]FLAGS=$save[]_AC_LANG_PREFIX[]FLAGS
+ ])
++OPENMP_LIBS=" "
+ if test "x$ax_cv_[]_AC_LANG_ABBREV[]_openmp" = "xunknown"; then
+ m4_default([$2],:)
+ else
+ if test "x$ax_cv_[]_AC_LANG_ABBREV[]_openmp" != "xnone"; then
+ OPENMP_[]_AC_LANG_PREFIX[]FLAGS=$ax_cv_[]_AC_LANG_ABBREV[]_openmp
++ if test "x$ax_cv_[]_AC_LANG_ABBREV[]_openmp" = "x-fopenmp"; then
++ OPENMP_LIBS="-lgomp"
++ fi
+ fi
+ m4_default([$1], [AC_DEFINE(HAVE_OPENMP,1,[Define if OpenMP is enabled])])
+ fi
+ AC_SUBST(OPENMP_[]_AC_LANG_PREFIX[]FLAGS)
++AC_SUBST(OPENMP_LIBS)
+ ])dnl AX_OPENMP
+diff -Nur fftw-3.2.1.orig/Makefile.am fftw-3.2.1/Makefile.am
+--- fftw-3.2.1.orig/Makefile.am 2009-02-20 19:28:56.040169973 +0000
++++ fftw-3.2.1/Makefile.am 2009-02-26 15:02:08.887255943 +0000
+@@ -36,6 +36,13 @@
+ if SMP
+ if COMBINED_THREADS
+ COMBINED_THREADLIBS=threads/libfftw3@PREC_SUFFIX@_threads.la
++else
++lib_LTLIBRARIES += libfftw3@PREC_SUFFIX@_threads.la
++libfftw3@PREC_SUFFIX@_threads_la_SOURCES =
++libfftw3@PREC_SUFFIX@_threads_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@
++libfftw3@PREC_SUFFIX@_threads_la_LIBADD = \
++ libfftw3@PREC_SUFFIX@.la \
++ threads/libfftw3@PREC_SUFFIX@_threads.la
+ endif
+ endif
+
+diff -Nur fftw-3.2.1.orig/threads/Makefile.am fftw-3.2.1/threads/Makefile.am
+--- fftw-3.2.1.orig/threads/Makefile.am 2009-02-20 19:28:55.832163268 +0000
++++ fftw-3.2.1/threads/Makefile.am 2009-02-26 15:02:08.887255943 +0000
+@@ -2,11 +2,7 @@
+ -I$(top_srcdir)/rdft -I$(top_srcdir)/api
+
+ if SMP
+-if COMBINED_THREADS
+ noinst_LTLIBRARIES = libfftw3@PREC_SUFFIX@_threads.la
+-else
+-lib_LTLIBRARIES = libfftw3@PREC_SUFFIX@_threads.la
+-endif
+ endif
+
+ # pkgincludedir = $(includedir)/fftw3@PREC_SUFFIX@
+@@ -16,4 +12,5 @@
+ openmp.c threads.h dft-vrank-geq1.c ct.c rdft-vrank-geq1.c hc2hc.c \
+ vrank-geq1-rdft2.c f77api.c f77funcs.h
+
++libfftw3@PREC_SUFFIX@_threads_la_LIBADD = $(THREADLIBS)
+ libfftw3@PREC_SUFFIX@_threads_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@