summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-07-09 23:34:04 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-07-09 23:34:04 +0000
commit3df40b6f16eeb68e431988684de927c9d789a050 (patch)
tree3d0813ce7f02351ce4e4b14bac2442e92281586c /sci-libs
parentrevbump to update the game engine (diff)
downloadgentoo-2-3df40b6f16eeb68e431988684de927c9d789a050.tar.gz
gentoo-2-3df40b6f16eeb68e431988684de927c9d789a050.tar.bz2
gentoo-2-3df40b6f16eeb68e431988684de927c9d789a050.zip
Version bump, switch to python-r1 for python-bindings
(Portage version: 2.2.01.22120-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libsvm/ChangeLog10
-rw-r--r--sci-libs/libsvm/libsvm-3.17.ebuild (renamed from sci-libs/libsvm/libsvm-3.12.ebuild)23
2 files changed, 20 insertions, 13 deletions
diff --git a/sci-libs/libsvm/ChangeLog b/sci-libs/libsvm/ChangeLog
index 32093925631c..b4edf0e72e99 100644
--- a/sci-libs/libsvm/ChangeLog
+++ b/sci-libs/libsvm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/libsvm
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libsvm/ChangeLog,v 1.30 2012/12/04 18:40:13 bicatali Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libsvm/ChangeLog,v 1.31 2013/07/09 23:34:04 bicatali Exp $
+
+*libsvm-3.17 (09 Jul 2013)
+
+ 09 Jul 2013; Sébastien Fabbro <bicatali@gentoo.org> +libsvm-3.17.ebuild,
+ -libsvm-3.12.ebuild:
+ Version bump, switch to python-r1 for python-bindings
04 Dec 2012; Sébastien Fabbro <bicatali@gentoo.org> files/3.14-makefile.patch:
Fixed parallel build, bug #445312
diff --git a/sci-libs/libsvm/libsvm-3.12.ebuild b/sci-libs/libsvm/libsvm-3.17.ebuild
index fc76d86178e3..902a34910684 100644
--- a/sci-libs/libsvm/libsvm-3.12.ebuild
+++ b/sci-libs/libsvm/libsvm-3.17.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libsvm/libsvm-3.12.ebuild,v 1.3 2012/06/26 23:49:24 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libsvm/libsvm-3.17.ebuild,v 1.1 2013/07/09 23:34:04 bicatali Exp $
-EAPI=4
+EAPI=5
-SUPPORT_PYTHON_ABIS="1"
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-inherit eutils java-pkg-opt-2 python flag-o-matic toolchain-funcs
+inherit eutils java-pkg-opt-2 python-r1 flag-o-matic toolchain-funcs
DESCRIPTION="Library for Support Vector Machines"
HOMEPAGE="http://www.csie.ntu.edu.tw/~cjlin/libsvm/"
@@ -18,7 +18,8 @@ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
IUSE="java openmp python tools"
DEPEND="java? ( >=virtual/jdk-1.4 )"
-RDEPEND="${DEPEND}
+RDEPEND="
+ java? ( >=virtual/jre-1.4 )
tools? ( sci-visualization/gnuplot )"
pkg_setup() {
@@ -32,13 +33,12 @@ pkg_setup() {
fi
append-cxxflags -DOPENMP
fi
- use python && python_pkg_setup
}
src_prepare() {
epatch \
"${FILESDIR}"/3.11-openmp.patch \
- "${FILESDIR}"/3.12-makefile.patch
+ "${FILESDIR}"/3.14-makefile.patch
sed -i -e "s@\.\./@${EPREFIX}/usr/bin/@g" tools/*.py \
|| die "Failed to fix paths in python files"
@@ -77,10 +77,11 @@ src_install() {
if use python ; then
installation() {
- insinto $(python_get_sitedir)
- doins python/*.py
+ touch python/__init__.py || die
+ python_moduleinto libsvm
+ python_domodule python/*.py
}
- python_execute_function installation
+ python_foreach_impl installation
newdoc python/README README.python
fi