summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-01-05 20:09:08 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-01-05 20:09:08 +0000
commit3ecd3cb615bcade7810e60223a49d9b42115ebd8 (patch)
tree8da44a8b345f33efdfd37a761542fdb2ce82840c /sci-libs
parentVersion bump. Fixed RDEPEND not being explicitely assigned. Removed unnecessa... (diff)
downloadgentoo-2-3ecd3cb615bcade7810e60223a49d9b42115ebd8.tar.gz
gentoo-2-3ecd3cb615bcade7810e60223a49d9b42115ebd8.tar.bz2
gentoo-2-3ecd3cb615bcade7810e60223a49d9b42115ebd8.zip
Version bump
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/geos/ChangeLog9
-rw-r--r--sci-libs/geos/geos-3.3.1.ebuild90
2 files changed, 97 insertions, 2 deletions
diff --git a/sci-libs/geos/ChangeLog b/sci-libs/geos/ChangeLog
index 74f33c94d94d..7ae3e8149bb0 100644
--- a/sci-libs/geos/ChangeLog
+++ b/sci-libs/geos/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/geos
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.58 2011/05/03 11:18:28 grobian Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.59 2012/01/05 20:09:08 bicatali Exp $
+
+*geos-3.3.1 (05 Jan 2012)
+
+ 05 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org> +geos-3.3.1.ebuild:
+ Version bump
03 May 2011; Fabian Groffen <grobian@gentoo.org> geos-3.2.2.ebuild:
Marked ~x64-freebsd
diff --git a/sci-libs/geos/geos-3.3.1.ebuild b/sci-libs/geos/geos-3.3.1.ebuild
new file mode 100644
index 000000000000..af0c43db665f
--- /dev/null
+++ b/sci-libs/geos/geos-3.3.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.3.1.ebuild,v 1.1 2012/01/05 20:09:07 bicatali Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+inherit autotools eutils python
+
+DESCRIPTION="Geometry engine library for Geographic Information Systems"
+HOMEPAGE="http://trac.osgeo.org/geos/"
+SRC_URI="http://download.osgeo.org/geos/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="doc php python ruby static-libs"
+
+RDEPEND="php? ( dev-lang/php )
+ ruby? ( dev-lang/ruby )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ php? ( dev-lang/swig )
+ python? ( dev-lang/swig )
+ ruby? ( dev-lang/swig )"
+
+pkg_setup() {
+ use python && python_pkg_setup
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/3.2.0-python.patch \
+ "${FILESDIR}"/3.2.0-darwin.patch
+ eautoreconf
+ echo "#!${EPREFIX}/bin/bash" > py-compile
+}
+
+src_configure() {
+ econf \
+ $(use_enable python) \
+ $(use_enable ruby) \
+ $(use_enable php) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake
+ if use python; then
+ emake -C swig/python clean
+ python_copy_sources swig/python
+ building() {
+ emake \
+ PYTHON_CPPFLAGS="-I${EPREFIX}$(python_get_includedir)" \
+ PYTHON_LDFLAGS="$(python_get_library -l)" \
+ SWIG_PYTHON_CPPFLAGS="-I${EPREFIX}$(python_get_includedir)" \
+ pyexecdir="${EPREFIX}$(python_get_sitedir)" \
+ pythondir="${EPREFIX}$(python_get_sitedir)"
+ }
+ python_execute_function -s --source-dir swig/python building
+ fi
+ use doc && emake -C "${S}/doc" doxygen-html
+}
+
+src_install() {
+ default
+ if use python; then
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ pyexecdir="${EPREFIX}$(python_get_sitedir)" \
+ pythondir="${EPREFIX}$(python_get_sitedir)" \
+ install
+ }
+ python_execute_function -s --source-dir swig/python installation
+ python_clean_installation_image
+ fi
+ use doc && dohtml -r "${S}/doc" doxygen_docs/html/*
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize geos/geos.py
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup geos/geos.py
+}