summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-06-02 04:40:06 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-06-02 04:40:06 +0000
commit458733d23fc12b48d2bcd8e7c9909c30d728e9fd (patch)
tree39c1cd26aa2010959570d02043cede38a0ca3037 /sci-libs
parentAdd kernel description file (diff)
downloadgentoo-2-458733d23fc12b48d2bcd8e7c9909c30d728e9fd.tar.gz
gentoo-2-458733d23fc12b48d2bcd8e7c9909c30d728e9fd.tar.bz2
gentoo-2-458733d23fc12b48d2bcd8e7c9909c30d728e9fd.zip
Added missing backslashes that caused problems with sed. This fixes bug #132728.
(Portage version: 2.1_rc3-r2)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/torch/ChangeLog8
-rw-r--r--sci-libs/torch/files/digest-torch-36
-rw-r--r--sci-libs/torch/torch-3.ebuild8
3 files changed, 15 insertions, 7 deletions
diff --git a/sci-libs/torch/ChangeLog b/sci-libs/torch/ChangeLog
index 0a203d58065a..c16aeb9423ed 100644
--- a/sci-libs/torch/ChangeLog
+++ b/sci-libs/torch/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/torch
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/torch/ChangeLog,v 1.4 2005/08/24 16:28:34 phosphan Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/torch/ChangeLog,v 1.5 2006/06/02 04:40:06 markusle Exp $
+
+ 02 Jun 2006; Markus Dittrich <markusle@gentoo.org> torch-3.ebuild:
+ Added missing backslashes that caused problems with sed. This fixes
+ bug #132728.
24 Aug 2005; Patrick Kursawe <phosphan@gentoo.org> torch-3.ebuild:
No longer using cp -a (bug #103487)
diff --git a/sci-libs/torch/files/digest-torch-3 b/sci-libs/torch/files/digest-torch-3
index 44752ac23b2e..a016241b2900 100644
--- a/sci-libs/torch/files/digest-torch-3
+++ b/sci-libs/torch/files/digest-torch-3
@@ -1,2 +1,6 @@
-MD5 73ecbab0862a6d98aa6a602a89b2ceb6 Torch3src.tgz 775622
MD5 3e04241c606ddeb6cf0f6a5bc4b50a2e Torch3doc.tgz 1622648
+RMD160 29fa1e0ff9e5137fcbc4a59ceb057f4b7f386789 Torch3doc.tgz 1622648
+SHA256 c8ff336cf1af89755ed226ca1211f335d5e8a716d0c2fef18aa34afa2a148822 Torch3doc.tgz 1622648
+MD5 73ecbab0862a6d98aa6a602a89b2ceb6 Torch3src.tgz 775622
+RMD160 a83b873da125aae0085976e5b3a15288c988f40e Torch3src.tgz 775622
+SHA256 f3ae3b951bd2d966d804f273f7607af6044c06861a01143f661efac2bb15f3bd Torch3src.tgz 775622
diff --git a/sci-libs/torch/torch-3.ebuild b/sci-libs/torch/torch-3.ebuild
index 198c2c7e62be..698a819266aa 100644
--- a/sci-libs/torch/torch-3.ebuild
+++ b/sci-libs/torch/torch-3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/torch/torch-3.ebuild,v 1.3 2005/08/24 16:28:34 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/torch/torch-3.ebuild,v 1.4 2006/06/02 04:40:06 markusle Exp $
inherit toolchain-funcs multilib
@@ -47,7 +47,7 @@ src_install() {
sed -i \
-e "s:^LIBS_DIR.*:LIBS_DIR=/usr/$(get_libdir):" \
-e 's|^INCS := .*|INCS := -I /usr/include/torch $(MYINCS)|' \
- -e '/^INCS +=/c\' \
+ -e '/^INCS +=/c\\' \
Makefile_options_Linux
dodir /usr/share/${PN}
insinto /usr/share/${PN}
@@ -59,7 +59,7 @@ src_install() {
cd ${D}/usr/share/doc/${PF}
sed -i \
-e 's|^TORCHDIR.*|TORCHDIR := /usr/share/torch|' \
- -e '/MAKE/c\' -e '/VERSION_KEY/c\' \
+ -e '/MAKE/c\\' -e '/VERSION_KEY/c\\' \
examples/*/Makefile
for ex in examples/*/Makefile; do
echo -e '\t$(CC) $(CFLAGS_$(MODE)) $(INCS) -o $@ $< $(LIBS)' >> ${ex}