summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-02-18 11:54:02 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-02-18 11:54:02 +0000
commit54021d938b5612e7d768348a4d96a5c9749582bb (patch)
treec4664124ffa4034b7f6649282bb30c77e2ea853e /sci-libs
parentBump, thanks Ben Bannier, closing bug #257689 (diff)
downloadgentoo-2-54021d938b5612e7d768348a4d96a5c9749582bb.tar.gz
gentoo-2-54021d938b5612e7d768348a4d96a5c9749582bb.tar.bz2
gentoo-2-54021d938b5612e7d768348a4d96a5c9749582bb.zip
Version bump
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/cfitsio/ChangeLog8
-rw-r--r--sci-libs/cfitsio/cfitsio-3.130.ebuild56
-rw-r--r--sci-libs/cfitsio/files/cfitsio-3.130-autotools.patch263
3 files changed, 326 insertions, 1 deletions
diff --git a/sci-libs/cfitsio/ChangeLog b/sci-libs/cfitsio/ChangeLog
index eb4a089db61f..cfd8e1af7a40 100644
--- a/sci-libs/cfitsio/ChangeLog
+++ b/sci-libs/cfitsio/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/cfitsio
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cfitsio/ChangeLog,v 1.25 2009/02/09 20:32:43 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cfitsio/ChangeLog,v 1.26 2009/02/18 11:54:01 bicatali Exp $
+
+*cfitsio-3.130 (18 Feb 2009)
+
+ 18 Feb 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/cfitsio-3.130-autotools.patch, +cfitsio-3.130.ebuild:
+ Version bump
09 Feb 2009; Markus Meier <maekke@gentoo.org> cfitsio-3.100-r1.ebuild:
amd64/x86 stable, bug #256681
diff --git a/sci-libs/cfitsio/cfitsio-3.130.ebuild b/sci-libs/cfitsio/cfitsio-3.130.ebuild
new file mode 100644
index 000000000000..24892eced10c
--- /dev/null
+++ b/sci-libs/cfitsio/cfitsio-3.130.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cfitsio/cfitsio-3.130.ebuild,v 1.1 2009/02/18 11:54:01 bicatali Exp $
+
+EAPI=2
+inherit eutils fortran autotools
+
+DESCRIPTION="C and Fortran library for manipulating FITS files"
+HOMEPAGE="http://heasarc.gsfc.nasa.gov/docs/software/fitsio/fitsio.html"
+SRC_URI="ftp://heasarc.gsfc.nasa.gov/software/fitsio/c/${PN}${PV//.}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc fortran"
+
+DEPEND="fortran? ( dev-lang/cfortran )"
+RDEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+ if use fortran; then
+ FORTRAN="gfortran g77 ifc"
+ fortran_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # avoid internal cfortran
+ if use fortran; then
+ sed -i \
+ -e 's:"cfortran.h":<cfortran.h>:' \
+ f77_wrap.h || die "sed fortran failed"
+ mv cfortran.h cfortran.h.disabled
+ fi
+ epatch "${FILESDIR}"/${P}-autotools.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable fortran)
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc changes.txt README cfitsio.doc || die "dodoc failed"
+ insinto /usr/share/doc/${PF}/examples
+ doins cookbook.c testprog.c speed.c smem.c || die "install examples failed"
+ use fortran && dodoc fitsio.doc && doins cookbook.f
+ if use doc; then
+ insinto /usr/share/doc/${PF}/
+ doins quick.ps cfitsio.ps fpack.pdf
+ use fortran && doins fitsio.ps
+ fi
+}
diff --git a/sci-libs/cfitsio/files/cfitsio-3.130-autotools.patch b/sci-libs/cfitsio/files/cfitsio-3.130-autotools.patch
new file mode 100644
index 000000000000..241d9698d952
--- /dev/null
+++ b/sci-libs/cfitsio/files/cfitsio-3.130-autotools.patch
@@ -0,0 +1,263 @@
+--- configure.ac.absent 1970-01-01 01:00:00.000000000 +0100
++++ configure.ac 2008-06-02 01:08:32.000000000 +0100
+@@ -0,0 +1,158 @@
++AC_PREREQ(2.59)
++AC_INIT([cfitsio], [3.130], [pence@tetra.gsfc.nasa.gov])
++AC_CONFIG_SRCDIR([fitscore.c])
++AM_INIT_AUTOMAKE([foreign])
++
++
++AC_PROG_LIBTOOL
++dnl no api version info, so simply copy package version
++SHARED_VERSION_INFO="3:0:0"
++AC_SUBST(SHARED_VERSION_INFO)
++
++AC_PROG_YACC
++AC_PROG_LEX
++
++AC_MSG_CHECKING([whether to enable fortran interface])
++AC_ARG_ENABLE([fortran],
++ AS_HELP_STRING([--enable-fortran], [Build the fortran interface]),
++ [ENABLE_FORTRAN=$enableval
++ AC_MSG_RESULT([$enableval])],
++ [ENABLE_FORTRAN=no
++ AC_MSG_RESULT([no])]
++)
++
++if test x"$ENABLE_FORTRAN" = x"yes" ; then
++ AC_PROG_F77
++ if test x$F77 = xg77; then
++ cfortran_def=g77Fortran
++ elif test x$F77 = xifort ; then
++ cfortran_def=INTEL_COMPILER
++ elif test x$F77 = xgfortran ; then
++ cfortran_def=gFortran
++ elif test x$F77 = xpgf77 ; then
++ cfortran_def=pgiFortran
++ else
++ cfortran_def=f2cFortran
++ fi
++ CPPFLAGS_FORTRAN="-D$cfortran_def"
++ AC_SUBST(CPPFLAGS_FORTRAN)
++fi
++AC_SUBST([ENABLE_FORTRAN])
++AM_CONDITIONAL([ENABLE_FORTRAN], test "x$ENABLE_FORTRAN" = "xyes")
++
++AC_CANONICAL_HOST
++case $host in
++ *apple*darwin*)
++ dnl may break Absoft compilers
++ AC_DEFINE(_LARGEFILE_SOURCE, [1],
++ [Define to 1 if you have large file support])
++ AC_DEFINE(_FILE_OFFSET_BITS, [64],
++ [Offsets bits in files])
++ ;;
++ *hppa*)
++ CPPFLAGS_EXTRA="-DPG_PPU"
++ ;;
++ *sunos5*)
++ AC_DEFINE(_LARGEFILE_SOURCE, [1],
++ [Define to 1 if you have large file support])
++ AC_DEFINE(_FILE_OFFSET_BITS, [64],
++ [Offsets bits in files])
++ CPPFLAGS_EXTRA="-DHAVE_ALLOCA_H -DHAVE_POSIX_SIGNALS"
++ ;;
++ *irix*)
++ CPPFLAGS_EXTRA="-DHAVE_POSIX_SIGNALS"
++ ;;
++ *linux*)
++ AC_DEFINE(_LARGEFILE_SOURCE, [1],
++ [Define to 1 if you have large file support])
++ AC_DEFINE(_FILE_OFFSET_BITS, [64],
++ [Offsets bits in files])
++ ;;
++ *cygwin*)
++ CPPFLAGS_EXTRA="-DHAVE_POSIX_SIGNALS"
++ ;;
++ *)
++ ;;
++esac
++AC_SUBST(CPPFLAGS_EXTRA)
++
++AC_CHECK_FUNCS([ftruncate])
++AC_CHECK_FUNCS([shmat shmdt shmget],
++ AC_DEFINE(HAVE_SHMEM_SERVICES, [1],
++ [Define to yes if you have shared memory functions])
++)
++AC_CHECK_FUNCS([gethostbyname connect],
++ [AC_DEFINE(HAVE_NET_SERVICES, [1],
++ [Define to 1 if you have network functions])]
++)
++AC_CHECK_TYPE(long long,
++ [AC_DEFINE(HAVE_LONGLONG, [1],
++ [Define to 1 if your compiler supports long long])]
++)
++dnl check for flock_t
++AC_COMPILE_IFELSE(
++ [AC_LANG_PROGRAM([[
++#include <sys/fcntl.h>
++ ]], [[
++flock_t filler;
++ ]])],
++ [AC_DEFINE(HAVE_FLOCK_T, 1, [if you have flock_t])
++ AC_MSG_RESULT("yes")],
++ [AC_MSG_RESULT("no") ])
++
++if test "$HAVE_FLOCK_T" != 1; then
++ AC_COMPILE_IFELSE([
++ AC_LANG_PROGRAM([[
++#include <sys/flock.h>
++ ]], [[
++flock_t filler;
++ ]])],
++ [AC_DEFINE(HAVE_FLOCK_T, 1, [if you have flock_t])
++ AC_MSG_RESULT("yes")],
++ [AC_MSG_RESULT("no") ])
++fi
++
++# check for union semun type
++AC_CHECK_TYPE(union semun,
++ AC_DEFINE(HAVE_UNION_SEMUN, [1],
++ [Define to 1 if you have semun in sys/sem.h]),,[
++#include <sys/types.h>
++#include <sys/ipc.h>
++#include <sys/sem.h>
++ ]
++)
++
++dnl this quick check will add -lm to LIBS
++AC_CHECK_LIB(m, cos)
++
++AC_ARG_WITH(gsiftp-flavour,
++ [ --with-gsiftp-flavour[[=PATH]] Enable Globus Toolkit gsiftp protocol support ],
++ [ if test "x$withval" != "xno"; then
++
++ if test "x$withval" != "xyes" ; then
++ GSIFTP_FLAVOUR=${withval}
++ fi
++ AC_DEFINE(GSIFTP_FLAVOUR, [1],
++ [Define to 1 if you want Globus Toolkit architecture])
++ fi
++ ]
++)
++
++AC_ARG_WITH(gsiftp,
++ [ --with-gsiftp[[=PATH]] Enable Globus Toolkit gsiftp protocol support ],
++ [ if test "x$withval" != "xno"; then
++ if test "x$withval" != "xyes" ; then
++ CPPFLAGS_GLOBUS="-I${withval}/include/${GSIFTP_FLAVOUR}"
++ LIBS_GLOBUS="-L${withval}/lib -lglobus_ftp_client_${GSIFTP_FLAVOUR}"
++ HAVE_GSIFTP=yes
++ fi
++ AC_DEFINE(HAVE_GSIFTP, [1],
++ [Define if you want Globus Toolkit gsiftp protocol support])
++ fi
++ ]
++)
++
++AC_SUBST(CPPFLAGS_GLOBUS)
++AC_SUBST(LIBS_GLOBUS)
++AC_CONFIG_FILES([Makefile cfitsio.pc])
++AC_OUTPUT
+--- Makefile.am.absent 1970-01-01 01:00:00.000000000 +0100
++++ Makefile.am 2008-06-02 01:07:45.000000000 +0100
+@@ -0,0 +1,81 @@
++lib_LTLIBRARIES = libcfitsio.la
++
++C_SOURCES = \
++ buffers.c cfileio.c checksum.c compress.c drvrfile.c drvrmem.c \
++ drvrnet.c drvrsmem.c drvrgsiftp.c editcol.c edithdu.c eval_l.c \
++ eval_y.c eval_f.c fitscore.c getcol.c getcolb.c getcold.c getcole.c \
++ getcoli.c getcolj.c getcolk.c getcoll.c getcols.c getcolsb.c \
++ getcoluk.c getcolui.c getcoluj.c getkey.c group.c grparser.c \
++ histo.c iraffits.c \
++ modkey.c putcol.c putcolb.c putcold.c putcole.c putcoli.c \
++ putcolj.c putcolk.c putcoluk.c putcoll.c putcols.c putcolsb.c \
++ putcolu.c putcolui.c putcoluj.c putkey.c region.c scalnull.c \
++ swapproc.c wcssub.c wcsutil.c imcompress.c quantize.c ricecomp.c \
++ pliocomp.c fits_hcompress.c fits_hdecompress.c
++
++F77_SOURCES=
++if ENABLE_FORTRAN
++F77_SOURCES += f77_wrap1.c f77_wrap2.c f77_wrap3.c f77_wrap4.c f77_wrap.h
++endif
++AM_YFLAGS = -d -v
++
++include_HEADERS = fitsio.h fitsio2.h longnam.h drvrsmem.h
++libcfitsio_la_SOURCES = $(C_SOURCES) $(F77_SOURCES) $(include_HEADERS)
++libcfitsio_la_LDFLAGS = -no-undefined -version-info @SHARED_VERSION_INFO@
++libcfitsio_la_CPPFLAGS = @CPPFLAGS_FORTRAN@ @CPPFLAGS_EXTRA@ @CPPFLAGS_GLOBUS@
++libcfitsio_la_LIBADD = @LIBS_GLOBUS@
++
++
++pkgconfigdir = $(libdir)/pkgconfig
++pkgconfig_DATA = cfitsio.pc
++
++LDADD = libcfitsio.la
++bin_PROGRAMS = fitscopy imcopy listhead fpack funpack
++fitscopy_SOURCES = fitscopy.c
++listhead_SOURCES = listhead.c
++imcopy_SOURCES = imcopy.c
++fpack_SOURCES = fpack.c fpackutil.c
++funpack_SOURCES = funpack.c fpackutil.c
++
++# tests
++check_PROGRAMS = testprog
++noinst_PROGRAMS = speed cookbook smem
++testprog_SOURCES = testprog.c
++speed_SOURCES = speed.c
++cookbook_SOURCES = cookbook.c
++smem_SOURCES = smem.c
++
++if ENABLE_FORTRAN
++check_PROGRAMS += testf77
++testf77_SOURCES = testf77.f
++endif
++
++check-local: $(check_PROGRAMS)
++ @total=0; failed=0; \
++ for i in $(check_PROGRAMS); do \
++ echo "--- Testing $$i ---"; \
++ ./$$i${EXEEXT} > my_$$i.out; \
++ diff $$i.out my_$$i.out; \
++ cmp $$i.fit $$i.std; \
++ if [ "x$$?" = "x0" ]; then \
++ echo "Test \`$$i' PASSED."; \
++ else \
++ echo "Test \`$$i' FAILED!!!"; \
++ failed=$$(($$failed + 1)); \
++ fi; \
++ total=$$(($$total + 1)); \
++ done; \
++ if [ $$failed -gt 0 ]; then \
++ echo "*** ERROR: $$failed/$$total tests failed!!!"; \
++ echo ""; \
++ exit 1; \
++ fi
++
++eval:
++ @$(LEX) -t eval.l > eval_l.c1; \
++ sed -e 's/yy/ff/g' -e 's/YY/FF/g' eval_l.c1 > eval_l.c; \
++ rm -f eval_l.c1; \
++ $(YACC) -d -v -y eval.y; \
++ sed -e 's/yy/ff/g' -e 's/YY/FF/g' y.tab.c > eval_y.c; \
++ sed -e 's/yy/ff/g' -e 's/YY/FF/g' y.tab.h > eval_tab.h; \
++ rm -f y.tab.c y.tab.h
+--- cfitsio.pc.in.orig 2008-06-02 01:20:50.000000000 +0100
++++ cfitsio.pc.in 2008-06-02 01:22:14.000000000 +0100
+@@ -1,10 +1,10 @@
+ prefix=@prefix@
+ exec_prefix=@exec_prefix@
+-libdir=${exec_prefix}/lib
+-includedir=${prefix}/include
++libdir=@libdir@
++includedir=@includedir@
+
+-Name: cfitsio
++Name: @PACKAGE_NAME@
+ Description: FITS File Subroutine Library
+-Version: 3.006
+-Libs: -L${libdir} -lcfitsio @LIBS@ -lm
++Version: @PACKAGE_VERSION@
++Libs: -L${libdir} -lcfitsio @LIBS@
+ Cflags: -I${includedir}