summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-06-04 16:05:56 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-06-04 16:05:56 +0000
commit55cae6226e2e137a610693a4bc73768a844f232e (patch)
treee5d61d6ad89f04066b7949fcdfb898cd338de3e4 /sci-libs
parentStable for x86, wrt bug #507796 (diff)
downloadgentoo-2-55cae6226e2e137a610693a4bc73768a844f232e.tar.gz
gentoo-2-55cae6226e2e137a610693a4bc73768a844f232e.tar.bz2
gentoo-2-55cae6226e2e137a610693a4bc73768a844f232e.zip
Version bump
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/hdf5/ChangeLog11
-rw-r--r--sci-libs/hdf5/files/hdf5-1.8.13-implicits.patch35
-rw-r--r--sci-libs/hdf5/files/hdf5-1.8.13-no-messing-ldpath.patch21
-rw-r--r--sci-libs/hdf5/hdf5-1.8.13.ebuild104
-rw-r--r--sci-libs/hdf5/metadata.xml30
5 files changed, 184 insertions, 17 deletions
diff --git a/sci-libs/hdf5/ChangeLog b/sci-libs/hdf5/ChangeLog
index 15c930ec0885..f13d1019c107 100644
--- a/sci-libs/hdf5/ChangeLog
+++ b/sci-libs/hdf5/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/hdf5
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.117 2013/11/15 15:49:14 xarthisius Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.118 2014/06/04 16:05:55 bicatali Exp $
+
+*hdf5-1.8.13 (04 Jun 2014)
+
+ 04 Jun 2014; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/hdf5-1.8.13-implicits.patch,
+ +files/hdf5-1.8.13-no-messing-ldpath.patch, +hdf5-1.8.13.ebuild, metadata.xml:
+ Version bump
*hdf5-1.8.12 (15 Nov 2013)
diff --git a/sci-libs/hdf5/files/hdf5-1.8.13-implicits.patch b/sci-libs/hdf5/files/hdf5-1.8.13-implicits.patch
new file mode 100644
index 000000000000..2061d16f71ea
--- /dev/null
+++ b/sci-libs/hdf5/files/hdf5-1.8.13-implicits.patch
@@ -0,0 +1,35 @@
+--- a/test/cache_common.h
++++ b/test/cache_common.h
+@@ -702,5 +702,8 @@ void validate_mdc_config(hid_t file_id,
+ hbool_t compare_init,
+ int test_num);
+
++hbool_t resize_configs_are_equal(const H5C_auto_size_ctl_t *a,
++ const H5C_auto_size_ctl_t *b,
++ hbool_t compare_init);
+ #endif /* _CACHE_COMMON_H */
+
+--- a/testpar/t_span_tree.c
++++ b/testpar/t_span_tree.c
+@@ -37,6 +37,9 @@
+ #include "hdf5.h"
+ #include "H5private.h"
+ #include "testphdf5.h"
++#define H5S_PACKAGE
++#define H5S_TESTING
++#include "H5Spkg.h"
+
+
+ static void coll_write_test(int chunk_factor);
+--- a/configure.ac
++++ b/configure.ac
+@@ -1504,6 +1504,9 @@ case "$host_cpu-$host_vendor-$host_os" in
+ ## however, we do not do this since it breaks the big test on some
+ ## older platforms.
+ AM_CPPFLAGS="-D_BSD_SOURCE $AM_CPPFLAGS"
++
++ ## _GNU_SOURCE is needed for vasprintf
++ AM_CPPFLAGS="-D_GNU_SOURCE $AM_CPPFLAGS"
+ ;;
+ esac
+
diff --git a/sci-libs/hdf5/files/hdf5-1.8.13-no-messing-ldpath.patch b/sci-libs/hdf5/files/hdf5-1.8.13-no-messing-ldpath.patch
new file mode 100644
index 000000000000..82bc5d8b120a
--- /dev/null
+++ b/sci-libs/hdf5/files/hdf5-1.8.13-no-messing-ldpath.patch
@@ -0,0 +1,21 @@
+Prevent build system with messing up LD_LIBRARY_PATH
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -125,8 +125,6 @@ settings_DATA=libhdf5.settings
+ # Remove the generated .c file if errors occur unless HDF5_Make_Ignore
+ # is set to ignore the error.
+ H5Tinit.c: H5detect$(EXEEXT)
+- LD_LIBRARY_PATH="$$LD_LIBRARY_PATH`echo $(LDFLAGS) | \
+- sed -e 's/-L/:/g' -e 's/ //g'`" \
+ $(RUNSERIAL) ./H5detect$(EXEEXT) > $@ || \
+ (test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
+ ($(RM) $@ ; exit 1)
+@@ -137,8 +135,6 @@ H5Tinit.c: H5detect$(EXEEXT)
+ # Remove the generated .c file if errors occur unless HDF5_Make_Ignore
+ # is set to ignore the error.
+ H5lib_settings.c: H5make_libsettings$(EXEEXT) libhdf5.settings
+- LD_LIBRARY_PATH="$$LD_LIBRARY_PATH`echo $(LDFLAGS) | \
+- sed -e 's/-L/:/g' -e 's/ //g'`" \
+ $(RUNSERIAL) ./H5make_libsettings$(EXEEXT) > $@ || \
+ (test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
+ ($(RM) $@ ; exit 1)
diff --git a/sci-libs/hdf5/hdf5-1.8.13.ebuild b/sci-libs/hdf5/hdf5-1.8.13.ebuild
new file mode 100644
index 000000000000..1ef0ad197a1d
--- /dev/null
+++ b/sci-libs/hdf5/hdf5-1.8.13.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.13.ebuild,v 1.1 2014/06/04 16:05:55 bicatali Exp $
+
+EAPI=5
+
+FORTRAN_NEEDED=fortran
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils eutils fortran-2 flag-o-matic toolchain-funcs multilib
+
+MY_P=${PN}-${PV/_p/-patch}
+
+DESCRIPTION="General purpose library and file format for storing scientific data"
+HOMEPAGE="http://www.hdfgroup.org/HDF5/"
+SRC_URI="http://www.hdfgroup.org/ftp/HDF5/releases/${MY_P}/src/${MY_P}.tar.bz2"
+
+LICENSE="NCSA-HDF"
+SLOT="0/${PV%%_p*}"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="cxx debug examples fortran fortran2003 mpi static-libs szip threads zlib"
+
+REQUIRED_USE="
+ cxx? ( !mpi ) mpi? ( !cxx )
+ threads? ( !cxx !mpi !fortran )
+ fortran2003? ( fortran )"
+
+RDEPEND="
+ mpi? ( virtual/mpi[romio] )
+ szip? ( >=sci-libs/szip-2.1:0= )
+ zlib? ( sys-libs/zlib:0= )"
+
+DEPEND="${RDEPEND}
+ sys-devel/libtool:2
+ >=sys-devel/autoconf-2.69"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.9-static_libgfortran.patch
+ "${FILESDIR}"/${PN}-1.8.9-mpicxx.patch
+ "${FILESDIR}"/${PN}-1.8.13-no-messing-ldpath.patch
+ "${FILESDIR}"/${PN}-1.8.13-implicits.patch
+)
+
+pkg_setup() {
+ tc-export CXX CC AR # workaround for bug 285148
+ if use fortran; then
+ use fortran2003 && FORTRAN_STANDARD=2003
+ fortran-2_pkg_setup
+ fi
+ if use mpi; then
+ if has_version 'sci-libs/hdf5[-mpi]'; then
+ ewarn "Installing hdf5 with mpi enabled with a previous hdf5 with mpi disabled may fail."
+ ewarn "Try to uninstall the current hdf5 prior to enabling mpi support."
+ fi
+ export CC=mpicc
+ use fortran && export FC=mpif90
+ elif has_version 'sci-libs/hdf5[mpi]'; then
+ ewarn "Installing hdf5 with mpi disabled while having hdf5 installed with mpi enabled may fail."
+ ewarn "Try to uninstall the current hdf5 prior to disabling mpi support."
+ fi
+}
+
+src_prepare() {
+ # respect gentoo examples directory
+ sed \
+ -e "s:hdf5_examples:doc/${PF}/examples:g" \
+ -i $(find . -name Makefile.am) $(find . -name "run*.sh.in") || die
+ sed \
+ -e '/docdir/d' \
+ -i config/commence.am || die
+ if ! use examples; then
+ sed -e '/^install:/ s/install-examples//' \
+ -i Makefile.am || die #409091
+ fi
+ # enable shared libs by default for h5cc config utility
+ sed -i -e "s/SHLIB:-no/SHLIB:-yes/g" tools/misc/h5cc.in || die
+ # bug #419677
+ use prefix && \
+ append-ldflags -Wl,-rpath,"${EPREFIX}"/usr/$(get_libdir) \
+ -Wl,-rpath,"${EPREFIX}"/$(get_libdir)
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-production
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --enable-deprecated-symbols
+ $(use_enable prefix sharedlib-rpath)
+ $(use_enable debug debug all)
+ $(use_enable debug codestack)
+ $(use_enable cxx)
+ $(use_enable fortran)
+ $(use_enable fortran2003)
+ $(use_enable mpi parallel)
+ $(use_enable threads threadsafe)
+ $(use_with szip szlib)
+ $(use_with threads pthread)
+ $(use_with zlib)
+ )
+ autotools-utils_src_configure
+}
diff --git a/sci-libs/hdf5/metadata.xml b/sci-libs/hdf5/metadata.xml
index 0267d6039ebe..a7c6921a2f93 100644
--- a/sci-libs/hdf5/metadata.xml
+++ b/sci-libs/hdf5/metadata.xml
@@ -1,19 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <maintainer>
- <email>xarthisius@gentoo.org</email>
- <name>Kacper Kowalik</name>
- </maintainer>
- <longdescription>
- HDF5 is a file format and library for storing scientific data. HDF5
- was designed and implemented to address the deficiencies of HDF4.x. It
- has a more powerful and flexible data model, supports files larger
- than 2 GB, and supports parallel I/O.
- </longdescription>
- <use>
- <flag name="fortran2003">enable new features that require Fortran 2003
- (http://www.hdfgroup.org/HDF5/doc/fortran/NewFeatures_F2003.pdf)</flag>
- </use>
+<herd>sci</herd>
+<maintainer>
+ <email>xarthisius@gentoo.org</email>
+ <name>Kacper Kowalik</name>
+</maintainer>
+<longdescription>
+ HDF5 is a file format and library for storing scientific data. HDF5
+ was designed and implemented to address the deficiencies of HDF4.x. It
+ has a more powerful and flexible data model, supports files larger
+ than 2 GB, and supports parallel I/O.
+</longdescription>
+<use>
+ <flag name="fortran2003">Enable new features that require Fortran 2003
+ (http://www.hdfgroup.org/HDF5/doc/fortran/NewFeatures_F2003.pdf)</flag>
+</use>
</pkgmetadata>