summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-10 18:29:14 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-10 18:29:14 +0000
commit5f000c39f6e8f94f6b6408857793663c57339600 (patch)
tree1445614f581d258204433658dcf3b318f4695472 /sci-libs
parent0.9.43 version bump. (diff)
downloadgentoo-2-5f000c39f6e8f94f6b6408857793663c57339600.tar.gz
gentoo-2-5f000c39f6e8f94f6b6408857793663c57339600.tar.bz2
gentoo-2-5f000c39f6e8f94f6b6408857793663c57339600.zip
convert to multilib
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/djbfft/ChangeLog7
-rw-r--r--sci-libs/djbfft/djbfft-0.76-r2.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/sci-libs/djbfft/ChangeLog b/sci-libs/djbfft/ChangeLog
index b7b7e8ee88ff..35fe64442932 100644
--- a/sci-libs/djbfft/ChangeLog
+++ b/sci-libs/djbfft/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/djbfft
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/djbfft/ChangeLog,v 1.20 2013/01/14 10:05:22 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/djbfft/ChangeLog,v 1.21 2013/08/10 18:29:14 aballier Exp $
+
+*djbfft-0.76-r2 (10 Aug 2013)
+
+ 10 Aug 2013; Alexis Ballier <aballier@gentoo.org> +djbfft-0.76-r2.ebuild:
+ convert to multilib
14 Jan 2013; Justin Lecher <jlec@gentoo.org> -djbfft-0.76.ebuild,
metadata.xml:
diff --git a/sci-libs/djbfft/djbfft-0.76-r2.ebuild b/sci-libs/djbfft/djbfft-0.76-r2.ebuild
new file mode 100644
index 000000000000..0a5aeffd3c02
--- /dev/null
+++ b/sci-libs/djbfft/djbfft-0.76-r2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/djbfft/djbfft-0.76-r2.ebuild,v 1.1 2013/08/10 18:29:14 aballier Exp $
+
+EAPI=5
+inherit eutils flag-o-matic toolchain-funcs multilib multilib-minimal
+
+DESCRIPTION="Extremely fast library for floating-point convolution"
+HOMEPAGE="http://cr.yp.to/djbfft.html"
+SRC_URI="http://cr.yp.to/djbfft/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+DOCS=( CHANGES README TODO VERSION )
+
+src_prepare() {
+ SOVER="${PV:0:1}.${PV:2:1}.${PV:3:1}" # a.bc -> a.b.c
+ # mask out everything, which is not suggested by the author (RTFM)!
+ ALLOWED_FLAGS="-fstack-protector -march -mcpu -pipe -mpreferred-stack-boundary -ffast-math"
+ strip-flags
+
+ SONAME="libdjbfft.so.${SOVER}"
+
+ epatch \
+ "${FILESDIR}"/${P}-gcc3.patch \
+ "${FILESDIR}"/${P}-shared.patch \
+ "${FILESDIR}"/${P}-headers.patch
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ [[ ${ABI} == x86* ]] && append-cflags -malign-double
+
+ sed -i -e "s:\"lib\":\"$(get_libdir)\":" hier.c || die
+ echo "$(tc-getCC) ${CFLAGS} -fPIC" > "conf-cc"
+ echo "$(tc-getCC) ${LDFLAGS}" > "conf-ld"
+ echo "${ED}usr" > "conf-home"
+ einfo "conf-cc: $(<conf-cc)"
+}
+
+multilib_src_compile() {
+ emake \
+ LIBDJBFFT=${SONAME} \
+ LIBPERMS=0755 \
+ ${SONAME}
+ echo "the compile function was:"
+ cat ./compile
+ echo "the conf-ld function was:"
+ cat ./conf-ld
+}
+
+multilib_src_test() {
+ local t
+ for t in accuracy accuracy2 speed; do
+ emake ${t}
+ einfo "Testing ${t}"
+ LD_LIBRARY_PATH=. ./${t} > ${t}.out || die "test ${t} failed"
+ done
+}
+
+multilib_src_install() {
+ emake LIBDJBFFT=${SONAME} install
+ ./install || die "install failed"
+ dosym ${SONAME} /usr/$(get_libdir)/libdjbfft.so
+ dosym ${SONAME} /usr/$(get_libdir)/libdjbfft.so.${SOVER%%.*}
+}