summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-22 07:01:22 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-22 07:01:22 +0000
commit6e343b28d392ff4968bc461c894c95b83b31e3eb (patch)
treefa832abb4831c93678f7bfbf5ce816a7128e69af /sci-libs
parentLDFLAGS respected, fix parallel make issue (diff)
downloadgentoo-2-6e343b28d392ff4968bc461c894c95b83b31e3eb.tar.gz
gentoo-2-6e343b28d392ff4968bc461c894c95b83b31e3eb.tar.bz2
gentoo-2-6e343b28d392ff4968bc461c894c95b83b31e3eb.zip
revert old version
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/pgplot/pgplot-5.2.2-r3.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/sci-libs/pgplot/pgplot-5.2.2-r3.ebuild b/sci-libs/pgplot/pgplot-5.2.2-r3.ebuild
index 1c6d4704a108..5bb0c3bddd8e 100644
--- a/sci-libs/pgplot/pgplot-5.2.2-r3.ebuild
+++ b/sci-libs/pgplot/pgplot-5.2.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/pgplot/pgplot-5.2.2-r3.ebuild,v 1.6 2010/05/22 06:50:38 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/pgplot/pgplot-5.2.2-r3.ebuild,v 1.7 2010/05/22 07:01:22 jlec Exp $
EAPI=2
inherit eutils toolchain-funcs
@@ -28,7 +28,6 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-makemake.patch
epatch "${FILESDIR}"/${PN}-compile-setup.patch
epatch "${FILESDIR}"/${PN}-headers.patch
- epatch "${FILESDIR}"/${PN}-ldflags.patch
# gfortran < 4.3 does not compile gif, pp and wd drivers
if [[ "$(tc-getFC)" == gfortran ]] &&
@@ -81,7 +80,7 @@ src_compile() {
./makemake . linux
einfo "Doing static libs and execs"
emake all cpg || die "emake static failed"
- emake -j1 clean
+ emake clean
einfo "Doing shared libs"
emake \
CFLAGS="${CFLAGS} -fPIC" \
@@ -98,7 +97,7 @@ src_compile() {
fi
# this just cleans out not needed files
- emake -j1 clean
+ emake clean
}
src_test() {