summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-21 21:20:21 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-21 21:20:21 +0000
commit766bb20612a29ac3aa888058bafa0f19c250b884 (patch)
tree82978a8ab6a2c6297fb4c9cba3e1f809c44b65db /sci-libs
parentStable for ppc, wrt bug #458188 (diff)
downloadgentoo-2-766bb20612a29ac3aa888058bafa0f19c250b884.tar.gz
gentoo-2-766bb20612a29ac3aa888058bafa0f19c250b884.tar.bz2
gentoo-2-766bb20612a29ac3aa888058bafa0f19c250b884.zip
sci-libs/umfpack: Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/umfpack/ChangeLog8
-rw-r--r--sci-libs/umfpack/metadata.xml12
-rw-r--r--sci-libs/umfpack/umfpack-5.2.0.ebuild8
-rw-r--r--sci-libs/umfpack/umfpack-5.5.2.ebuild8
-rw-r--r--sci-libs/umfpack/umfpack-5.6.1-r1.ebuild8
5 files changed, 24 insertions, 20 deletions
diff --git a/sci-libs/umfpack/ChangeLog b/sci-libs/umfpack/ChangeLog
index 3c29bbeb04be..8f32cde9c81a 100644
--- a/sci-libs/umfpack/ChangeLog
+++ b/sci-libs/umfpack/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/umfpack
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/umfpack/ChangeLog,v 1.42 2012/11/21 23:56:14 bicatali Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/umfpack/ChangeLog,v 1.43 2013/02/21 21:20:21 jlec Exp $
+
+ 21 Feb 2013; Justin Lecher <jlec@gentoo.org> umfpack-5.2.0.ebuild,
+ umfpack-5.5.2.ebuild, umfpack-5.6.1-r1.ebuild, metadata.xml:
+ Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config
21 Nov 2012; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
umfpack-5.6.1-r1.ebuild:
diff --git a/sci-libs/umfpack/metadata.xml b/sci-libs/umfpack/metadata.xml
index 29f71ca077a0..314c6c20a456 100644
--- a/sci-libs/umfpack/metadata.xml
+++ b/sci-libs/umfpack/metadata.xml
@@ -1,17 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
UMFPACK is a set of routines for solving unsymmetric sparse linear
systems, Ax=b, using the Unsymmetric MultiFrontal method.
Includes a C-callable interface, and a Fortran-callable interface.
MATLAB routines are not included in the Gentoo package.
</longdescription>
-<use>
- <flag name="cholmod">Use <pkg>sci-libs/cholmod</pkg> for matrix
+ <use>
+ <flag name="cholmod">Use <pkg>sci-libs/cholmod</pkg> for matrix
ordering</flag>
- <flag name="metis">Use METIS via (<pkg>sci-libs/cholmod</pkg>)
+ <flag name="metis">Use METIS via (<pkg>sci-libs/cholmod</pkg>)
for matrix partitioning</flag>
-</use>
+ </use>
</pkgmetadata>
diff --git a/sci-libs/umfpack/umfpack-5.2.0.ebuild b/sci-libs/umfpack/umfpack-5.2.0.ebuild
index e62c2a4708a3..53ec2593c5c8 100644
--- a/sci-libs/umfpack/umfpack-5.2.0.ebuild
+++ b/sci-libs/umfpack/umfpack-5.2.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/umfpack/umfpack-5.2.0.ebuild,v 1.17 2012/10/16 19:17:03 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/umfpack/umfpack-5.2.0.ebuild,v 1.18 2013/02/21 21:20:21 jlec Exp $
-inherit autotools eutils fortran-2
+inherit autotools eutils fortran-2 toolchain-funcs
MY_PN=UMFPACK
@@ -32,7 +32,7 @@ src_unpack() {
src_compile() {
econf \
- --with-blas="$(pkg-config --libs blas)"
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
emake || die "emake failed"
}
diff --git a/sci-libs/umfpack/umfpack-5.5.2.ebuild b/sci-libs/umfpack/umfpack-5.5.2.ebuild
index de1a3bf7ab69..0a27dd29521f 100644
--- a/sci-libs/umfpack/umfpack-5.5.2.ebuild
+++ b/sci-libs/umfpack/umfpack-5.5.2.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/umfpack/umfpack-5.5.2.ebuild,v 1.6 2012/10/16 19:17:03 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/umfpack/umfpack-5.5.2.ebuild,v 1.7 2013/02/21 21:20:21 jlec Exp $
EAPI=4
AUTOTOOLS_AUTORECONF=yes
-inherit autotools-utils fortran-2
+inherit autotools-utils fortran-2 toolchain-funcs
MY_PN=UMFPACK
@@ -33,7 +33,7 @@ S="${WORKDIR}/${MY_PN}"
src_configure() {
myeconfargs+=(
- --with-blas="$(pkg-config --libs blas)"
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
$(use_with metis cholmod)
)
autotools-utils_src_configure
diff --git a/sci-libs/umfpack/umfpack-5.6.1-r1.ebuild b/sci-libs/umfpack/umfpack-5.6.1-r1.ebuild
index 9fe76cd9f708..7a4c7a5e4414 100644
--- a/sci-libs/umfpack/umfpack-5.6.1-r1.ebuild
+++ b/sci-libs/umfpack/umfpack-5.6.1-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/umfpack/umfpack-5.6.1-r1.ebuild,v 1.2 2012/11/21 23:56:14 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/umfpack/umfpack-5.6.1-r1.ebuild,v 1.3 2013/02/21 21:20:21 jlec Exp $
EAPI=4
-inherit autotools-utils
+inherit autotools-utils toolchain-funcs
DESCRIPTION="Unsymmetric multifrontal sparse LU factorization library"
HOMEPAGE="http://www.cise.ufl.edu/research/sparse/umfpack"
@@ -26,7 +26,7 @@ DEPEND="${RDEPEND}
src_configure() {
local myeconfargs+=(
- --with-blas="$(pkg-config --libs blas)"
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
$(use_with doc)
$(use_with cholmod)
)